c9d2c0c054
- Now fetch and install automatically the data file needed by xrmap and a lot of goodies. - A lot of improvement since 2.10 - A lot of bug fix since 2.10 PR: ports/50492 Submitted by: Serge Gagnon <gagnon__s@videotron.ca>
27 lines
1.1 KiB
Plaintext
27 lines
1.1 KiB
Plaintext
--- editkit/Makefile.orig Sun Dec 15 02:50:09 2002
|
|
+++ editkit/Makefile Mon Mar 17 17:01:38 2003
|
|
@@ -12,10 +12,11 @@
|
|
# TWOBUTN paste with button3 click, set selection with button3 drag
|
|
# MINIMAL to remove bak files, /usr/share/edmtx and e**rc
|
|
# TLL for Terry Loveall personal settings
|
|
+PREFIX=/usr/X11R6
|
|
+SHARE_DIR=$(PREFIX)/share/editkit
|
|
+INCLUDES=-I$(PREFIX)/include
|
|
|
|
-SHARE_DIR=/usr/share/editkit
|
|
-
|
|
-CFLAGS = -O2 -fomit-frame-pointer -pipe -Wall -DTHREED -DNOEDIT -DGREEK -DJUSTIFY -DSHARE_DIR="\"$(SHARE_DIR)\""
|
|
+CFLAGS = -O2 $(INCLUDES) -fomit-frame-pointer -pipe -Wall -DTHREED -DNOEDIT -DGREEK -DJUSTIFY -DSHARE_DIR="\"$(SHARE_DIR)\""
|
|
|
|
#CFLAGS = -O2 -fomit-frame-pointer -pipe -Wall -DMINIMAL -DTWOBUTN -DVERTCURS -DTLL
|
|
|
|
@@ -63,7 +64,7 @@
|
|
if [ -x edt ]; then cp -f edt /usr/bin; fi
|
|
if [ -x emt ]; then cp -f emt /usr/bin; fi
|
|
if [ -x edx ]; then cp -f edx /usr/X11R6/bin; fi
|
|
- if [ -x emx ]; then cp -f emx /usr/X11R6/bin; fi
|
|
+ if [ -x emx ]; then cp -f emx $(PREFIX)/bin; fi
|
|
mkdir -p $(SHARE_DIR)
|
|
cp -f rc.example $(SHARE_DIR)/rc.common
|
|
cp -f README $(SHARE_DIR)
|