d619684901
PR: 27650 Submitted by: marcus@marcuscom.com Reviewed by: will
44 lines
1.3 KiB
Plaintext
44 lines
1.3 KiB
Plaintext
--- configure.in.orig Tue Apr 17 19:00:52 2001
|
|
+++ configure.in Thu Jun 7 13:49:53 2001
|
|
@@ -234,9 +234,6 @@
|
|
AC_CHECK_TYPE(offset_t,loff_t)
|
|
AC_CHECK_TYPE(ssize_t, int)
|
|
|
|
-# we need libcups for CUPS support...
|
|
-AC_CHECK_LIB(cups,httpConnect)
|
|
-
|
|
# we need libdl for PAM and the new VFS code
|
|
AC_CHECK_LIB(dl,main)
|
|
|
|
@@ -1258,7 +1255,7 @@
|
|
--without-krb5 Don't include Kerberos 5 support (default)],
|
|
[ AC_MSG_RESULT(yes)
|
|
AC_DEFINE(KRB5_AUTH)
|
|
- LIBS="$LIBS -ldes425 -lkrb5 -lcrypto -lcom_err"
|
|
+ LIBS="$LIBS -ldes425 -lkrb5 -lk5crypto -lcom_err"
|
|
CFLAGS="$CFLAGS -I$withval/include"
|
|
LDFLAGS="$LDFLAGS -L$withval/lib"],
|
|
AC_MSG_RESULT(no)
|
|
@@ -1486,6 +1483,21 @@
|
|
esac ],
|
|
AC_MSG_RESULT(no)
|
|
)
|
|
+
|
|
+#################################################
|
|
+# check for CUPS printing support
|
|
+AC_MSG_CHECKING(whether to use CUPS printing)
|
|
+AC_ARG_WITH(cups,
|
|
+[ --with-cups=base-dir Include CUPS printing support
|
|
+ --without-cups Don't include CUPS printing support (default)],
|
|
+[ AC_MSG_RESULT(yes)
|
|
+ LIBS="$LIBS -lcups"
|
|
+ CFLAGS="$CFLAGS -I$withval/include"
|
|
+ LDFLAGS="$LDFLAGS -L$withval/lib"
|
|
+ AC_CHECK_LIB(cups,httpConnect)],
|
|
+ AC_MSG_RESULT(no)
|
|
+)
|
|
+
|
|
|
|
#################################################
|
|
# check for experimental disk-quotas support
|