8e5f24b770
- Update to 2.32 - Respect ${CC}, ${CFLAGS}, ${NOPORTDOCS}, ${DOCSDIR} and ${EXAMPLESDIR} - Pass maintainership to submitter Moreover: - In order to ensure proper permissions/ownerships/stripping, override the vendor install and use ${INSTALL_*} instead - Group distfiles by using ${DIST_SUBDIR} [1]: PR: ports/88070 Submitted by: Serge Gagnon <serge.gagnon@b2b2c.ca> (new maintainer)
12 lines
432 B
Plaintext
12 lines
432 B
Plaintext
--- earthview/Makefile.orig Thu Jul 14 23:16:30 2005
|
|
+++ earthview/Makefile Thu Oct 27 11:52:21 2005
|
|
@@ -8,7 +8,7 @@
|
|
all: earthview
|
|
|
|
earthview: earthview.c
|
|
- gcc -Wall -DDATADIR=\"$(DATADIR)\" earthview.c -o earthview -L/usr/X11R6/lib -lX11 -lm -lz -lbz2
|
|
+ $(CC) $(CFLAGS) -DDATADIR=\"$(DATADIR)\" earthview.c -o earthview -I$(X11BASE)/include -L$(X11BASE)/lib -lX11 -lm -lz -lbz2
|
|
|
|
install:
|
|
install -c -s earthview $(BINDIR)
|