freebsd-ports/games/xtruco/files/patch-aa
Justin M. Seger b56e7b2654 Import of xtruco-1.0.
This is XTruco  -  simple version for X Windows
of the famous card game named Super Truco.

PR:		6007
Submitted by:	andy@icc.surw.chel.su
1998-03-15 17:11:24 +00:00

33 lines
827 B
Plaintext

--- Makefile Mon Oct 21 19:18:27 1996
+++ /home/andy/tmp/wrk/Makefile Sat Mar 14 20:08:33 1998
@@ -6,17 +6,17 @@
# #
################################
-INCLUDES = -I/usr/X11/include
+INCLUDES = -I/usr/X11R6/include
# Remove '-DIPC_OK' if you have problems with 'shared-memory' (IPC routines)
OPC = -DIPC_OK
-LIBRARIES = -lX11 -L/usr/X11/lib
+LIBRARIES = -lX11 -L/usr/X11R6/lib
CFILES = xtruco.c bitmap.c cursor.c display.c event.c gc.c pixmap.c\
topwind.c window.c color.c button.c font.c read.c
-CC = gcc -O2 -g -Dlinux -DX11R6 $(INCLUDES) $(OPC)
+CC = gcc -DX11R6 $(INCLUDES) $(OPC)
PROG=xtruco
@@ -25,7 +25,7 @@
OBJS=$(CFILES:.c=.o)
all: $(OBJS)
- $(CC) -o $(PROG) $(LIBRARIES) $(OBJS)
+ $(CC) ${CFLAGS} -o $(PROG) $(LIBRARIES) $(OBJS)
# strip ${PROG}
clean: