freebsd-ports/databases/sqsh/files/patch-ab
Mikhail Teterin 26c59a87d0 Reset maintainership to ports, due to the original author's
timeout (the previous timeout also noted in the cvs-log -- 2
years ago). Upgrade to the latest sqsh-2.1. Build with readline
and motif, unless WITHOUT_X11 is set (plain --with-x results in
a rather hard to use X support, author recommend Motif too).

Remove the bogus dependency on gettext introduced in Makefile
version 1.2 -- the (unpatched) software will, indeed, link with
libintl, if present -- mistaking it for Sybase OpenClient's
libintl.

Install the system-wide sqshrc as ${PREFIX}/etc/sqshrc.default,
and allow for another system-wide ${PREFIX}/etc/sqshrc to
overwrite some or all of the default settings.

PR:	ports/40374	(readline and X/Motif)
2002-10-15 13:18:00 +00:00

36 lines
827 B
Plaintext

--- configure Fri Nov 9 14:58:04 2001
+++ configure Tue Oct 15 13:51:29 2002
@@ -1106,4 +1106,8 @@
SYBASE_LIBS=
+ if test "$SYBASE_VERSION" = "FreeTDS"
+ then
+ SYBASE_LIBS="-lct -ltds"
+ else
#
# Check for -lblk
@@ -1152,9 +1156,4 @@
fi
- #
- # Check for -ltds (FreeTDS project)
- #
- if test -f $SYBASE_LIBDIR/libtds.a; then
- SYBASE_LIBS="$SYBASE_LIBS -ltds"
fi
@@ -1196,5 +1195,5 @@
ncr*)
SYBASE_OS="-ldl -lm";;
- sunos*)
+ sunos*|*bsd*)
SYBASE_OS="-lm";;
solaris*)
@@ -2691,5 +2690,5 @@
cat >> $CONFIG_STATUS <<EOF
-CONFIG_FILES=\${CONFIG_FILES-"Makefile src/Makefile scripts/install.sh scripts/make_wrapper.sh"}
+CONFIG_FILES=\${CONFIG_FILES-"Makefile src/Makefile scripts/install.sh scripts/make_wrapper.sh doc/global.sqshrc"}
EOF
cat >> $CONFIG_STATUS <<\EOF