freebsd-ports/audio/cpige/distinfo
Edwin Groothuis db520879e2 re-roll of tarball
Only in cpige-1.3-new/: LICENCE
Only in cpige-1.3-new/: Makefile.windows
diff -ru cpige/cpige.c cpige-1.3-new/cpige.c
--- cpige/cpige.c	Fri Nov 25 10:08:13 2005
+++ cpige-1.3-new/cpige.c	Wed Nov 30 07:06:12 2005
@@ -21,7 +21,10 @@
 #include <fcntl.h>
 #include <dirent.h>
 #include <sys/stat.h>
-#include <regex.h>
+
+#ifndef WIN32
+ #include <regex.h>
+#endif

 #include "cpige.h"
 #include "tool.h"
@@ -115,12 +118,12 @@

   /* Global dynamic configuration */
   cmdLine = parseCommandLine(argc, argv);
-  (void) testCommandLine();
+  testCommandLine();

   /* Logfile */
   if ((logfile = fopen(cmdLine->logFile, "a+")) == NULL)
   {
-    ERROR("Unable to openlogfile: %s Setting log to stdout\n", cmdLine->logFile);
+    _ERROR("Unable to openlogfile: %s Setting log to stdout\n", cmdLine->logFile);
     logfile = stdout;
   } else {
     VERBOSE("Successfully opened %s\n", cmdLine->logFile);
@@ -134,20 +137,20 @@
 #if !WIN32
     if (daemon(1, 1) == -1)
     {
-      ERROR("Error daemonizing. %s\n", strerror(errno));
+      _ERROR("Error daemonizing. %s\n", strerror(errno));
       exit(-1);
     }
-    (void) fprintf(stdout, "Server launching in background. pid: %d\n", (int)getpid());
+    fprintf(stdout, "Server launching in background. pid: %d\n", (int)getpid());
     fd = open("/dev/null", O_RDWR);
     if (fd == -1) {
       perror("Opening /dev/null: ");
       exit(0);
     }
     for (i = 0; i < 3; i++)
-      (void) dup2(fd, i);
-    (void) close(fd);
+      dup2(fd, i);
+    close(fd);
 #else
-   (void) printf("Fork not available on WIN32.\n");
+   printf("Fork not available on WIN32.\n");
 #endif
   }

@@ -158,13 +161,13 @@
   /* Create output dir if does not exists! */
   if (( pige_dir = opendir(cmdLine->dir)) == NULL)
   {
-    ERROR("Unable to open %s for writing\n", cmdLine->dir);
+    _ERROR("Unable to open %s for writing\n", cmdLine->dir);
 #ifdef WIN32
     if (mkdir(cmdLine->dir) != 0) {
 #else
     if (mkdir(cmdLine->dir, 0755) != 0) {
 #endif
-      ERROR("Failed trying to create %s. Verify rights.\n", cmdLine->dir);
+      _ERROR("Failed trying to create %s. Verify rights.\n", cmdLine->dir);
       exit(-1);
     } else {
       VERBOSE("Created %s\n", cmdLine->dir);
@@ -172,7 +175,7 @@
     }
   } else {
     VERBOSE("Sucessfully opened %s\n", cmdLine->dir);
-    (void) closedir(pige_dir);
+    closedir(pige_dir);
   }

   /* Start time, for uptime calculation */
@@ -204,13 +207,15 @@
    * print_icyheaders(icy_headers);
    */

+#ifndef WIN32
   if(cmdLine->useNumbers == 1)
     songs = getSongs(cmdLine->dir);
-
+#endif
+
   nextsize = 512;

   oldtitre = memory_allocation(strlen("please.delete") + 1);
-  (void) strcpy(oldtitre, "please.delete");
+  strncpy(oldtitre, "please.delete", 14);

   while (1)
   {
@@ -220,7 +225,7 @@
     retval = select(server_socket+1, &rfds, NULL, NULL, &timeout);
     if (retval <= 0)
     {
-      ERROR("Connection Error.\n");
+      _ERROR("Connection Error.\n");
       server_close(server_socket);
       server_socket = reconnect(RECONNECT_TIME, TENTATIVES, 1);
       tempsize = 0;
@@ -230,7 +235,7 @@
     size = recv(server_socket, buffer, nextsize, 0);
     if ((size == -1) || ((size == 0) && nextsize != 0))
     {
-      ERROR("Connection error in recv main() size: %d nextsize: %d\n", size, nextsize);
+      _ERROR("Connection error in recv main() size: %d nextsize: %d\n", size, nextsize);
       server_socket = reconnect(RECONNECT_TIME, TENTATIVES, 1);
       tempsize = 0;
       nextsize = 512;
@@ -240,11 +245,11 @@
     {
       if (fwrite(buffer, sizeof(char), size, output_file) != size*sizeof(char))
       {
-        ERROR("Error writing output. Disk full ?\n");
+        _ERROR("Error writing output. Disk full ?\n");
         break;
       }
       /* Many thanks to the #hurdfr team! */
-      (void) fflush(output_file);
+      fflush(output_file);
     }
     if ( tempsize == icy_headers->metaint )
     {
@@ -275,15 +280,15 @@

             buffer3 = GetId3v1(buffer2, buffer1, icy_headers->name);
             fwrite(buffer3, sizeof(char), 128, output_file);
-            free(buffer3);
-            free(buffer2);
-            free(buffer1);
+            (void)free(buffer3);
+            (void)free(buffer2);
+            (void)free(buffer1);
           }

           if (output_file)
           {
             /* VERBOSE("Closing: %d.mp3\n", lastCut.hour); */
-            (void) fclose(output_file);
+            fclose(output_file);
           }

           switch (cmdLine->intervalType)
@@ -313,10 +318,10 @@
           }
           VERBOSE("Opening: %s\n", filename);
           output_file = fopen(filename, WRITE);
-          free(filename);
+          (void)free(filename);
         }
       } else if (cmdLine->live) {
-        (void) printf("Not yet implemented.\n");
+        printf("Not yet implemented.\n");
         exit(1);
         /* Live Mode */
         /* I must write some stuff here ;) */
@@ -337,13 +342,13 @@
           fprintf(stdout, " ");

         statusline = statusLine(uptime, metacounter, icy_headers->metaint, oldtitre, nexttitre);
-        (void) fprintf(stdout, "\r%s", statusline);
+        fprintf(stdout, "\r%s", statusline);

         if ( strlen(statusline) > maxlinelength)
           maxlinelength = strlen(statusline);

         if (statusline != NULL)
-          free(statusline);
+          (void)free(statusline);
       }

       /* Stats evry countdown seconds */
@@ -354,12 +359,12 @@
         {
           if (fwrite(statusline, sizeof(char), strlen(statusline), logfile) != strlen(statusline))
           {
-            ERROR("Fwrite error.\n");
+            _ERROR("Fwrite error.\n");
             break;
           }
           /* Many thanks to the #hurdfr@freenode team! */
-          (void) fflush(logfile);
-          (void) free(statusline);
+          fflush(logfile);
+          (void)free(statusline);
         } else {
           VERBOSE("getStats returned NULL values...\n");
         }
@@ -379,7 +384,7 @@
       titre = getTitle(meta);

       if (meta != NULL)
-        free(meta);
+        (void)free(meta);

       if (titre != NULL)
       {
@@ -408,19 +413,19 @@
                     {
                       char *buffer1;
                       buffer1 = GetId3v1(curSong->title, curSong->artist, icy_headers->name);
-                      (void) fwrite(buffer1, sizeof(char), 128, output_file);
-                      free(buffer1);
+                      fwrite(buffer1, sizeof(char), 128, output_file);
+                      (void)free(buffer1);
                     }
-                    (void) fclose(output_file);
+                    fclose(output_file);
                   }

                   if (cmdLine->useNumbers == 0)
                   {
                     filename = memory_allocation(strlen(titre) + strlen(cmdLine->dir)+ 1 + strlen(extension) + 1 +1);
-                    (void) snprintf(filename, strlen(titre)+strlen(extension)+strlen(cmdLine->dir)+1+1, "%s%s.%s", cmdLine->dir, titre, extension);
+                    snprintf(filename, strlen(titre)+strlen(extension)+strlen(cmdLine->dir)+1+1, "%s%s.%s", cmdLine->dir, titre, extension);
                   } else {
                     filename = memory_allocation(5+strlen(titre) + strlen(cmdLine->dir)+ 1 + strlen(extension) + 1 + 1);
-                    (void) snprintf(filename, 5+strlen(titre)+strlen(extension)+strlen(cmdLine->dir)+1+1, "%s%.4d_%s.%s", cmdLine->dir, songs, titre, extension);
+                    snprintf(filename, 5+strlen(titre)+strlen(extension)+strlen(cmdLine->dir)+1+1, "%s%.4d_%s.%s", cmdLine->dir, songs, titre, extension);
                   }

                   if ((output_file = fopen(filename, "r")) == NULL) { /* Anti doublons */
@@ -428,31 +433,33 @@
                     output_file = fopen(filename, WRITE);
                   } else {
                     VERBOSE("File already exists %s.\n", filename);
-                    (void) fclose(output_file);
+                    fclose(output_file);
                     output_file = NULL;
                   }
-                  (void) free(filename);
+                  (void)free(filename);
                 }
               } /* Title are differents */
             } /* Oldtitre != NULL */
-            if (oldtitre != NULL) free(oldtitre);
+            if (oldtitre != NULL)
+              (void)free(oldtitre);
             oldtitre = memory_allocation(strlen(titre) + 1);
-            (void) strncpy(oldtitre, titre, strlen(titre));
+            strncpy(oldtitre, titre, strlen(titre));
           } else {
             /* Title is "ASUIVRE" */
-            if (nexttitre != NULL) free(nexttitre);
+            if (nexttitre != NULL)
+              (void)free(nexttitre);

             nexttitre = memory_allocation(strlen(titre) + 1);
-            (void) strncpy(nexttitre, titre, strlen(titre));
+            strncpy(nexttitre, titre, strlen(titre));
           }
           if (titre != NULL)
-            free(titre);
+            (void)free(titre);

         } /* Strlen(titre > 0) */
       }
       tempsize = 0; /* tempsize = 0: chunk received successfully. Awaiting next chunk */
     } else if (tempsize > icy_headers->metaint) {
-      ERROR("Error tempsize > metaint\n");
+      _ERROR("Error tempsize > metaint\n");
       break;
     } else
       tempsize = tempsize + size;
@@ -463,14 +470,18 @@
       nextsize = 512;
   } /* infinite loop */

-  (void) server_close(server_socket);
+  server_close(server_socket);

   /* cleanup */
-  if (icy_headers != NULL) free(icy_headers);
-  if (output_file != NULL) fclose(output_file);
-  if (logfile != stdout) fclose(logfile);
-  (void) free(cmdLine);
-  (void) free(cPigeStats);
+  if (icy_headers != NULL)
+    (void)free(icy_headers);
+  if (output_file != NULL)
+    fclose(output_file);
+  if (logfile != stdout)
+    fclose(logfile);
+
+  (void)free(cmdLine);
+  (void)free(cPigeStats);

   return 0;
 }
@@ -491,9 +502,10 @@
   suffix[0] = 0;

   icy = malloc(sizeof(icyHeaders));
-
+
   /* Usefull when radio doesn't specify icy name */
   icy->name = "No Name";
+  icy->content_type = "audio/mpeg";

   if (headers == NULL)
     return NULL;
@@ -549,7 +561,7 @@
       if (strncmp(prefix, "icy-notice1", 11) == 0)
       {
         icy->notice1 = memory_allocation(strlen(suffix) + 1);
-        (void) strncpy(icy->notice1, suffix, strlen(suffix));
+        strncpy(icy->notice1, suffix, strlen(suffix));
       }
       if (strncmp(prefix, "icy-notice2", 11) == 0)
       {
@@ -557,25 +569,25 @@
           icy->type = 0;

         icy->notice2 = memory_allocation(strlen(suffix)+1);
-        (void) strncpy(icy->notice2, suffix, strlen(suffix));
+        strncpy(icy->notice2, suffix, strlen(suffix));
       }

       if (strncmp(prefix, "icy-name", 8) == 0)
       {
         icy->name = memory_allocation(strlen(suffix)+1);
-        (void) strncpy(icy->name, suffix, strlen(suffix));
+        strncpy(icy->name, suffix, strlen(suffix));
       }

       if (strncmp(prefix, "icy-genre", 9) == 0)
       {
         icy->genre = memory_allocation(strlen(suffix)+1);
-        (void) strncpy(icy->genre, suffix, strlen(suffix));
+        strncpy(icy->genre, suffix, strlen(suffix));
       }

       if (strncmp(prefix, "icy-url", 7) == 0)
       {
         icy->url = memory_allocation(strlen(suffix)+1);
-        (void) strncpy(icy->url, suffix, strlen(suffix));
+        strncpy(icy->url, suffix, strlen(suffix));
       }

       if (strncmp(prefix, "icy-pub", 7) == 0)
@@ -587,14 +599,16 @@
       if (strncmp(prefix, "icy-br", 6) == 0 )
         icy->br = (int) atoi((char *) &suffix[0]);

-      if (strncmp(prefix, "content-type", 12) == 0 ) {
+      if ((strncmp(prefix, "content-type", 12) == 0 ) ||
+        (strncmp(prefix, "Content-Type", 12) == 0))
+      {
         icy->content_type = memory_allocation(strlen(suffix)+1);
-        (void) strncpy(icy->content_type, suffix, strlen(suffix));
+        strncpy(icy->content_type, suffix, strlen(suffix));
       }
     }
   } /*  for eachline */

-  (void) free(headers);
+  (void)free(headers);
   return icy;
 }

@@ -621,7 +635,7 @@
   cu = getUptime(uptime);
   line = memory_allocation(300); /* Exessif. */

-  (void) sprintf(line, "Uptime: %d days, %d hours, %d min, %d seconds\nDownloaded: %lldKo\nSongs played: %ld\nReconnections: %ld\n", cu->day, cu->hour, cu->min, cu->sec, (long long unsigned int)((metacounter*metaint)/1024), cPigeStats->songs, cPigeStats->reconnections);
+  sprintf(line, "Uptime: %d days, %d hours, %d min, %d seconds\nDownloaded: %lldKo\nSongs played: %ld\nReconnections: %ld\n", cu->day, cu->hour, cu->min, cu->sec, (long long unsigned int)((metacounter*metaint)/1024), cPigeStats->songs, cPigeStats->reconnections);

   return line;
 }
@@ -636,16 +650,16 @@
   /* Pas terrible... */
   line = memory_allocation(300);

-  (void) sprintf(line, "[%dj %dh:%dm:%ds][%lldKo] ", cu->day, cu->hour, cu->min, cu->sec, (long long unsigned int)((metacounter * metaint) / 1024));
+  sprintf(line, "[%dj %dh:%dm:%ds][%lldKo] ", cu->day, cu->hour, cu->min, cu->sec, (long long unsigned int)((metacounter * metaint) / 1024));
   if (cmdLine->pige)
-    (void) sprintf(line+strlen(line), "%dh -> %dh ", getHour(), getHour()+1);
+    sprintf(line+strlen(line), "%dh -> %dh ", getHour(), getHour()+1);

   if (titre != NULL)
-    (void) sprintf(line+strlen(line), "%s", titre);
+    sprintf(line+strlen(line), "%s", titre);

   if (nexttitre != NULL)
     if (strstr(nexttitre, titre) == NULL)
-      (void) sprintf(line+strlen(line), " -> %s", nexttitre);
+      sprintf(line+strlen(line), " -> %s", nexttitre);

   return line;
 }
@@ -669,7 +683,7 @@

   if (serversPool == NULL)
   {
-    ERROR("Error: not any server defined.\n");
+    _ERROR("Error: not any server defined.\n");
     exit(1);
   }

@@ -677,7 +691,7 @@
   settings = getSettings(serversPool, &poolPosition);
   if (settings == NULL)
   {
-    ERROR("No valid settings in urlPool.\n");
+    _ERROR("No valid settings in urlPool.\n");
     exit(1);
   }

@@ -690,7 +704,7 @@
     settings = getSettings(serversPool, &poolPosition);
     if (settings == NULL)
     {
-      ERROR("No valid settings in urlPool.\n");
+      _ERROR("No valid settings in urlPool.\n");
       exit(1);
     }

@@ -708,7 +722,7 @@

   if (sendHeaders(server_socket, settings->mountpoint, 1) <= 0)
   {
-    ERROR("Error sending headers: 0 byte sent.\n");
+    _ERROR("Error sending headers: 0 byte sent.\n");
     goto RECO;
   }

@@ -731,21 +745,21 @@
   headers = memory_allocation(256);

   if (mountpoint == NULL)
-    (void) sprintf(headers, "GET / HTTP/1.0\r\n");
+    sprintf(headers, "GET / HTTP/1.0\r\n");
   else
-    (void) sprintf(headers, "GET %s HTTP/1.0\r\n", mountpoint);
+    sprintf(headers, "GET %s HTTP/1.0\r\n", mountpoint);

   if (metadata)
-    (void) strcat(headers, "Icy-MetaData:1\r\n");
+    strncat(headers, "Icy-MetaData:1\r\n", 16);
   else
-    (void) strcat(headers, "Icy-MetaData:0\r\n");
+    strncat(headers, "Icy-MetaData:0\r\n", 16);

-  (void) strcat(headers, "User-Agent:");
-  (void) strcat(headers, USER_AGENT);
-  (void) strcat(headers, "\r\n\r\n");
+  strncat(headers, "User-Agent:", 11);
+  strncat(headers, USER_AGENT, strlen(USER_AGENT));
+  strncat(headers, "\r\n\r\n", 4);

   ret = send(serversocket, headers, strlen(headers), 0);
-  (void) free(headers);
+  (void)free(headers);
   return ret;
 }

@@ -766,12 +780,12 @@
   retval = select(server_socket+1, &rfds, NULL, NULL, &timeout);
   if (retval <= 0)
   {
-    ERROR("Erreur de connexion!\n");
-    (void) server_close(server_socket);
+    _ERROR("Erreur de connexion!\n");
+    server_close(server_socket);
     return NULL;
   } else if (recv(server_socket, &c, 1, 0) != 1) {
-    ERROR("Error reading from shoutcast socket\n");
-    (void) server_close(server_socket);
+    _ERROR("Error reading from shoutcast socket\n");
+    server_close(server_socket);
     return NULL;
   }

@@ -786,10 +800,10 @@
     retval = select(server_socket+1, &rfds, NULL, NULL, &timeout);
     if (retval <= 0)
     {
-      (void) printf("Connection error in select. (readmeta)\n");
-      (void) free(buffer);
-      (void) free(meta);
-      (void) server_close(server_socket);
+      printf("Connection error in select. (readmeta)\n");
+      (void)free(buffer);
+      (void)free(meta);
+      server_close(server_socket);
       return NULL;
     } else {
       readsize = 0;
@@ -802,21 +816,21 @@
         retval = select(server_socket+1, &rfds, NULL, NULL, &timeout);
         if (retval <= 0)
         {
-          ERROR("Erreur de connexion!\n");
-          (void) server_close(server_socket);
+          _ERROR("Erreur de connexion!\n");
+          server_close(server_socket);
           return NULL;
         } else {
           size = recv(server_socket, buffer, (c*16 - readsize), 0);
           if (size <= 0)
           {
             VERBOSE("Megaproblem here.\n");
-            (void) server_close(server_socket);
+            server_close(server_socket);
           }
           readsize += size;
-          (void) strncat(meta, buffer, size);
+          strncat(meta, buffer, size);
         }
       }
-      (void) free(buffer);
+      (void)free(buffer);
     }
   } else {
     /* Title was not sent. */
@@ -903,13 +917,13 @@

   if (strlen(cursong->title) == 0)
   {
-    (void) free(cursong->title);
+    (void)free(cursong->title);
     cursong->title = NULL;
   }

   if (strlen(cursong->artist) == 0)
   {
-    (void) free(cursong->artist);
+    (void)free(cursong->artist);
     cursong->artist = NULL;
   }

@@ -956,7 +970,7 @@
   {
     return 1;
   } else {
-    ERROR("Error: return code from HTTP server: %d.\n", returnCode);
+    _ERROR("Error: return code from HTTP server: %d.\n", returnCode);
     return 0;
   }
 }
@@ -973,7 +987,7 @@
   char c;

   buffer = memory_allocation(256);
-  (void) memset(headers, 0, 4096);
+  memset(headers, 0, 4096);

   /* For select() it's a global struct. */
   timeout.tv_sec = SOCKET_TIMEOUT;
@@ -982,13 +996,13 @@
   retval = select(server_socket+1, &rfds, NULL, NULL, &timeout);
   if (retval <= 0)
   {
-    ERROR("Erreur de connexion in getHeaders().\n");
+    _ERROR("Erreur de connexion in getHeaders().\n");
     goto error;
   }

   if (recv(serversocket, buffer, 256, 0) <= 0)
   {
-    ERROR("Erreur de connexion.\n");
+    _ERROR("Erreur de connexion.\n");
     goto error;
   }

@@ -998,7 +1012,7 @@
     goto error;
   }

-  free(buffer);
+  (void)free(buffer);
   buffer = NULL;

   headers[0] = 0;
@@ -1015,7 +1029,7 @@
       goto error;

     } else if (recv(server_socket, &c, 1, 0) != 1) {
-      ERROR("Error reading data in getHeaders()\n");
+      _ERROR("Error reading data in getHeaders()\n");
       goto error;
     }

@@ -1033,13 +1047,13 @@
   headers[i] = 0;
   if (!strlen(headers)) { return NULL; }
   ptr = memory_allocation(strlen(headers)+1);
-  (void) strncpy(ptr, headers, strlen(headers));
+  strncpy(ptr, headers, strlen(headers));
   return ptr;

 error:
-  (void) server_close(server_socket);
+  server_close(server_socket);
   if (buffer != NULL)
-    free(buffer);
+    (void)free(buffer);

   return NULL;
 }
@@ -1053,7 +1067,7 @@
   chunk = memory_allocation(128);

   /* id3v1 tag */
-  (void) sprintf(chunk, "TAG");
+  sprintf(chunk, "TAG");

   /* Title */
   relativePointer = chunk + 3; /* 3 octets */
@@ -1061,13 +1075,13 @@
     padding = (30 - strlen(titre));
     if (padding < 0)
     {
-      (void) snprintf(relativePointer+3, 31, "%s", titre);
+      snprintf(relativePointer+3, 31, "%s", titre);
     } else {
-      (void) sprintf(relativePointer, "%s", titre);
-      (void) memset(relativePointer + (30-padding), 0, padding);
+      sprintf(relativePointer, "%s", titre);
+      memset(relativePointer + (30-padding), 0, padding);
     }
   } else {
-    (void) memset(relativePointer, 0, 30);
+    memset(relativePointer, 0, 30);
   }

   /* Artist */
@@ -1075,13 +1089,13 @@
   if (artiste) {
     padding = (30 - strlen(artiste));
     if (padding < 0) {
-      (void) snprintf(relativePointer, 31, "%s", artiste);
+      snprintf(relativePointer, 31, "%s", artiste);
     } else {
-      (void) sprintf(relativePointer, "%s", artiste);
-      (void) memset(relativePointer + (30 - padding), 0, padding);
+      sprintf(relativePointer, "%s", artiste);
+      memset(relativePointer + (30 - padding), 0, padding);
     }
   } else {
-    (void) memset(relativePointer, 0, 30);
+    memset(relativePointer, 0, 30);
   }

   /* Album (on met l'url de la radio ...) */
@@ -1089,27 +1103,27 @@
   if (radioName != NULL) {
     padding = (30 - strlen(radioName));
     if (padding < 0) {
-      (void) snprintf(relativePointer, 31, "%s", radioName);
+      snprintf(relativePointer, 31, "%s", radioName);
     } else {
-      (void) sprintf(relativePointer, "%s", radioName);
-      (void) memset(relativePointer + (30-padding), 0, padding);
+      sprintf(relativePointer, "%s", radioName);
+      memset(relativePointer + (30-padding), 0, padding);
     }
   } else {
-    (void) memset(relativePointer, 0, 30);
+    memset(relativePointer, 0, 30);
   }

   /* Year */
   relativePointer = relativePointer + 30; /* 93 octets */
-  (void) memset(relativePointer, 0, 4);
+  memset(relativePointer, 0, 4);

   /* Comment */
   relativePointer = relativePointer + 4; /* 97 octets */
-  (void) snprintf(relativePointer, 31, "by cPige http://ed.zehome.com/");
+  snprintf(relativePointer, 31, "by cPige http://ed.zehome.com/");
   /* Ouah la chance, ça rentre! */

   /* genre */
   relativePointer = relativePointer + 30; /* 127 octets */
-  (void) memset(relativePointer, 1, 1);
+  memset(relativePointer, 1, 1);

   /* 128 bytes ! We won :) */
   return chunk;
@@ -1145,13 +1159,13 @@
   VERBOSE("Using win32 sockets\n");
   WSADATA WSAData;
   if((res = WSAStartup(MAKEWORD(2,0), &WSAData)) != 0)
-    (void) printf("Impossible d'initialiser l'API Winsock 2.0\n");
+    printf("Impossible d'initialiser l'API Winsock 2.0\n");
 #endif

   VERBOSE("Entring Server_connect\n");

   /* on initialise la socket */
-  (void) memset(&serverSockAddr, 0, sizeof(serverSockAddr));
+  memset(&serverSockAddr, 0, sizeof(serverSockAddr));
   VERBOSE("Servername: %s\n", servername);
   VERBOSE("Port: %d\n", serverport);
   hostAddr = inet_addr(servername);
@@ -1159,15 +1173,15 @@
   /* If it is an ip address */
   if ((long) hostAddr != (long)-1)
   {
-    (void) memcpy(&serverSockAddr.sin_addr, &hostAddr, sizeof(hostAddr));
+    memcpy(&serverSockAddr.sin_addr, &hostAddr, sizeof(hostAddr));
   } else {
     serverHostEnt = gethostbyname(servername);
     if (serverHostEnt == NULL)
     {
-      ERROR("Error with gethostbyname. exiting.\n");
+      _ERROR("Error with gethostbyname. exiting.\n");
       return -1;
     }
-    (void) memcpy(&serverSockAddr.sin_addr, serverHostEnt->h_addr, serverHostEnt->h_length);
+    memcpy(&serverSockAddr.sin_addr, serverHostEnt->h_addr, serverHostEnt->h_length);
   }
   serverSockAddr.sin_port = htons(serverport);
   serverSockAddr.sin_family = AF_INET; /* FIXEME: IPv6 Support ? */
@@ -1175,7 +1189,7 @@
   /* creation de la socket */
   if ( (server_socket = socket(AF_INET, SOCK_STREAM, 0)) < 0)
   {
-    ERROR("Error creating shoutcast socket. Exiting.\n");
+    _ERROR("Error creating shoutcast socket. Exiting.\n");
     return -2;
   }

@@ -1185,7 +1199,7 @@
   /* requete de connexion */
   if(connect( server_socket, (struct sockaddr *)&serverSockAddr, sizeof(serverSockAddr)) < 0 )
   {
-    ERROR("Remote host connection failed.\n");
+    _ERROR("Remote host connection failed.\n");
     return -3;
   } else {
     VERBOSE("Connected.\n");
@@ -1200,8 +1214,8 @@
 int server_close (int serversocket)
 {
   VERBOSE("Closing server connection.\n");
-  (void) shutdown(server_socket, 2);
-  (void) close(server_socket);
+  shutdown(server_socket, 2);
+  close(server_socket);
   server_socket = 0;
   VERBOSE("Server connection closed.\n");
   return -1;
@@ -1209,7 +1223,7 @@

 void print_credits()
 {
-  (void) printf ("cPige %s by Laurent Coustet (c) 2005\n", VERSION);
+  printf ("cPige %s by Laurent Coustet (c) 2005\n", VERSION);
   return;
 }

@@ -1218,7 +1232,7 @@
   printf ("cPige help. cPige is a Laurent Coustet product.\n");
   printf ("For more informations about me and my software\n");
   printf ("please visit http://ed.zehome.com/\n\n");
-  printf ("Usage: ./cpige -h http://stream.frequence3.net:8000/ -d /home/ed/Pige -l logfile.log\n\n");
+  printf ("Usage: ./cpige -h http://stream-hautdebit.frequence3.net:8000/ -d /home/ed/Pige -l logfile.log\n\n");
   printf ("    -h host to connect to.\n");
   printf ("    -V show cpige Version.\n");
   printf ("    -d directory save stream to this directory.\n");
@@ -1229,7 +1243,9 @@
   printf ("    -l Path to logfile.\n");
   printf ("    -I [h|m] pige mode will cut on a hour by hour basis or min by min basis.\n");
   printf ("    -i nb how many \"nb\" hour(s) or minute(s) we should wait before cutting.\n");
+#ifndef WIN32
   printf ("    -n cPige will append xxxx to file in 'non pige mode', where xxxx is a number.\n");
+#endif
   /* printf ("    -L live mode (takes no argument), save entire file until 401. (not implemented)\n"); */
   return;
 }
@@ -1274,7 +1290,7 @@

   cmdLine->logFile    = "cpige.log";
   cmdLine->dir        = malloc(3);
-  strcpy(cmdLine->dir, "./");
+  strncpy(cmdLine->dir, "./", 3);

   for (i = 1; i < argc; i++)
   {
@@ -1284,8 +1300,8 @@
       /* from streamripper */
       if ((i == (argc-1)) || (argv[i+1][0] == '-'))
       {
-        (void) print_help();
-        (void) fprintf(stderr, "option %s requires an argument\n", argv[i]);
+        (void)print_help();
+        fprintf(stderr, "option %s requires an argument\n", argv[i]);
         exit(1);
       }
     }
@@ -1309,35 +1325,35 @@
       case 'd':
         i++;
         cmdLine->dir = memory_allocation(strlen(argv[i]) + 1 + 1);
-        (void) strncpy(cmdLine->dir, argv[i], strlen(argv[i]));
+        strncpy(cmdLine->dir, argv[i], strlen(argv[i]));

         if ((argv[i][(strlen(argv[i]))] != '/') && (argv[i][(strlen(argv[i]))] != '\\')) {
           cmdLine->dir[(strlen(cmdLine->dir))] = '/';
           cmdLine->dir[(strlen(cmdLine->dir)+1)] = 0;
         }
         break;
-
+#ifndef WIN32
       case 'n':
         cmdLine->useNumbers = 1;
         break;
-
+#endif
       case 'l':
         i++;
         cmdLine->logFile = memory_allocation(strlen(argv[i]) +1);
-        (void) strncpy(cmdLine->logFile, argv[i], strlen(argv[i]));
+        strncpy(cmdLine->logFile, argv[i], strlen(argv[i]));
         break;

       case 'P':
         if (cmdLine->live == 1)
         {
-          (void) printf("You can't use Live Mode and Pige mode simultaneously.\n");
+          printf("You can't use Live Mode and Pige mode simultaneously.\n");
           exit(-1);
         }
         if (cmdLine->pige == 1)
           break;

         cmdLine->pige = 1;
-        (void) printf("Pige Mode activated.\n");
+        printf("Pige Mode activated.\n");
         break;

       case 'q':
@@ -1371,7 +1387,7 @@
         if (cmdLine->pige != 1)
         {
           cmdLine->pige = 1;
-          (void) printf("Pige Mode activated.\n");
+          printf("Pige Mode activated.\n");
         }

         if ( *argv[i] == 'h' || *argv[i] == 'H' )
@@ -1399,7 +1415,7 @@
         if (cmdLine->pige != 1)
         {
           cmdLine->pige = 1;
-          (void) printf("Pige Mode activated.\n");
+          printf("Pige Mode activated.\n");
         }

         cmdLine->interval = atoi(argv[i]);
@@ -1455,6 +1471,8 @@
 /* Returns what song number we lastly saved
  * the stream to
  */
+
+#ifndef WIN32
 int getSongs(char *dir)
 {
   DIR *dirp;
@@ -1496,6 +1514,7 @@

   return songs;
 }
+#endif

 int checkInterval()
 {
@@ -1510,7 +1529,7 @@
       ret = 1;
   } else {
     ret = 1;
-    (void) fprintf(stderr, "Intenal Error: intervalType unknown!\n");
+    fprintf(stderr, "Intenal Error: intervalType unknown!\n");
   }

   return ret;
diff -ru cpige/cpige.h cpige-1.3-new/cpige.h
--- cpige/cpige.h	Fri Nov 25 09:46:32 2005
+++ cpige-1.3-new/cpige.h	Wed Nov 30 05:32:58 2005
@@ -126,7 +126,9 @@
 int mustCut(lastCut *cut);
 int getCloserInterval(int now, int interval);

+#ifndef WIN32
 int getSongs(char *dir);
+#endif

 stats *cPigeStats;

Only in cpige-1.3-new/: cpige.log
diff -ru cpige/debug.c cpige-1.3-new/debug.c
--- cpige/debug.c	Wed Nov 16 07:34:01 2005
+++ cpige-1.3-new/debug.c	Wed Nov 30 06:33:56 2005
@@ -35,8 +35,8 @@
   now = time(NULL);
   if (now == (time_t)-1)
   {
-    (void) fprintf(stderr, "Can't log line: time() failed.\n");
-    (void) perror("time");
+    fprintf(stderr, "Can't log line: time() failed.\n");
+    perror("time");
     return;
   }

@@ -48,7 +48,7 @@
 #endif
   if (curTime == NULL)
   {
-    fprintf(stderr, "Can't log line: localtime_r() failed.\n");
+    fprintf(stderr, "Can't log line: localtime(_r)() failed.\n");
     return;
   }

@@ -62,14 +62,14 @@
   sprintf(z_format, "[%.2d:%.2d:%.2d] [DEBUG PRIO %d][File: %s][Line: %d] %s", curTime->tm_hour, curTime->tm_min, curTime->tm_sec, _debug_priority, _debug_filename, _debug_line, _debug_message);

 #ifndef WIN32
-  free(curTime);
+  (void)free(curTime);
 #endif

   vfprintf(_Debug_Output, z_format, ap);

   fflush(_Debug_Output);

-  free(z_format);
+  (void)free(z_format);
   va_end(ap);
   return;
 }
diff -ru cpige/debug.h cpige-1.3-new/debug.h
--- cpige/debug.h	Wed Nov 16 07:34:01 2005
+++ cpige-1.3-new/debug.h	Wed Nov 30 06:22:29 2005
@@ -15,7 +15,7 @@

 #include <stdio.h>

-#define DEBUGLEVEL          3
+#define DEBUGLEVEL          1

 #define DEBUG_ERR           1
 #define DEBUG_MSG           2
@@ -23,7 +23,7 @@

 #define DEBUG(priority, ...) _DEBUG(__LINE__, __FILE__, priority, __VA_ARGS__)

-#define ERROR(...)   DEBUG(DEBUG_ERR, __VA_ARGS__)
+#define _ERROR(...)   DEBUG(DEBUG_ERR, __VA_ARGS__)
 #define MESSAGE(...) DEBUG(DEBUG_MSG, __VA_ARGS__)
 #define VERBOSE(...) DEBUG(DEBUG_ALL, __VA_ARGS__)

diff -ru cpige/pool.c cpige-1.3-new/pool.c
--- cpige/pool.c	Sat Nov 12 05:06:53 2005
+++ cpige-1.3-new/pool.c	Wed Nov 30 06:33:31 2005
@@ -32,9 +32,9 @@

   if (new->settings == NULL)
   {
-    ERROR("Error parsing URL `%s'.\n", url);
-    free(new->url);
-    free(new);
+    _ERROR("Error parsing URL `%s'.\n", url);
+    (void)free(new->url);
+    (void)free(new);
     return pool;
   }

diff -ru cpige/tool.c cpige-1.3-new/tool.c
--- cpige/tool.c	Sat Nov 12 05:06:53 2005
+++ cpige-1.3-new/tool.c	Wed Nov 30 06:33:15 2005
@@ -104,9 +104,9 @@

 void printServSettings(serverSettings_t *set)
 {
-  (void) printf("host: %s\n", set->serverAddr);
-  (void) printf("port: %d\n", set->port);
-  (void) printf("mp: %s\n", set->mountpoint);
+  printf("host: %s\n", set->serverAddr);
+  printf("port: %d\n", set->port);
+  printf("mp: %s\n", set->mountpoint);
   return;
 }
2005-12-02 00:09:16 +00:00

4 lines
183 B
Plaintext

MD5 (cpige-1.3.tar.gz) = bca41760dcb45356f027dbc1a1823580
SHA256 (cpige-1.3.tar.gz) = 012ab1b91bd36bf8fa723f3c1b97f11a32f07c6c4c9f686e3b5f31bd4e8956f8
SIZE (cpige-1.3.tar.gz) = 22422