freebsd-ports/mail/teapop-devel/files/patch-aa
Jim Mock c0048336de Add a patch to install teapop.passwd as teapop.passwd.sample -- this
prevents evilness which would cause teapop.passwd to be overwritten when
installing a newer version of the port.

Submitted by:	Tobias Reifenberger <treif@mayn.de>
2000-08-13 09:39:52 +00:00

22 lines
707 B
Plaintext

--- etc/Makefile.in.orig Sat Aug 12 16:28:44 2000
+++ etc/Makefile.in Sat Aug 12 17:15:14 2000
@@ -23,14 +23,15 @@
fi
install: build
+ @echo installing teapop.passwd.sample; \
+ ${INSTALL} -d ${sysconfdir}; \
+ ${INSTALL} -m 0644 teapop.passwd ${sysconfdir}/teapop.passwd.sample;
@echo Checking for existing teapop.passwd; \
if [ -f ${sysconfdir}/teapop.passwd ]; then \
echo "Exists...NOT installing teapop.passwd"; \
else \
echo "Not found, installing teapop.passwd"; \
- ${INSTALL} -d ${sysconfdir}; \
- ${INSTALL} teapop.passwd ${sysconfdir}; \
- ${CHMOD} 0755 ${sysconfdir}/teapop.passwd; \
+ ${INSTALL} -m 0644 teapop.passwd ${sysconfdir}; \
fi
makefile: ../config/timestamp