freebsd-ports/japanese/tk42/files/patch-ab
Jun Kuriyama 8f7ae93769 ELFization patch.
PR:		ports/8044
Submitted by:	Taguchi Takeshi <taguchi@tohoku.iij.ad.jp>
1998-09-27 08:24:37 +00:00

141 lines
5.4 KiB
Plaintext

--- ./unix/Makefile.in.ORIG Sun Sep 20 16:36:43 1998
+++ ./unix/Makefile.in Sun Sep 20 16:43:49 1998
@@ -56,7 +56,9 @@
BIN_DIR = $(exec_prefix)/bin
# Directory in which to install the include file tk.h:
-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
+INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include/tk$(VERSION)
+GENERIC_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/generic
+UNIX_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/unix
# Top-level directory for manual entries:
MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
@@ -75,7 +77,7 @@
# The directory containing the Tcl sources and headers appropriate
# for this version of Tk ("srcdir" will be replaced or has already
# been replaced by the configure script):
-TCL_GENERIC_DIR = @TCL_SRC_DIR@/generic
+TCL_GENERIC_DIR = ${prefix}/include/tcl7.6jp
# The directory containing the Tcl library archive file appropriate
# for this version of Tk:
@@ -95,11 +97,11 @@
# Libraries to use when linking: must include at least Xlib, the
# dynamic loading library, and the math library (in that order). This
# definition is determined by the configure script.
-LIBS = @TCL_BUILD_LIB_SPEC@ @LIBS@ $(X11_LIB_SWITCHES) @DL_LIBS@ @MATH_LIBS@ -lc
+LIBS = @TCL_LIB_SPEC@ @LIBS@ $(X11_LIB_SWITCHES) @DL_LIBS@ @MATH_LIBS@ -lc
# To change the compiler switches, for example to change from -O
# to -g, change the following line:
-CFLAGS = -O
+CFLAGS = @CFLAGS@
# To turn off the security checks that disallow incoming sends when
# the X server appears to be insecure, reverse the comments on the
@@ -291,6 +293,9 @@
rm -f @TK_LIB_FILE@
@MAKE_LIB@
$(RANLIB) @TK_LIB_FILE@
+.if ${PORTOBJFORMAT}X == elfX
+ ln -sf ${TK_LIB_FILE} `echo ${TK_LIB_FILE} | sed 's/\.so.*$$/.so/'`
+.endif
wish: $(WISH_OBJS) $(TK_LIB_FILE)
$(CC) @LD_FLAGS@ $(WISH_OBJS) @TK_BUILD_LIB_SPEC@ $(LIBS) \
@@ -307,12 +312,12 @@
test: tktest
LD_LIBRARY_PATH=`pwd`:${TCL_BIN_DIR}:${LD_LIBRARY_PATH}; \
export LD_LIBRARY_PATH; \
- TCL_LIBRARY=@TCL_SRC_DIR@/library; export TCL_LIBRARY; \
+ TCL_LIBRARY=${TCL_BIN_DIR}; export TCL_LIBRARY; \
TK_LIBRARY=$(TOP_DIR)/library; export TK_LIBRARY; \
( echo cd $(TOP_DIR)/tests\; source all\; exit ) \
| ./tktest -geometry +0+0
-install: install-binaries install-libraries install-demos install-man
+install: install-binaries install-libraries install-demos
# Note: before running ranlib below, must cd to target directory because
# some ranlibs write to current directory, and this might not always be
@@ -332,13 +337,18 @@
@$(INSTALL_DATA) $(TK_LIB_FILE) $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
@(cd $(LIB_INSTALL_DIR); $(RANLIB) $(TK_LIB_FILE))
@chmod 555 $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
+.if ${PORTOBJFORMAT}X == elfX
+ @(cd $(LIB_INSTALL_DIR); ln -sf ${TK_LIB_FILE} `echo ${TK_LIB_FILE} | sed 's/\.so.*$$/.so/'`)
+.endif
@echo "Installing wish"
@$(INSTALL_PROGRAM) wish $(BIN_INSTALL_DIR)/wish$(VERSION)
@echo "Installing tkConfig.sh"
- @$(INSTALL_DATA) tkConfig.sh $(LIB_INSTALL_DIR)/tkConfig.sh
+ @$(INSTALL_DATA) tkConfig.sh $(SCRIPT_INSTALL_DIR)/tkConfig.sh
install-libraries:
@for i in $(INSTALL_ROOT)$(prefix)/lib $(INCLUDE_INSTALL_DIR) \
+ $(GENERIC_INCLUDE_INSTALL_DIR) \
+ $(UNIX_INCLUDE_INSTALL_DIR) \
$(SCRIPT_INSTALL_DIR) ; \
do \
if [ ! -d $$i ] ; then \
@@ -348,8 +358,18 @@
else true; \
fi; \
done;
- @echo "Installing tk.h"
- @$(INSTALL_DATA) $(GENERIC_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk.h
+ @for i in $(GENERIC_DIR)/*.h ; \
+ do \
+ echo "Installing $$i"; \
+ $(INSTALL_DATA) $$i $(GENERIC_INCLUDE_INSTALL_DIR); \
+ done;
+ @for i in $(UNIX_DIR)/*.h ; \
+ do \
+ echo "Installing $$i"; \
+ $(INSTALL_DATA) $$i $(UNIX_INCLUDE_INSTALL_DIR); \
+ done;
+ @ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk.h
+ @ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/tkWStr.h $(INCLUDE_INSTALL_DIR)/tkWStr.h
for i in $(SRC_DIR)/library/*.tcl $(SRC_DIR)/library/*.gif $(SRC_DIR)/library/*.xbm $(SRC_DIR)/library/tclIndex $(SRC_DIR)/library/prolog.ps $(UNIX_DIR)/tkAppInit.c; \
do \
echo "Installing $$i"; \
@@ -401,28 +421,28 @@
@cd $(SRC_DIR)/doc; for i in *.1; \
do \
echo "Installing doc/$$i"; \
- rm -f $(MAN1_INSTALL_DIR)/$$i; \
+ rm -f $(MAN1_INSTALL_DIR)/$$i.gz; \
sed -e '/man\.macros/r man.macros' -e '/man\.macros/d' \
- $$i > $(MAN1_INSTALL_DIR)/$$i; \
- chmod 444 $(MAN1_INSTALL_DIR)/$$i; \
+ $$i |gzip -9 > $(MAN1_INSTALL_DIR)/$$i.gz; \
+ chmod 444 $(MAN1_INSTALL_DIR)/$$i.gz; \
done;
$(UNIX_DIR)/mkLinks $(MAN1_INSTALL_DIR)
@cd $(SRC_DIR)/doc; for i in *.3; \
do \
echo "Installing doc/$$i"; \
- rm -f $(MAN3_INSTALL_DIR)/$$i; \
+ rm -f $(MAN3_INSTALL_DIR)/$$i.gz; \
sed -e '/man\.macros/r man.macros' -e '/man\.macros/d' \
- $$i > $(MAN3_INSTALL_DIR)/$$i; \
- chmod 444 $(MAN3_INSTALL_DIR)/$$i; \
+ $$i |gzip -9 > $(MAN3_INSTALL_DIR)/$$i.gz; \
+ chmod 444 $(MAN3_INSTALL_DIR)/$$i.gz; \
done;
$(UNIX_DIR)/mkLinks $(MAN3_INSTALL_DIR)
@cd $(SRC_DIR)/doc; for i in *.n; \
do \
echo "Installing doc/$$i"; \
- rm -f $(MANN_INSTALL_DIR)/$$i; \
+ rm -f $(MANN_INSTALL_DIR)/$$i.gz; \
sed -e '/man\.macros/r man.macros' -e '/man\.macros/d' \
- $$i > $(MANN_INSTALL_DIR)/$$i; \
- chmod 444 $(MANN_INSTALL_DIR)/$$i; \
+ $$i |gzip -9 > $(MANN_INSTALL_DIR)/$$i.gz; \
+ chmod 444 $(MANN_INSTALL_DIR)/$$i.gz; \
done;
$(UNIX_DIR)/mkLinks $(MANN_INSTALL_DIR)