freebsd-ports/lang/julia/files/patch-base_Makefile
Wen Heping 434d421449 lang/julia: Update to 1.8.4 and Makefile cleanup
PR:		268629
Reported by:	rizor.reardon@yahoo.com(maintainer)
2022-12-29 20:02:23 +08:00

21 lines
584 B
Plaintext

--- base/Makefile.orig 2022-12-23 22:14:27 UTC
+++ base/Makefile
@@ -190,7 +190,7 @@ symlink_p7zip: $(build_bindir)/7z$(EXE)
ifneq ($(USE_SYSTEM_P7ZIP),0)
SYMLINK_SYSTEM_LIBRARIES += symlink_p7zip
-7Z_PATH := $(shell which 7z$(EXE))
+7Z_PATH := $(shell which 7zz$(EXE))
endif
$(build_bindir)/7z$(EXE):
@@ -218,6 +218,8 @@ else
$(eval $(call symlink_system_library,CSL,libgcc_s,1))
endif
endif
+else
+$(eval $(call symlink_system_library,CSL,libgcc_s,1))
endif
ifneq (,$(LIBGFORTRAN_VERSION))
$(eval $(call symlink_system_library,CSL,libgfortran,$(LIBGFORTRAN_VERSION)))