freebsd-ports/games/tank/files/patch-aa
Jordan K. Hubbard 37f8f86596 NEW PORT: games/tank, a network tank battle game for Mesa/GL
Note: I suffered a temporary brain glitch on the import and called
the vendor tag "XTANK" rather than "TANK".  I'm suspecting that's not
a total catastrophe, but just to note the inconsistency here in the
initial import message.

PR:		5916
Submitted by:	Donald Burr <dburr@POBoxes.com>
1998-03-14 11:41:26 +00:00

132 lines
3.4 KiB
Plaintext

diff -ruN ../../OLD/tank-0.4a/./Makefile ./Makefile
--- ../../OLD/tank-0.4a/./Makefile Sun Feb 2 09:59:42 1997
+++ ./Makefile Wed Mar 4 04:42:57 1998
@@ -43,11 +43,11 @@
"GLAUXINC = $(GLAUXINC)" linux-elf
linux-mesa:
- cd Mesa; $(MAKE) linux
+ # cd Mesa; $(MAKE) linux
$(MAKE) -f Makefile.Linux.Mesa linux
linux-mesa-elf:
- cd Mesa; $(MAKE) linux-elf
+ # cd Mesa; $(MAKE) linux-elf
$(MAKE) -f Makefile.Linux.Mesa linux-elf
aix-opengl:
@@ -65,7 +65,7 @@
$(MAKE) -f Makefile.Linux clean
mesa-clean:
- cd Mesa; $(MAKE) clean
+ # cd Mesa; $(MAKE) clean
$(MAKE) -f Makefile.Linux clean
backup:
diff -ruN ../../OLD/tank-0.4a/./Makefile.Linux.Mesa ./Makefile.Linux.Mesa
--- ../../OLD/tank-0.4a/./Makefile.Linux.Mesa Sun Feb 2 09:59:42 1997
+++ ./Makefile.Linux.Mesa Wed Mar 4 04:42:57 1998
@@ -3,16 +3,16 @@
.SUFFIXES: .cc .o
-ARCH = -DLINUX -DMESA #-DSOUND
+ARCH = -DLINUX -DUSING_MESA #-DSOUND
MESA = Mesa
-INCLUDE = -I/usr/include -I$(MESA)/include -I$(MESA)/include/GL
+INCLUDE = -I/usr/include -I/usr/X11R6/include -I/usr/X11R6/include/GL
-CFLAGS = $(INCLUDE) $(ARCH) -O2 -m486 -Wall -pipe \
+CFLAGS = $(INCLUDE) $(ARCH) -DSOUND -O3 -m486 -Wall -pipe \
-pedantic -funroll-loops -mieee-fp
-LDFLAGS = -L/usr/X11R6/lib -L$(MESA)/lib
+LDFLAGS = -L/usr/X11R6/lib
TAR = tar
COMPRESS = compress -v
diff -ruN ../../OLD/tank-0.4a/./collisions.c ./collisions.c
--- ../../OLD/tank-0.4a/./collisions.c Sun Feb 2 09:59:42 1997
+++ ./collisions.c Wed Mar 4 04:42:57 1998
@@ -10,7 +10,7 @@
#include <sys/time.h>
#include <math.h>
-#ifdef MESA
+#ifdef USING_MESA
#include <glaux.h>
#else
#include <aux.h>
diff -ruN ../../OLD/tank-0.4a/./daemon.c ./daemon.c
--- ../../OLD/tank-0.4a/./daemon.c Sun Feb 2 09:59:42 1997
+++ ./daemon.c Wed Mar 4 04:42:57 1998
@@ -24,7 +24,7 @@
#include <GL/gl.h>
#include <GL/glu.h>
-#ifdef MESA
+#ifdef USING_MESA
#include <glaux.h>
#else
#include <aux.h>
diff -ruN ../../OLD/tank-0.4a/./defines.h ./defines.h
--- ../../OLD/tank-0.4a/./defines.h Sun Feb 2 09:59:42 1997
+++ ./defines.h Wed Mar 4 04:44:12 1998
@@ -15,7 +15,7 @@
/* Definitions des variables du jeu */
/* ------------------------------------------------*/
-#define TANK_HOME "/usr/games/tank-0.4a"
+#define TANK_HOME "/usr/local/lib/tank"
/* ------------------------------------------------*/
/* Definitions du nombre maximum d'objets */
diff -ruN ../../OLD/tank-0.4a/./lists.c ./lists.c
--- ../../OLD/tank-0.4a/./lists.c Sun Feb 2 09:59:42 1997
+++ ./lists.c Wed Mar 4 04:42:57 1998
@@ -13,7 +13,7 @@
#include <GL/gl.h>
#include <GL/glu.h>
-#ifdef MESA
+#ifdef USING_MESA
#include <glaux.h>
#else
#include <aux.h>
diff -ruN ../../OLD/tank-0.4a/./operations.c ./operations.c
--- ../../OLD/tank-0.4a/./operations.c Sun Feb 2 09:59:43 1997
+++ ./operations.c Wed Mar 4 04:42:57 1998
@@ -13,7 +13,7 @@
#include "defines.h"
#include "operations.h"
-#ifdef MESA
+#ifdef USING_MESA
#include <glaux.h>
#else
#include <aux.h>
diff -ruN ../../OLD/tank-0.4a/./tank.c ./tank.c
--- ../../OLD/tank-0.4a/./tank.c Sun Feb 2 09:59:43 1997
+++ ./tank.c Wed Mar 4 04:44:26 1998
@@ -22,7 +22,7 @@
#include <GL/glx.h>
#include <X11/Xutil.h>
-#ifdef MESA
+#ifdef USING_MESA
#include <glaux.h>
#else
#include <aux.h>
@@ -1383,7 +1383,7 @@
#ifdef SOUND
- if(system("cat eatthis.au >/dev/audio &") != 0) {
+ if(system("cat /usr/local/lib/tank/eatthis.au >/dev/audio &") != 0) {
}
#endif