- Fix build with clang

- Add LICENSE
- Support MANPREFIX

PR:		ports/174163
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Beech Rintoul 2012-12-11 21:49:33 +00:00
parent ada99036c4
commit ffcb872223
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=308716
10 changed files with 107 additions and 51 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= gcvs
PORTVERSION= 1.0
PORTREVISION= 12
PORTREVISION= 13
PORTEPOCH= 1
CATEGORIES= devel tk
MASTER_SITES= SF/cvsgui/gCvs/${PORTNAME}-${PORTVERSION}
@ -11,28 +11,29 @@ MASTER_SITES= SF/cvsgui/gCvs/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= High-end interface client for CVS
BUILD_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84
RUN_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84
LICENSE= GPLv2
USE_GNOME= gtk12
GNU_CONFIGURE= yes
USE_TCL_BUILD= yes
USE_TCL_WRAPPER=yes
USE_TK_WRAPPER= yes
USE_GMAKE= yes
BREAKS_IF_PEDANTIC= yes
CONFIGURE_ARGS+= --with-tclinclude=${LOCALBASE}/include/tcl8.4
CONFIGURE_ARGS+= --with-tcllib=${LOCALBASE}/lib/tcl8.4
CONFIGURE_SCRIPT= make_configure
USE_AUTOTOOLS= aclocal autoheader automake autoconf
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing --force --copy --gnu
GNU_CONFIGURE= yes
CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS:N-std=*:N:}"
CONFIGURE_ARGS= --with-tclinclude=${TCL_INCLUDEDIR} \
--with-tcllib=${TCL_LIBDIR}
MAKE_JOBS_SAFE= yes
MAN1= cvs.1
MAN5= cvs.5
MAN8= cvsbug.8
INFO= cvs cvsclient
USE_AUTOTOOLS= automake14:env autoconf:env
MAKE_JOBS_UNSAFE= yes
AUTOTOOLSFILES= make_configure
.include <bsd.port.pre.mk>
pre-configure:
@(cd ${WRKSRC}/cvsunix && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOCONF} \
${AUTOCONF_ARGS})
.if ${OSVERSION} >= 800037
BROKEN= does not compile
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
MD5 (gcvs-1.0.tar.gz) = 42eff200593eabfbef3a7e9157d76999
SHA256 (gcvs-1.0.tar.gz) = 0cac671c9d90f4a8902f1b6327605ac851a3aa058021310f4ba7ab5a047b13bf
SIZE (gcvs-1.0.tar.gz) = 2917708

View File

@ -0,0 +1,19 @@
--- common/UCvsConsole.cpp.orig 2000-06-06 14:48:24.000000000 +0900
+++ common/UCvsConsole.cpp 2012-11-06 16:16:19.000000000 +0900
@@ -22,6 +22,7 @@
*
*/
+#include <cstdlib>
#include "stdafx.h"
#if qGTK
@@ -230,7 +231,7 @@
nEndChar = w.selection_end_pos;
}
- guint long length = nEndChar - nStartChar;
+ gulong length = nEndChar - nStartChar;
if(length > 0 && nStartChar < len)
{
char *buf = (char *)malloc((length + 1) * sizeof(char));

View File

@ -0,0 +1,14 @@
--- cvstree/CvsLog.h.orig 2002-06-16 02:49:37.000000000 +0900
+++ cvstree/CvsLog.h 2012-11-06 16:19:38.000000000 +0900
@@ -26,8 +26,9 @@
#endif /* WIN32 */
#include <vector>
-#include <time.h>
-#include <stdio.h>
+#include <ctime>
+#include <cstdio>
+#include <cstring>
#if defined(_MSC_VER) && _MSC_VER < 0x514 // VC7
# include <iostream.h>

View File

@ -0,0 +1,12 @@
--- cvstree/main.cpp.orig 2002-07-10 22:43:47.000000000 +0900
+++ cvstree/main.cpp 2012-11-06 16:21:19.000000000 +0900
@@ -1,6 +1,7 @@
-#include <stdio.h>
+#include <cstdio>
#include "getopt.h"
-#include <errno.h>
+#include <cerrno>
+#include <cstdlib>
using namespace std;
#if defined(_MSC_VER) && _MSC_VER < 0x514 && __GNUC__<3 // VC7 and gcc 3

View File

@ -28,7 +28,8 @@
- LIBS="$LIBS -L$GSSAPI/lib -lgssapi -lkrb5 -lasn1 -ldes -lroken"
+ LIBS="$LIBS -L$GSSAPI/lib -lgssapi -lkrb5 -lasn1 -lcrypto -lroken -lcrypt -lcom_err"
else
LIBS="$LIBS -L$GSSAPI/lib -lgssapi_krb5 -lkrb5 -lcrypto -lcom_err"
- LIBS="$LIBS -L$GSSAPI/lib -lgssapi_krb5 -lkrb5 -lcrypto -lcom_err"
+ LIBS="$LIBS -L$GSSAPI/lib -lgssapi_krb5 -lgssapi -lkrb5 -lasn1 -lcrypto -lroken -lcrypt -lcom_err"
fi
save_CPPFLAGS=$CPPFLAGS
CPPFLAGS="-I$GSSAPI/include $CPPFLAGS"

View File

@ -1,6 +1,23 @@
--- cvsunix/lib/Makefile.in.orig Thu Nov 7 19:29:36 2002
+++ cvsunix/lib/Makefile.in Tue Jul 1 04:38:17 2003
@@ -200,6 +200,7 @@
@@ -125,6 +125,7 @@
CC = @CC@
CXX = @CXX@
CFLAGS = @CFLAGS@
+CXXFLAGS = @CXXFLAGS@
CPPFLAGS=
YACC = @YACC@
@@ -135,7 +136,7 @@
.cpp.o:
$(CXX) $(CPPFLAGS) -I.. -I$(srcdir) -I$(cvs_srcdir) \
- $(DEFS) $(CFLAGS) -c $<
+ $(DEFS) $(CXXFLAGS) -c $<
.SUFFIXES:
.SUFFIXES: .c .cpp .o .obj
@@ -200,6 +201,7 @@
regex.o: regex.h
md5.o: md5.h
argmatch.o: cvsgui.h

View File

@ -1,19 +0,0 @@
--- make_configure.orig Thu Nov 7 19:42:00 2002
+++ make_configure Wed Nov 22 15:07:42 2006
@@ -1,14 +1,4 @@
-aclocal
-autoheader
-
-list=`find . -name Makefile.am -exec dirname {} \;`
-
-for subdir in $list
-do
- echo making $subdir/Makefile.in
- automake --add-missing --gnu $subdir/Makefile
-done
-
-autoconf
+cd cvsunix && %%AUTORECONF%%
+cd ..
./configure $*

View File

@ -1,6 +1,16 @@
--- rf/uwidget.cpp.orig 2003-01-14 19:07:42.000000000 +0100
+++ rf/uwidget.cpp 2007-11-22 20:06:28.000000000 +0100
@@ -231,23 +231,23 @@
@@ -24,7 +24,8 @@
#include "config.h"
#endif
-#include <stdio.h>
+#include <cstdio>
+#include <cstdlib>
#include "uwidget.h"
#include "uconsole.h"
@@ -231,23 +232,23 @@
static void gtkclicked(GtkButton *button, gpointer user_data)
{
@ -30,7 +40,7 @@
gchar *text;
gtk_clist_get_text(GTK_CLIST(clist), row, column, &text);
UEventSendMessage(widid, EV_LIST_SELECTING, UMAKEINT(cmdid, row), text);
@@ -255,15 +255,15 @@
@@ -255,15 +256,15 @@
static void gtkselectclistcolumn(GtkCList *clist, gint column, gpointer user_data)
{
@ -50,7 +60,7 @@
if (event->type == GDK_2BUTTON_PRESS)
{
UEventSendMessage(widid, EV_LIST_DBLCLICK, cmdid, 0L);
@@ -274,8 +274,8 @@
@@ -274,8 +275,8 @@
static void gtkcomboclicked(GtkWidget *widget, gpointer user_data)
{
@ -61,7 +71,7 @@
GtkList *list = GTK_LIST(widget->parent);
GList *selection = list->selection;
@@ -320,8 +320,8 @@
@@ -320,8 +321,8 @@
static void gtkmenuactivated(GtkWidget *widget, gpointer user_data)
{
@ -72,7 +82,7 @@
UStr selTxt;
@@ -392,7 +392,7 @@
@@ -392,7 +393,7 @@
static void dataForeach(GQuark key_id, gpointer data, gpointer user_data)
{
const char *str = g_quark_to_string(key_id);
@ -81,7 +91,7 @@
int cmd;
if(matchToken(str, cmd))
{
@@ -514,32 +514,32 @@
@@ -514,32 +515,32 @@
static void gtktreeexpand(GtkWidget *item, gpointer user_data)
{
@ -122,7 +132,7 @@
g_assert(GTK_IS_TREE_ITEM(item));
UEventSendMessage(widid, EV_TREE_SELECTING, UMAKEINT(cmdid, 1), item);
}
@@ -661,8 +661,8 @@
@@ -661,8 +662,8 @@
gint page_num,
gpointer data)
{
@ -133,7 +143,7 @@
UEventSendMessage(widid, EV_PAGE_CHANGED, UMAKEINT(cmdid, page_num), 0L);
}
@@ -682,8 +682,8 @@
@@ -682,8 +683,8 @@
static gint gtkexposeevent(GtkWidget *widget, GdkEvent *event, gpointer user_data)
{
@ -144,7 +154,7 @@
UEventSendMessage(widid, EV_CUSTOM_DRAW, cmdid, event);
return TRUE;
@@ -782,7 +782,7 @@
@@ -782,7 +783,7 @@
m_listeners.push_back(listener);
}
@ -153,7 +163,7 @@
{
std::vector<UCmdTarget *>::iterator i;
for(i = m_listeners.begin(); i != m_listeners.end(); ++i)
@@ -3136,10 +3136,10 @@
@@ -3136,10 +3137,10 @@
if(!GTK_IS_CLIST(w))
return;

View File

@ -19,8 +19,6 @@ lib/cvs/contrib/rcs-to-cvs
lib/cvs/contrib/rcs2log
lib/cvs/contrib/rcslock
lib/cvs/contrib/sccs2rcs
@dirrm lib/cvs/contrib
@dirrm lib/cvs
%%DATADIR%%/ChangeRoot.tcl
%%DATADIR%%/ChangeRootTK.tcl
%%DATADIR%%/Cleanup.tcl
@ -45,7 +43,6 @@ lib/cvs/contrib/sccs2rcs
%%DATADIR%%/cvs2cl.tcl
%%DATADIR%%/cvsignore_add.tcl
%%DATADIR%%/cvsignore_remove.tcl
%%DATADIR%%/startup.tcl
%%DATADIR%%/pixmaps/about.xpm
%%DATADIR%%/pixmaps/add.xpm
%%DATADIR%%/pixmaps/addb.xpm
@ -88,5 +85,8 @@ lib/cvs/contrib/sccs2rcs
%%DATADIR%%/pixmaps/upfolder.xpm
%%DATADIR%%/pixmaps/warning.xpm
%%DATADIR%%/pixmaps/watch.xpm
%%DATADIR%%/startup.tcl
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%
@dirrm lib/cvs/contrib
@dirrm lib/cvs