- Update to 1.2.9

- Update pkg-descr
- Make happy portlint

Approved by:	miwi@ (mentor)
This commit is contained in:
Sofian Brabez 2011-08-18 22:38:48 +00:00
parent a29ac509e6
commit ffbbeb4e91
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=279989
4 changed files with 21 additions and 75 deletions

View File

@ -6,11 +6,11 @@
#
PORTNAME= libssh2
PORTVERSION= 1.2.8
PORTREVISION= 2
PORTVERSION= 1.2.9
PORTEPOCH= 2
CATEGORIES= security devel
MASTER_SITES= http://www.libssh2.org/download/
MASTER_SITES= http://www.libssh2.org/download/ \
${MASTER_SITE_LOCAL:S,%SUBDIR%,sbz,}
MAINTAINER= sbz@FreeBSD.org
COMMENT= A library implementing the SSH2 protocol
@ -86,8 +86,8 @@ MAN3= libssh2_agent_connect.3 \
libssh2_channel_receive_window_adjust2.3 \
libssh2_channel_request_pty.3 \
libssh2_channel_request_pty_ex.3 \
libssh2_channel_request_pty_size_ex.3 \
libssh2_channel_request_pty_size.3 \
libssh2_channel_request_pty_size_ex.3 \
libssh2_channel_send_eof.3 \
libssh2_channel_set_blocking.3 \
libssh2_channel_setenv.3 \
@ -107,23 +107,22 @@ MAN3= libssh2_agent_connect.3 \
libssh2_channel_x11_req_ex.3 \
libssh2_exit.3 \
libssh2_free.3 \
libssh2_free_host_entry.3 \
libssh2_host_entry_match.3 \
libssh2_hostkey_hash.3 \
libssh2_init.3 \
libssh2_keepalive_config.3 \
libssh2_keepalive_send.3 \
libssh2_knownhost_add.3 \
libssh2_knownhost_addc.3 \
libssh2_knownhost_check.3 \
libssh2_knownhost_checkp.3 \
libssh2_knownhost_del.3 \
libssh2_knownhost_get.3 \
libssh2_knownhost_free.3 \
libssh2_knownhost_get.3 \
libssh2_knownhost_init.3 \
libssh2_knownhost_readfile.3 \
libssh2_knownhost_readline.3 \
libssh2_knownhost_writefile.3 \
libssh2_knownhost_writeline.3 \
libssh2_new_host_entry.3 \
libssh2_poll.3 \
libssh2_poll_channel_read.3 \
libssh2_publickey_add.3 \
@ -146,6 +145,7 @@ MAN3= libssh2_agent_connect.3 \
libssh2_session_flag.3 \
libssh2_session_free.3 \
libssh2_session_get_blocking.3 \
libssh2_session_get_timeout.3 \
libssh2_session_hostkey.3 \
libssh2_session_init.3 \
libssh2_session_init_ex.3 \
@ -154,10 +154,11 @@ MAN3= libssh2_agent_connect.3 \
libssh2_session_method_pref.3 \
libssh2_session_methods.3 \
libssh2_session_set_blocking.3 \
libssh2_session_set_timeout.3 \
libssh2_session_startup.3 \
libssh2_sftp_close.3 \
libssh2_sftp_closedir.3 \
libssh2_sftp_close_handle.3 \
libssh2_sftp_closedir.3 \
libssh2_sftp_fsetstat.3 \
libssh2_sftp_fstat.3 \
libssh2_sftp_fstat_ex.3 \
@ -168,8 +169,8 @@ MAN3= libssh2_agent_connect.3 \
libssh2_sftp_mkdir.3 \
libssh2_sftp_mkdir_ex.3 \
libssh2_sftp_open.3 \
libssh2_sftp_opendir.3 \
libssh2_sftp_open_ex.3 \
libssh2_sftp_opendir.3 \
libssh2_sftp_read.3 \
libssh2_sftp_readdir.3 \
libssh2_sftp_readdir_ex.3 \
@ -209,6 +210,11 @@ MAN3= libssh2_agent_connect.3 \
libssh2_userauth_publickey_fromfile_ex.3 \
libssh2_version.3
# allow maintainer to generate MAN3 manpages list (make extract is required before)
x-generate-man3:
@(cd ${WRKSRC}/docs && ${LS} -1F *.3 | ${SORT} | ${CUT} -d '/' -f4 \
| ${GREP} -v template)
post-patch:
@${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in

View File

@ -1,2 +1,2 @@
SHA256 (libssh2-1.2.8.tar.gz) = adc6f7de1e50c3ac369931b67d69a937a7c8c1f362df6b0a84667fbbd91c403d
SIZE (libssh2-1.2.8.tar.gz) = 637707
SHA256 (libssh2-1.2.9.tar.gz) = fc05ef82ce05562b7ba6483098aae99b3d1dd1522c478d76ff7547859d6bd664
SIZE (libssh2-1.2.9.tar.gz) = 642150

View File

@ -1,60 +0,0 @@
From: Daniel Stenberg <daniel@haxx.se>
Date: Wed, 6 Apr 2011 10:03:11 +0000 (+0200)
Subject: configure: fix $VERSION
X-Git-Url: http://git.libssh2.org/?p=libssh2.git;a=commitdiff_plain;h=f0a37bdadc311b83fcb2ccafad4827016abe5d18;js=1
configure: fix $VERSION
Stop using the $VERSION variable as it seems to be magically used by
autoconfig itself and thus gets set to the value set in AC_INIT()
without us wanting that. $LIBSSH2VER is now the libssh2 version as
detected.
Reported by: Paul Howarth
Bug: http://www.libssh2.org/mail/libssh2-devel-archive-2011-04/0008.shtml
---
diff --git a/configure.ac b/configure.ac
index 9bdf3b9..46c6cfa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,12 +15,14 @@ if test "x$SED" = "xsed-was-not-found-by-configure"; then
fi
dnl figure out the libssh2 version
-VERSION=`$SED -ne 's/^#define LIBSSH2_VERSION *"\(.*\)"/\1/p' ${srcdir}/include/libssh2.h`
+LIBSSH2VER=`$SED -ne 's/^#define LIBSSH2_VERSION *"\(.*\)"/\1/p' ${srcdir}/include/libssh2.h`
AM_INIT_AUTOMAKE
AC_MSG_CHECKING([libssh2 version])
-AC_MSG_RESULT($VERSION)
+AC_MSG_RESULT($LIBSSH2VER)
-AB_VERSION=$VERSION
+AC_SUBST(LIBSSH2VER)
+
+AB_VERSION=$LIBSSH2VER
AB_INIT
@@ -289,7 +291,7 @@ AC_OUTPUT
AC_MSG_NOTICE([summary of build options:
- version: ${VERSION}
+ version: ${LIBSSH2VER}
Host type: ${host}
Install prefix: ${prefix}
Compiler: ${CC}
diff --git a/libssh2.pc.in b/libssh2.pc.in
index 013e6bf..eaef88b 100644
--- a/libssh2.pc.in
+++ b/libssh2.pc.in
@@ -10,7 +10,7 @@ includedir=@includedir@
Name: libssh2
URL: http://www.libssh2.org/
Description: Library for SSH based connunication
-Version: @VERSION@
+Version: @LIBSSH2VER@
Libs: -L${libdir} -lssh2 @LDFLAGS@ @LIBS@
Libs.private: @LIBS@
Cflags: -I${includedir}

View File

@ -1,5 +1,5 @@
libssh2 is a library implementing the SSH2 protocol as defined by
Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25), SECSH-CONNECTION(23),
SECSH-ARCH(20), SECSH-FILEXFER(06)*, SECSH-DHGEX(04), and SECSH-NUMBERS(10).
libssh2 is a client-side C library implementing the SSH2 protocol. It supports
regular terminal, SCP and SFTP sessions; port forwarding; password, key-based
and keyboard-interactive authentication.
WWW: http://www.libssh2.org/