Don't clobber config files on update.
PR: 111923 Submitted by: emaste
This commit is contained in:
parent
0128e7b31f
commit
ffba539fe7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=194210
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= unixODBC
|
||||
PORTVERSION= 2.2.12
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.unixodbc.org/
|
||||
|
||||
@ -56,5 +56,10 @@ post-install:
|
||||
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
|
||||
.endif
|
||||
.endif
|
||||
.for conffile in odbc.ini odbcinst.ini
|
||||
@if [ ! -f ${PREFIX}/etc/${conffile} ]; then \
|
||||
${CP} -p ${PREFIX}/etc/${conffile}.sample ${PREFIX}/etc/${conffile} ; \
|
||||
fi
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
13
databases/unixODBC/files/patch-Makefile.in
Normal file
13
databases/unixODBC/files/patch-Makefile.in
Normal file
@ -0,0 +1,13 @@
|
||||
--- Makefile.in.orig Sun Jun 24 15:44:33 2007
|
||||
+++ Makefile.in Sun Jun 24 15:45:04 2007
|
||||
@@ -876,8 +876,8 @@
|
||||
|
||||
|
||||
install-data-am:
|
||||
- -touch $(DESTDIR)${sysconfdir}/odbcinst.ini
|
||||
- -touch $(DESTDIR)${sysconfdir}/odbc.ini
|
||||
+ -touch $(DESTDIR)${sysconfdir}/odbcinst.ini.sample
|
||||
+ -touch $(DESTDIR)${sysconfdir}/odbc.ini.sample
|
||||
-mkdir -p $(DESTDIR)${sysconfdir}/ODBCDataSources
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
@ -7,8 +7,12 @@ bin/iusql
|
||||
bin/odbc_config
|
||||
bin/odbcinst
|
||||
%%GUI:%%bin/odbctest
|
||||
etc/odbc.ini
|
||||
etc/odbcinst.ini
|
||||
@unexec if cmp -s %D/etc/odbc.ini %D/etc/odbc.ini.sample; then rm -f %D/etc/odbc.ini; fi
|
||||
etc/odbc.ini.sample
|
||||
@exec [ -f %D/etc/odbc.ini ] || cp %D/etc/odbc.ini.sample %D/etc/odbc.ini
|
||||
@unexec if cmp -s %D/etc/odbcinst.ini %D/etc/odbcinst.ini.sample; then rm -f %D/etc/odbcinst.ini; fi
|
||||
etc/odbcinst.ini.sample
|
||||
@exec [ -f %D/etc/odbcinst.ini ] || cp %D/etc/odbcinst.ini.sample %D/etc/odbcinst.ini
|
||||
include/autotest.h
|
||||
include/odbcinst.h
|
||||
include/odbcinstext.h
|
||||
|
Loading…
Reference in New Issue
Block a user