add libv3d 0.1.7

V3D IO Library
This commit is contained in:
Ying-Chieh Liao 2002-07-02 18:49:58 +00:00
parent 39c52f913a
commit ff8cd31b75
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62361
7 changed files with 131 additions and 0 deletions

View File

@ -187,6 +187,7 @@
SUBDIR += librsvg
SUBDIR += librsvg2
SUBDIR += libungif
SUBDIR += libv3d
SUBDIR += libwmf
SUBDIR += libxine
SUBDIR += linplasma

87
graphics/libv3d/Makefile Normal file
View File

@ -0,0 +1,87 @@
# ex:ts=8
# Ports collection makefile for: libv3d
# Date Created: Jul 2, 2002
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= libv3d
PORTVERSION= 0.1.7
CATEGORIES= graphics
MASTER_SITES= ftp://wolfpack.twu.net/users/wolfpack/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
USE_REINPLACE= yes
USE_MESA= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= UNIX --prefix=${PREFIX}
USE_GMAKE= yes
INSTALLS_SHLIB= yes
MAN3= V3DGLInterpriteDelete.3 \
V3DGLInterpriteNew.3 \
V3DGLProcessModel.3 \
V3DGLProcessModelExtra.3 \
V3DGLResourceDelete.3 \
V3DGLResourceGetInterpritation.3 \
V3DGLResourceNew.3 \
V3DGLResourceNewFromModelData.3 \
V3DGLResourceSetInterpritation.3 \
V3DHFGetHeightFromWorldPosition.3 \
V3DHFLoadFromFile.3 \
V3DIntro.3 \
V3DLoadModel.3 \
V3DMHCreate.3 \
V3DMHDestroy.3 \
V3DMHHeightfieldBaseDirectoryGet.3 \
V3DMHHeightfieldBaseDirectorySet.3 \
V3DMHListDelete.3 \
V3DMHListDeleteAll.3 \
V3DMHListGetPtr.3 \
V3DMHListInsert.3 \
V3DMHTextureBaseDirectoryGet.3 \
V3DMHTextureBaseDirectorySet.3 \
V3DMPCreate.3 \
V3DMPDestroy.3 \
V3DMPDup.3 \
V3DMPFlipWinding.3 \
V3DMPGetNormal.3 \
V3DMPGetTexCoord.3 \
V3DMPGetTotal.3 \
V3DMPGetVertex.3 \
V3DMPListGetPtr.3 \
V3DMPListInsert.3 \
V3DMPUnitlizeNormal.3 \
V3DModelCreate.3 \
V3DModelDestroy.3 \
V3DModelDup.3 \
V3DModelListDelete.3 \
V3DModelListDeleteAll.3 \
V3DModelListGetPtr.3 \
V3DModelListInsert.3 \
V3DSaveModel.3 \
V3DTextureDestroy.3 \
V3DTextureLoadFromData1D.3 \
V3DTextureLoadFromData2D.3 \
V3DTextureLoadFromFile2D.3 \
V3DTextureLoadFromFile2DPreempt.3 \
V3DTexturePriority.3 \
V3DTextureSelect.3 \
V3DTextureSelectFrame.3 \
v3d_glinterprite_struct.3 \
v3d_glresource_struct.3 \
v3d_hf_options_struct.3 \
v3d_texture_ref_struct.3
post-patch:
@${REINPLACE_CMD} -e "s,make,${GMAKE},g" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s,%%CFLAGS%%,${CFLAGS},g" \
-e "s,%%X11BASE%%,${X11BASE},g" \
-e "s,%%PTHREAD_CFLAGS%%,${PTHREAD_CFLAGS},g" \
-e "s,%%PTHREAD_LIBS%%,${PTHREAD_LIBS},g" \
${WRKSRC}/libv3d/platforms.ini
.include <bsd.port.mk>

1
graphics/libv3d/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (libv3d-0.1.7.tgz) = 3492f56aa1b2d13c7c2be6736a4896a8

View File

@ -0,0 +1,24 @@
--- libv3d/platforms.ini.orig Wed Jul 3 02:37:49 2002
+++ libv3d/platforms.ini Wed Jul 3 02:42:55 2002
@@ -23,8 +23,7 @@
Platform = UNIX
Description = For most any UNIX system
PREFIX = /usr/
- CFLAGS = -Wall -O6 -funroll-loops -fomit-frame-pointer -ffast-math \
--D__USE_BSD
+ CFLAGS = %%CFLAGS%% -D__USE_BSD
LIBS = -lm
LIB_DIR =
CC = cc
@@ -65,8 +64,9 @@
PlatformFeature = opengl
Description = An implementation of OpenGL (ie Mesa3D)
MustExist = Yes
- FeatureLIBS = -lGL -lGLU
- FeatureLIB_DIR = -L/usr/X11R6/lib/
+ FeatureCFLAGS = -I%%X11BASE%%/include %%PTHREAD_CFLAGS%%
+ FeatureLIBS = -lGL -lGLU %%PTHREAD_LIBS%%
+ FeatureLIB_DIR = -L%%X11BASE%%/lib/
FeatureDepend = gl-lib
DependType = Library
MustExist = Yes

View File

@ -0,0 +1 @@
V3D IO Library

View File

@ -0,0 +1,6 @@
The V3D IO Library (commonly known as libv3d) is used by third party
applications to read and write .v3d model files. You do need this library
if you have other programs that depend on libv3d to read and write .v3d
files.
WWW: http://wolfpack.twu.net/Vertex/libv3d.html

11
graphics/libv3d/pkg-plist Normal file
View File

@ -0,0 +1,11 @@
include/v3d/v3d.h
include/v3d/v3dfio.h
include/v3d/v3dgl.h
include/v3d/v3dhf.h
include/v3d/v3dmh.h
include/v3d/v3dmodel.h
include/v3d/v3dmp.h
include/v3d/v3dtex.h
@dirrm include/v3d
lib/libv3d.so
lib/libv3d.so.0.1.7