Remove expired port:

2016-04-07 accessibility/gnopernicus: Not developed upstream anymore. Obsoleted by accessibility/orca
This commit is contained in:
Rene Ladan 2016-04-08 19:27:43 +00:00
parent 88eb30eec1
commit ff36f58b45
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=412783
10 changed files with 1 additions and 315 deletions

1
MOVED
View File

@ -8273,3 +8273,4 @@ textproc/py-genshi-devel|textproc/py-genshi|2016-03-31|Has expired: The port is
www/py-satchmo||2016-04-03|Has expired: Project development unmaintained
www/py-ua-parser|devel/py-ua_parser|2016-04-04|Duplicate port deleted
net-mgmt/weathermap||2016-04-04|Has expired: Distfile unavailable, website no longer exists
accessibility/gnopernicus|accessibility/orca|2016-04-08|Has expired: Not developed upstream anymore. Obsoleted by accessibility/orca

View File

@ -16,7 +16,6 @@
SUBDIR += eflite
SUBDIR += gnome-mag
SUBDIR += gnome-speech
SUBDIR += gnopernicus
SUBDIR += gok
SUBDIR += java-access-bridge
SUBDIR += jovie

View File

@ -1,42 +0,0 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/accessibility/gnopernicus/Makefile,v 1.85 2007/07/23 19:03:49 mezz Exp $
PORTNAME= gnopernicus
PORTVERSION= 1.1.2
PORTREVISION= 12
CATEGORIES= accessibility x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Collection of accessibility apps for GNOME 2
DEPRECATED= Not developed upstream anymore. Obsoleted by accessibility/orca
EXPIRATION_DATE= 2016-04-07
LIB_DEPENDS= libgnome-mag.so:accessibility/gnome-mag
USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
USE_XORG= x11
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_GNOME= gnomeprefix intlhack libgnomeui atspi gnomespeech
GNU_CONFIGURE= yes
CONFIGURE_ARGS= X_LIBS=-lX11
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= SED="${SED}"
INSTALL_TARGET= install-strip
GCONF_SCHEMAS= brlmonitor.schemas gnopernicus.schemas remote.schemas
post-patch:
@${REINPLACE_CMD} -e 's|^F||' \
${WRKSRC}/help/braille_monitor/C/brlmonitor-C.omf \
${WRKSRC}/help/braille_monitor/es/brlmonitor-es.omf
@${CP} ${FILESDIR}/gnopernicus-mag-config ${WRKSRC}/gnopi
@${REINPLACE_CMD} -e 's|test$$||' ${WRKSRC}/*/Makefile.in
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (gnome2/gnopernicus-1.1.2.tar.bz2) = 88a750ead047e52ee3c655bd4d5947d9131619ecbf56bc1977c8a3bf6e4f5214
SIZE (gnome2/gnopernicus-1.1.2.tar.bz2) = 1578754

View File

@ -1,66 +0,0 @@
#!/bin/sh
GNOPI_RES_X=`gconftool-2 --get /apps/gnopernicus/magnifier/schema1/generic_zoomer/display_size_x`
GNOPI_RES_Y=`gconftool-2 --get /apps/gnopernicus/magnifier/schema1/generic_zoomer/display_size_y`
OLD_SOURCE=`gconftool-2 --get /apps/gnopernicus/magnifier/schema1/generic_zoomer/source`
OLD_TARGET=`gconftool-2 --get /apps/gnopernicus/magnifier/schema1/generic_zoomer/target`
SPLITSCREEN_RES_X=`expr $GNOPI_RES_X / 2`
if test $# -eq 0; then
echo "Usage: gnopernicus-magnifier [-s] [-t] [[-F] | [-S]]
-s source_display Sets the magnifier source display screen. Eg (:0.0)
-t target_display Sets the magnifier target display screen. Eg (:0.0)
-F Sets the magnifier placement so it will cover the
whole screen (Fullscreen).
-S Sets the magnifier placement so it will cover the right
vertical half of the screen (Vertical Split Screen).
Note: When doing a full scren magnification, the source/target screens
have to be set before the full-screen mode and their values have to be different"
exit 1
fi
while getopts ":FSs:at:b" Option
do
case $Option in
F)
echo "FullScreen"
if test "x$OLD_SOURCE" = "x$OLD_TARGET"; then
echo "Source and target are the same.Please set them different first"
exit 1
fi
echo "Setting fullscreen mode."
gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_left 0
gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_top 0
gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_width $GNOPI_RES_X
gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_height $GNOPI_RES_Y
;;
S)
echo "Setting vertical split screen mode."
gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_left $SPLITSCREEN_RES_X
gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_top 0
gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_width $GNOPI_RES_X
gconftool-2 --set --type=int /apps/gnopernicus/magnifier/schema1/generic_zoomer/zp_height $GNOPI_RES_Y
;;
s)
echo "Setting magnifier source screen value from [$OLD_SOURCE] to [$OPTARG]"
gconftool-2 --set --type=string /apps/gnopernicus/magnifier/schema1/generic_zoomer/source $OPTARG
OLD_SOURCE=$OPTARG
;;
t)
echo "Setting magnifier target screen value from [$OLD_TARGET] to [$OPTARG]"
gconftool-2 --set --type=string /apps/gnopernicus/magnifier/schema1/generic_zoomer/target $OPTARG
OLD_TARGET=$OPTARG
;;
*)
echo "Not handled!"
;;
esac
done
shift $(($OPTIND - 1))

View File

@ -1,21 +0,0 @@
--- configure.orig Mon Jan 9 15:02:42 2006
+++ configure Mon Jan 9 15:04:48 2006
@@ -21635,11 +21635,17 @@
TTYNAME_2="/dev/cua/c"
TTYNAME_3="/dev/cua/d"
;;
- FreeBSD-*)
+ FreeBSD-4*|FreeBSD-5*)
TTYNAME_0="/dev/cuaa0"
TTYNAME_1="/dev/cuaa1"
TTYNAME_2="/dev/cuaa2"
TTYNAME_3="/dev/cuaa3"
+ ;;
+ FreeBSD-*)
+ TTYNAME_0="/dev/cuad0"
+ TTYNAME_1="/dev/cuad1"
+ TTYNAME_2="/dev/cuaU0"
+ TTYNAME_3="/dev/cuaU1"
;;
*)
echo "Can't figure out the name of the serial port on this OS"

View File

@ -1,12 +0,0 @@
--- srcore/srspc.c.orig Sun May 8 01:10:29 2005
+++ srcore/srspc.c Sun May 8 01:10:37 2005
@@ -1531,8 +1531,8 @@ src_timeout_start_speech (gpointer data)
static void
src_restart_speech ()
{
- g_printerr ("\nRestarting speech.\n");
gboolean use_speech = FALSE;
+ g_printerr ("\nRestarting speech.\n");
SET_SRCORE_CONFIG_DATA (SRCORE_SPEECH_ACTIVE, CFGT_BOOL, &use_speech);
g_timeout_add (SRC_SPEECH_RESTART_TIMEOUT, src_timeout_start_speech, NULL);
}

View File

@ -1,13 +0,0 @@
--- srlow/libsrlow/SRLow.c.orig Mon Jun 27 04:14:03 2005
+++ srlow/libsrlow/SRLow.c Mon Jun 27 04:14:18 2005
@@ -666,8 +666,9 @@ srl_get_focused_cell (Accessible *acc_ta
for (i = rows; !rv && i <= rowe && count < SRL_MAX_CHILDREN_CNT; i++)
for (j = cols; !rv && j <= cole && count < SRL_MAX_CHILDREN_CNT; j++)
{
+ Accessible *cell;
count++;
- Accessible *cell = AccessibleTable_getAccessibleAt (table, i, j);
+ cell = AccessibleTable_getAccessibleAt (table, i, j);
if (cell)
{
if (srl_acc_has_state (cell, SPI_STATE_FOCUSED))

View File

@ -1,4 +0,0 @@
Gnopernicus provides Assistive Technologies (AT) for blind and visually
impaired persons through modules for text-to-speech, braille, etc.
WWW: http://www.baum.ro/gnopernicus.html

View File

@ -1,154 +0,0 @@
bin/gnopernicus
bin/gnopernicus-mag-config
bin/srcore
etc/gnopernicus-1.0/translation_tables/de.a2b
etc/gnopernicus-1.0/translation_tables/en_US.a2b
etc/gnopernicus-1.0/translation_tables/es.a2b
etc/gnopernicus-1.0/translation_tables/fr.a2b
etc/gnopernicus-1.0/translation_tables/sv.a2b
include/gnopernicus-1.0/libbrl/brlxmlapi.h
include/gnopernicus-1.0/libke/libke.h
include/gnopernicus-1.0/libmag/magxmlapi.h
include/gnopernicus-1.0/libsrconf/libsrconf.h
include/gnopernicus-1.0/libsrlow/SRLow.h
include/gnopernicus-1.0/libsrlow/SRObject.h
include/gnopernicus-1.0/libsrlow/screen-review.h
include/gnopernicus-1.0/libsrs/srs-xml.h
include/gnopernicus-1.0/libsrutil/SREvent.h
include/gnopernicus-1.0/libsrutil/SRMessages.h
include/gnopernicus-1.0/libsrutil/srintl.h
include/gnopernicus-1.0/libsrutil/sru-debug.h
include/gnopernicus-1.0/libsrutil/sru-glib.h
include/gnopernicus-1.0/libsrutil/sru-module.h
include/gnopernicus-1.0/libsrutil/sru-test.h
include/gnopernicus-1.0/libsrutil/util.h
lib/gnopernicus-1.0/libbrl.so
lib/gnopernicus-1.0/libbrl.so.2
lib/gnopernicus-1.0/libbrl.so.2.0.0
lib/gnopernicus-1.0/libke.so
lib/gnopernicus-1.0/libke.so.2
lib/gnopernicus-1.0/libke.so.2.0.0
lib/gnopernicus-1.0/libmag.so
lib/gnopernicus-1.0/libmag.so.2
lib/gnopernicus-1.0/libmag.so.2.0.0
lib/gnopernicus-1.0/libsrconf.so
lib/gnopernicus-1.0/libsrconf.so.2
lib/gnopernicus-1.0/libsrconf.so.2.0.0
lib/gnopernicus-1.0/libsrlow.so
lib/gnopernicus-1.0/libsrlow.so.2
lib/gnopernicus-1.0/libsrlow.so.2.0.0
lib/gnopernicus-1.0/libsrs.so
lib/gnopernicus-1.0/libsrs.so.2
lib/gnopernicus-1.0/libsrs.so.2.0.0
lib/gnopernicus-1.0/libsrutil.so
lib/gnopernicus-1.0/libsrutil.so.2
lib/gnopernicus-1.0/libsrutil.so.2.0.0
libdata/pkgconfig/gnopernicus-1.0.pc
libexec/brlmonitor
share/applications/gnopernicus.desktop
share/gnopernicus/glade/gnopi_files/Braille_Monitor_Settings/braille_monitor_settings.glade2
share/gnopernicus/glade/gnopi_files/Braille_Settings/attribute_settings.glade2
share/gnopernicus/glade/gnopi_files/Braille_Settings/braille_device.glade2
share/gnopernicus/glade/gnopi_files/Braille_Settings/braille_fill_char.glade2
share/gnopernicus/glade/gnopi_files/Braille_Settings/braille_mapping.glade2
share/gnopernicus/glade/gnopi_files/Braille_Settings/braille_settings.glade2
share/gnopernicus/glade/gnopi_files/Braille_Settings/braille_style.glade2
share/gnopernicus/glade/gnopi_files/Braille_Settings/cursor_settings.glade2
share/gnopernicus/glade/gnopi_files/Braille_Settings/status_cell.glade2
share/gnopernicus/glade/gnopi_files/Braille_Settings/translation_table.glade2
share/gnopernicus/glade/gnopi_files/Find/find.glade2
share/gnopernicus/glade/gnopi_files/Find/text_selected_24.png
share/gnopernicus/glade/gnopi_files/General_Settings/general_settings.glade2
share/gnopernicus/glade/gnopi_files/Keyboard_Mouse_Settings/keyboard_mouse_settings.glade2
share/gnopernicus/glade/gnopi_files/Language/language.glade2
share/gnopernicus/glade/gnopi_files/Load_Default/load_default.glade2
share/gnopernicus/glade/gnopi_files/Magnifier_Settings/magnifier_settings.glade2
share/gnopernicus/glade/gnopi_files/Presentation/presentation.glade2
share/gnopernicus/glade/gnopi_files/Screen_Review/screen_review.glade2
share/gnopernicus/glade/gnopi_files/Speech_Settings/speech_settings.glade2
share/gnopernicus/glade/gnopi_files/User_Properties/user_properties.glade2
share/gnopernicus/glade/gnopi_files/braille.xpm
share/gnopernicus/glade/gnopi_files/gnopi.glade2
share/gnopernicus/glade/gnopi_files/keyboard.xpm
share/gnopernicus/glade/gnopi_files/monitor.png
share/gnopernicus/glade/gnopi_files/start_up.png
share/gnopernicus/presentation/default.xml
share/gnopernicus/presentation/verbose.xml
share/gnome/help/brlmonitor/C/brlmonitor.xml
share/gnome/help/brlmonitor/C/legal.xml
share/gnome/help/brlmonitor/es/brlmonitor.xml
share/gnome/help/brlmonitor/es/legal.xml
share/gnome/help/gnopernicus/C/gnopernicus.xml
share/gnome/help/gnopernicus/C/legal.xml
share/gnome/help/gnopernicus/es/gnopernicus.xml
share/gnome/help/gnopernicus/es/legal.xml
share/gnome/help/gnopernicus/pt_BR/figures/gnopernicus.png
share/gnome/help/gnopernicus/pt_BR/gnopernicus.xml
share/gnome/help/gnopernicus/pt_BR/legal.xml
share/omf/gnopernicus/brlmonitor-C.omf
share/omf/gnopernicus/brlmonitor-es.omf
share/omf/gnopernicus/gnopernicus-C.omf
share/omf/gnopernicus/gnopernicus-es.omf
share/icons/hicolor/48x48/apps/gnopernicus.png
share/locale/ar/LC_MESSAGES/gnopernicus.mo
share/locale/az/LC_MESSAGES/gnopernicus.mo
share/locale/be/LC_MESSAGES/gnopernicus.mo
share/locale/bg/LC_MESSAGES/gnopernicus.mo
share/locale/bn/LC_MESSAGES/gnopernicus.mo
share/locale/bn_IN/LC_MESSAGES/gnopernicus.mo
share/locale/ca/LC_MESSAGES/gnopernicus.mo
share/locale/cs/LC_MESSAGES/gnopernicus.mo
share/locale/cy/LC_MESSAGES/gnopernicus.mo
share/locale/da/LC_MESSAGES/gnopernicus.mo
share/locale/de/LC_MESSAGES/gnopernicus.mo
share/locale/dz/LC_MESSAGES/gnopernicus.mo
share/locale/el/LC_MESSAGES/gnopernicus.mo
share/locale/en_CA/LC_MESSAGES/gnopernicus.mo
share/locale/en_GB/LC_MESSAGES/gnopernicus.mo
share/locale/es/LC_MESSAGES/gnopernicus.mo
share/locale/et/LC_MESSAGES/gnopernicus.mo
share/locale/eu/LC_MESSAGES/gnopernicus.mo
share/locale/fa/LC_MESSAGES/gnopernicus.mo
share/locale/fi/LC_MESSAGES/gnopernicus.mo
share/locale/fr/LC_MESSAGES/gnopernicus.mo
share/locale/ga/LC_MESSAGES/gnopernicus.mo
share/locale/gl/LC_MESSAGES/gnopernicus.mo
share/locale/gu/LC_MESSAGES/gnopernicus.mo
share/locale/hi/LC_MESSAGES/gnopernicus.mo
share/locale/hr/LC_MESSAGES/gnopernicus.mo
share/locale/hu/LC_MESSAGES/gnopernicus.mo
share/locale/id/LC_MESSAGES/gnopernicus.mo
share/locale/it/LC_MESSAGES/gnopernicus.mo
share/locale/ja/LC_MESSAGES/gnopernicus.mo
share/locale/ka/LC_MESSAGES/gnopernicus.mo
share/locale/ko/LC_MESSAGES/gnopernicus.mo
share/locale/lt/LC_MESSAGES/gnopernicus.mo
share/locale/lv/LC_MESSAGES/gnopernicus.mo
share/locale/mn/LC_MESSAGES/gnopernicus.mo
share/locale/mr/LC_MESSAGES/gnopernicus.mo
share/locale/ms/LC_MESSAGES/gnopernicus.mo
share/locale/nb/LC_MESSAGES/gnopernicus.mo
share/locale/ne/LC_MESSAGES/gnopernicus.mo
share/locale/nl/LC_MESSAGES/gnopernicus.mo
share/locale/or/LC_MESSAGES/gnopernicus.mo
share/locale/pa/LC_MESSAGES/gnopernicus.mo
share/locale/pl/LC_MESSAGES/gnopernicus.mo
share/locale/pt/LC_MESSAGES/gnopernicus.mo
share/locale/pt_BR/LC_MESSAGES/gnopernicus.mo
share/locale/ro/LC_MESSAGES/gnopernicus.mo
share/locale/ru/LC_MESSAGES/gnopernicus.mo
share/locale/rw/LC_MESSAGES/gnopernicus.mo
share/locale/sk/LC_MESSAGES/gnopernicus.mo
share/locale/sq/LC_MESSAGES/gnopernicus.mo
share/locale/sr/LC_MESSAGES/gnopernicus.mo
share/locale/sr@Latn/LC_MESSAGES/gnopernicus.mo
share/locale/sv/LC_MESSAGES/gnopernicus.mo
share/locale/ta/LC_MESSAGES/gnopernicus.mo
share/locale/te/LC_MESSAGES/gnopernicus.mo
share/locale/th/LC_MESSAGES/gnopernicus.mo
share/locale/tr/LC_MESSAGES/gnopernicus.mo
share/locale/uk/LC_MESSAGES/gnopernicus.mo
share/locale/vi/LC_MESSAGES/gnopernicus.mo
share/locale/zh_CN/LC_MESSAGES/gnopernicus.mo
share/locale/zh_HK/LC_MESSAGES/gnopernicus.mo
share/locale/zh_TW/LC_MESSAGES/gnopernicus.mo