databases/mariadb100-server: Security update to 10.0.35
- Fix build with aarch64 [1] - Remove new ${name}_limits behavior from 11-STABLE [2] PR: 227628 [1], 227434 [2] Submitted by: Naram Qashat <cyberbotx cyberbotx com> [1] Submitted by: 0mp [2] MFH: 2018Q2 Security: 57aec168-453e-11e8-8777-b499baebfeaf
This commit is contained in:
parent
34100e38f5
commit
ff08698dc8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=468422
@ -1,8 +1,8 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME?= mariadb
|
||||
PORTVERSION= 10.0.34
|
||||
PORTREVISION?= 2
|
||||
PORTVERSION= 10.0.35
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES= databases ipv6
|
||||
MASTER_SITES= http://ftp.osuosl.org/pub/${SITESDIR}/ \
|
||||
http://mirrors.supportex.net/${SITESDIR}/ \
|
||||
@ -22,7 +22,6 @@ LICENSE_NAME_PerconaFT= PerconaFT patents license
|
||||
LICENSE_FILE_PerconaFT= ${WRKSRC}/storage/tokudb/PerconaFT/PATENTS
|
||||
LICENSE_PERMS_PerconaFT= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
|
||||
BROKEN_aarch64= Fails to link: missing sbrk
|
||||
BROKEN_SSL= openssl-devel
|
||||
BROKEN_SSL_REASON_openssl-devel= incomplete definition of type 'struct dh_st'
|
||||
|
||||
@ -117,7 +116,6 @@ ${ENGINE}_CMAKE_OFF= -DWITHOUT_${ENGINE}=1
|
||||
|
||||
CONNECT_EXTRA_LIB_DEPENDS= libodbc.so:databases/unixODBC
|
||||
CONNECT_EXTRA_USE= gnome=libxml2
|
||||
INNOBASE_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-patch-MDEV-15288
|
||||
MAXKEY_EXTRA_PATCHES+= ${FILESDIR}/extra-patch-include_my__compare.h
|
||||
MROONGA_CMAKE_OFF= -DWITHOUT_MROONGA=1
|
||||
MROONGA_LIB_DEPENDS= liblz4.so:archivers/liblz4
|
||||
@ -163,11 +161,10 @@ USE_GCC= yes
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${OPSYS} != FreeBSD || ${OSVERSION} < 1101514 || \
|
||||
${OSVERSION} >= 1200000 && ${OSVERSION} < 1200057
|
||||
SUB_LIST+= LEGACY_LIMITS="" MODERN_LIMITS="@comment "
|
||||
.else
|
||||
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200057
|
||||
SUB_LIST+= LEGACY_LIMITS="@comment " MODERN_LIMITS=""
|
||||
.else
|
||||
SUB_LIST+= LEGACY_LIMITS="" MODERN_LIMITS="@comment "
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1517385452
|
||||
SHA256 (mariadb-10.0.34.tar.gz) = c5bb2a67dcce84ef39b59a63728a3d2a0196226041416491f0bc22d3388173ac
|
||||
SIZE (mariadb-10.0.34.tar.gz) = 69266294
|
||||
TIMESTAMP = 1524825442
|
||||
SHA256 (mariadb-10.0.35.tar.gz) = 401edb2c1e6be0badb94813b3db606ce8e57b6751a7e89f41127b943195ea828
|
||||
SIZE (mariadb-10.0.35.tar.gz) = 66551964
|
||||
|
@ -1,7 +0,0 @@
|
||||
--- storage/innobase/CMakeLists.txt.orig 2018-01-27 18:40:38 UTC
|
||||
+++ storage/innobase/CMakeLists.txt
|
||||
@@ -489,4 +489,3 @@ MYSQL_ADD_PLUGIN(innobase ${INNOBASE_SOU
|
||||
MODULE_OUTPUT_NAME ha_innodb
|
||||
LINK_LIBRARIES ${ZLIB_LIBRARY} ${LINKER_SCRIPT})
|
||||
|
||||
-ADD_DEPENDENCIES(innobase GenError)
|
46
databases/mariadb100-server/files/patch-mysys_stacktrace.c
Normal file
46
databases/mariadb100-server/files/patch-mysys_stacktrace.c
Normal file
@ -0,0 +1,46 @@
|
||||
--- mysys/stacktrace.c.orig 2018-01-27 18:40:37 UTC
|
||||
+++ mysys/stacktrace.c
|
||||
@@ -34,19 +34,19 @@
|
||||
#include <execinfo.h>
|
||||
#endif
|
||||
|
||||
+#ifdef __linux__
|
||||
#define PTR_SANE(p) ((p) && (char*)(p) >= heap_start && (char*)(p) <= heap_end)
|
||||
-
|
||||
static char *heap_start;
|
||||
-
|
||||
-#ifdef HAVE_BSS_START
|
||||
extern char *__bss_start;
|
||||
-#endif
|
||||
+#else
|
||||
+#define PTR_SANE(p) (p)
|
||||
+#endif /* __linux */
|
||||
|
||||
void my_init_stacktrace()
|
||||
{
|
||||
-#ifdef HAVE_BSS_START
|
||||
+#ifdef __linux__
|
||||
heap_start = (char*) &__bss_start;
|
||||
-#endif
|
||||
+#endif /* __linux__ */
|
||||
}
|
||||
|
||||
#ifdef __linux__
|
||||
@@ -149,15 +149,15 @@ static int safe_print_str(const char *ad
|
||||
|
||||
int my_safe_print_str(const char* val, int max_len)
|
||||
{
|
||||
+#ifdef __linux__
|
||||
char *heap_end;
|
||||
|
||||
-#ifdef __linux__
|
||||
// Try and make use of /proc filesystem to safely print memory contents.
|
||||
if (!safe_print_str(val, max_len))
|
||||
return 0;
|
||||
-#endif
|
||||
|
||||
heap_end= (char*) sbrk(0);
|
||||
+#endif
|
||||
|
||||
if (!PTR_SANE(val))
|
||||
{
|
Loading…
Reference in New Issue
Block a user