Update to upstream release 1.0.1, fix build on 11.2
Detailed submitter log: - Update to 1.0.1 - Switched to Github - Has newest sources - Updated WWW in pkg-desc - Current www doesn't exist - Removed doc depends/build - Does not build/install - Removed doxygen dir - Not needed/used PR: 230833 [1], 230674 [2] Submitted by: ndowens@yahoo.com [1] Reported by: lantw44@gmail.com [2] MFH: 2018Q3
This commit is contained in:
parent
f8345e011f
commit
ff02b29f46
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=478020
@ -2,41 +2,47 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= blitz++
|
||||
PORTVERSION= 0.9
|
||||
PORTREVISION= 9
|
||||
PORTVERSION= 1.0.1
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= SF/blitz/blitz/Blitz%2B%2B%20${PORTVERSION}
|
||||
DISTNAME= blitz-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= C++ class library for scientific computing
|
||||
|
||||
LICENSE= GPLv3 BSD3CLAUSE
|
||||
LICENSE_COMB= multi
|
||||
|
||||
BROKEN_FreeBSD_12= fails to compile: ../blitz/blitz.h:58:12: 'iostream.h' file not found
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
DOCS_USE= TEX=dvipsk,formats
|
||||
DOCS_USES= makeinfo
|
||||
DOCS_INFO= blitz
|
||||
DOCS_BUILD_DEPENDS= texi2dvi:print/texinfo \
|
||||
texi2html:textproc/texi2html
|
||||
DOCS_MAKE_ARGS_OFF= NOPORTDOCS=yes
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USES= libtool pathfix gmake
|
||||
CONFIGURE_ARGS= --with-cxx=gcc --disable-doxygen --enable-shared
|
||||
MAKE_ARGS+= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
|
||||
AUTOHEADER="${TRUE}"
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
DOCSDIR= ${PREFIX}/share/doc/blitz
|
||||
|
||||
USES= gmake libtool pathfix python
|
||||
USE_LDCONFIG= yes
|
||||
CONFIGURE_ARGS= --enable-shared CXX_OPTIMIZE_FLAGS="${CFLAGS}"
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= blitzpp
|
||||
GH_PROJECT= blitz
|
||||
|
||||
PORTDOCS= AUTHORS ChangeLog* LEGAL README NEWS \
|
||||
README.binutils TODO doc/*.txt
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
OPTIONS_SUB= yes
|
||||
DOCS_INFO= blitz
|
||||
DOCS_SUB_PLIST= ""
|
||||
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|g++|\$${CXX}|g ; \
|
||||
s|"-ftemplate-depth-30|"\$${CXXFLAGS} -ftemplate-depth-30|g ; \
|
||||
s|-O2||g' ${WRKSRC}/configure
|
||||
s|-O3|-O2|g ; s|-funroll-loops||g' ${WRKSRC}/configure
|
||||
${REINPLACE_CMD} -e 's,python,${PYTHON_CMD},' ${WRKSRC}/blitz/generate/Makefile.in
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
|
||||
|
||||
post-install:
|
||||
@${RM} -r ${STAGEDIR}${PREFIX}/share/doc/blitz-0.10
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (blitz-0.9.tar.gz) = 88b7c5e062b06767d04511776cf706316026b9357b128e126be88935626d2bcb
|
||||
SIZE (blitz-0.9.tar.gz) = 3124301
|
||||
TIMESTAMP = 1534896128
|
||||
SHA256 (blitzpp-blitz-1.0.1_GH0.tar.gz) = b62fc3f07b64b264307b01fec5e4f2793e09a68dcb5378984aedbc2e4b3adcef
|
||||
SIZE (blitzpp-blitz-1.0.1_GH0.tar.gz) = 4645082
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- Makefile.in.orig Fri Jan 20 18:04:40 2006
|
||||
+++ Makefile.in Fri Jan 20 18:05:51 2006
|
||||
@@ -291,8 +291,11 @@
|
||||
target_vendor = @target_vendor@
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
@FORTRAN_ENABLED_TRUE@FORTRAN_DIRS = benchmarks
|
||||
+ifndef NOPORTDOCS
|
||||
+DOCS = doc
|
||||
+endif
|
||||
SUBDIRS = bin blitz random lib testsuite \
|
||||
- examples $(FORTRAN_DIRS) doc
|
||||
+ examples $(FORTRAN_DIRS) $(DOCS)
|
||||
|
||||
EXTRA_DIST = LEGAL LICENSE README.binutils README-VS.NET.txt Blitz-VS.NET.zip \
|
||||
ChangeLog.1
|
@ -1,11 +0,0 @@
|
||||
--- ./doc/Makefile.in.orig Tue Feb 22 18:26:53 2005
|
||||
+++ doc/Makefile.in Tue Feb 22 18:27:14 2005
|
||||
@@ -275,7 +275,7 @@ target_vendor = @target_vendor@
|
||||
SUBDIRS = examples stencils doxygen
|
||||
|
||||
# install these files
|
||||
-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
|
||||
+docdir = $(datadir)/doc/$(PACKAGE)
|
||||
doc_DATA = blitz.ps blitz.pdf blitz.html \
|
||||
blitz_abt.html blitz_fot.html blitz_ovr.html blitz_toc.html \
|
||||
blitz_1.html blitz_2.html blitz_3.html blitz_4.html blitz_5.html \
|
@ -1,16 +0,0 @@
|
||||
--- doc/arrays-expr.texi.orig 2003-01-21 11:01:03 UTC
|
||||
+++ doc/arrays-expr.texi
|
||||
@@ -714,13 +714,8 @@ Computes the error function:
|
||||
@tex
|
||||
$$ {\rm erf}(x) = {2\over\sqrt\pi}\int_{0}^{x} e^{-t^2} dt $$
|
||||
@end tex
|
||||
-@html
|
||||
-@erf(x) = 2/sqrt(Pi) * integral(exp(-t^2), t=0..x)
|
||||
-@end html
|
||||
@ifnottex
|
||||
-@ifnothtml
|
||||
@math{@r{erf}(x) = 2/@r{sqrt}(Pi) * @r{integral}(@r{exp}(-t^2), t=0..x)}
|
||||
-@end ifnothtml
|
||||
@end ifnottex
|
||||
|
||||
Note that for large values of the parameter, calculating can result in
|
@ -1,11 +0,0 @@
|
||||
--- doc/blitz.texi.orig Sat Oct 16 08:05:00 2004
|
||||
+++ doc/blitz.texi Tue Feb 22 23:32:57 2005
|
||||
@@ -13,7 +13,7 @@
|
||||
|
||||
@dircategory Blitz++ library
|
||||
@direntry
|
||||
-* Blitz++: (blitz++). High-performance C++ numeric library
|
||||
+* Blitz++: (blitz). High-performance C++ numeric library
|
||||
@end direntry
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- ./doc/doxygen/Makefile.in.orig Tue Feb 22 18:32:47 2005
|
||||
+++ ./doc/doxygen/Makefile.in Tue Feb 22 18:33:07 2005
|
||||
@@ -244,7 +244,7 @@ target_alias = @target_alias@
|
||||
target_cpu = @target_cpu@
|
||||
target_os = @target_os@
|
||||
target_vendor = @target_vendor@
|
||||
-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)/doxygen
|
||||
+docdir = $(datadir)/doc/$(PACKAGE)/doxygen
|
||||
DISTCLEANFILES = Doxyfile doxygen-warning
|
||||
all: all-am
|
||||
|
@ -3,4 +3,4 @@ performance on par with Fortran 77/90. It uses template techniques to
|
||||
achieve high performance. The current versions provide dense arrays and
|
||||
vectors, random number generators, and small vectors and matrices.
|
||||
|
||||
WWW: http://www.oonumerics.org/blitz/
|
||||
WWW: https://github.com/blitzpp/blitz
|
||||
|
@ -1,9 +1,8 @@
|
||||
include/blitz/applics.h
|
||||
include/blitz/array-impl.h
|
||||
include/blitz/array-old.h
|
||||
include/blitz/array.cc
|
||||
include/blitz/array.h
|
||||
include/blitz/array/asexpr.cc
|
||||
include/blitz/array/asexpr.h
|
||||
include/blitz/array/bops.cc
|
||||
include/blitz/array/cartesian.h
|
||||
include/blitz/array/cgsolve.h
|
||||
include/blitz/array/complex.cc
|
||||
@ -12,7 +11,7 @@ include/blitz/array/convolve.h
|
||||
include/blitz/array/cycle.cc
|
||||
include/blitz/array/domain.h
|
||||
include/blitz/array/et.h
|
||||
include/blitz/array/eval.cc
|
||||
include/blitz/array/expr.cc
|
||||
include/blitz/array/expr.h
|
||||
include/blitz/array/fastiter.h
|
||||
include/blitz/array/funcs.h
|
||||
@ -36,12 +35,13 @@ include/blitz/array/resize.cc
|
||||
include/blitz/array/shape.h
|
||||
include/blitz/array/slice.h
|
||||
include/blitz/array/slicing.cc
|
||||
include/blitz/array/stencil-classes.cc
|
||||
include/blitz/array/stencil-et-macros.h
|
||||
include/blitz/array/stencil-et.h
|
||||
include/blitz/array/stencilops.h
|
||||
include/blitz/array/stencils.cc
|
||||
include/blitz/array/stencils.h
|
||||
include/blitz/array/storage.h
|
||||
include/blitz/array/uops.cc
|
||||
include/blitz/array/where.h
|
||||
include/blitz/array/zip.h
|
||||
include/blitz/bench.cc
|
||||
@ -49,30 +49,21 @@ include/blitz/bench.h
|
||||
include/blitz/benchext.cc
|
||||
include/blitz/benchext.h
|
||||
include/blitz/blitz.h
|
||||
include/blitz/bounds.h
|
||||
include/blitz/bzconfig.h
|
||||
include/blitz/bzdebug.h
|
||||
include/blitz/compiler.h
|
||||
include/blitz/constpointerstack.h
|
||||
include/blitz/et-forward.h
|
||||
include/blitz/etbase.h
|
||||
include/blitz/extremum.h
|
||||
include/blitz/funcs.h
|
||||
include/blitz/globeval.cc
|
||||
include/blitz/gnu/bzconfig.h
|
||||
include/blitz/indexexpr.h
|
||||
include/blitz/indexmap-forward.h
|
||||
include/blitz/levicivita.h
|
||||
include/blitz/limits-hack.h
|
||||
include/blitz/listinit.h
|
||||
include/blitz/matbops.h
|
||||
include/blitz/matdiag.h
|
||||
include/blitz/matexpr.h
|
||||
include/blitz/matgen.h
|
||||
include/blitz/mathf2.h
|
||||
include/blitz/mathfunc.h
|
||||
include/blitz/matltri.h
|
||||
include/blitz/matref.h
|
||||
include/blitz/matrix.cc
|
||||
include/blitz/matrix.h
|
||||
include/blitz/matsymm.h
|
||||
include/blitz/mattoep.h
|
||||
include/blitz/matuops.h
|
||||
include/blitz/matutri.h
|
||||
include/blitz/memblock.cc
|
||||
include/blitz/memblock.h
|
||||
include/blitz/meta/dot.h
|
||||
@ -84,72 +75,36 @@ include/blitz/meta/product.h
|
||||
include/blitz/meta/sum.h
|
||||
include/blitz/meta/vecassign.h
|
||||
include/blitz/minmax.h
|
||||
include/blitz/mstruct.h
|
||||
include/blitz/numinquire.h
|
||||
include/blitz/numtrait.h
|
||||
include/blitz/ops.h
|
||||
include/blitz/prettyprint.h
|
||||
include/blitz/promote-old.h
|
||||
include/blitz/promote.h
|
||||
include/blitz/rand-dunif.h
|
||||
include/blitz/rand-mt.h
|
||||
include/blitz/rand-normal.h
|
||||
include/blitz/rand-tt800.h
|
||||
include/blitz/rand-uniform.h
|
||||
include/blitz/random.h
|
||||
include/blitz/randref.h
|
||||
include/blitz/range.cc
|
||||
include/blitz/range.h
|
||||
include/blitz/ranks.h
|
||||
include/blitz/reduce.h
|
||||
include/blitz/shapecheck.h
|
||||
include/blitz/simdtypes.h
|
||||
include/blitz/tau.h
|
||||
include/blitz/timer.h
|
||||
include/blitz/tiny.h
|
||||
include/blitz/tinymat.h
|
||||
include/blitz/tinymatexpr.h
|
||||
include/blitz/tinymatio.cc
|
||||
include/blitz/tinyvec-et.h
|
||||
include/blitz/tinyvec.cc
|
||||
include/blitz/tinyvec.h
|
||||
include/blitz/tinyvecio.cc
|
||||
include/blitz/tinyveciter.h
|
||||
include/blitz/tinymat2.cc
|
||||
include/blitz/tinymat2.h
|
||||
include/blitz/tinymat2io.cc
|
||||
include/blitz/tinyvec2.cc
|
||||
include/blitz/tinyvec2.h
|
||||
include/blitz/tinyvec2io.cc
|
||||
include/blitz/tm2fastiter.h
|
||||
include/blitz/tmevaluate.h
|
||||
include/blitz/traversal.cc
|
||||
include/blitz/traversal.h
|
||||
include/blitz/tuning.h
|
||||
include/blitz/tv2fastiter.h
|
||||
include/blitz/tvcross.h
|
||||
include/blitz/tvecglobs.h
|
||||
include/blitz/tvevaluate.h
|
||||
include/blitz/update.h
|
||||
include/blitz/vecaccum.cc
|
||||
include/blitz/vecall.cc
|
||||
include/blitz/vecany.cc
|
||||
include/blitz/vecbfn.cc
|
||||
include/blitz/vecbops.cc
|
||||
include/blitz/veccount.cc
|
||||
include/blitz/vecdelta.cc
|
||||
include/blitz/vecdot.cc
|
||||
include/blitz/vecexpr.h
|
||||
include/blitz/vecexprwrap.h
|
||||
include/blitz/vecglobs.cc
|
||||
include/blitz/vecglobs.h
|
||||
include/blitz/vecio.cc
|
||||
include/blitz/veciter.h
|
||||
include/blitz/vecmax.cc
|
||||
include/blitz/vecmin.cc
|
||||
include/blitz/vecnorm.cc
|
||||
include/blitz/vecnorm1.cc
|
||||
include/blitz/vecpick.cc
|
||||
include/blitz/vecpick.h
|
||||
include/blitz/vecpickio.cc
|
||||
include/blitz/vecpickiter.h
|
||||
include/blitz/vecsum.cc
|
||||
include/blitz/vector-et.h
|
||||
include/blitz/vector.cc
|
||||
include/blitz/vector.h
|
||||
include/blitz/vecuops.cc
|
||||
include/blitz/vecwhere.cc
|
||||
include/blitz/vecwhere.h
|
||||
include/blitz/wrap-climits.h
|
||||
include/blitz/zero.cc
|
||||
include/blitz/zero.h
|
||||
include/random/F.h
|
||||
include/random/beta.h
|
||||
include/random/chisquare.h
|
||||
@ -158,6 +113,7 @@ include/random/discrete-uniform.h
|
||||
include/random/exponential.h
|
||||
include/random/gamma.h
|
||||
include/random/mt.h
|
||||
include/random/mtparam.cc
|
||||
include/random/normal.h
|
||||
include/random/uniform.h
|
||||
lib/libblitz.a
|
||||
@ -165,35 +121,8 @@ lib/libblitz.so
|
||||
lib/libblitz.so.0
|
||||
lib/libblitz.so.0.0.0
|
||||
libdata/pkgconfig/blitz.pc
|
||||
libdata/pkgconfig/blitz-uninstalled.pc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz.ps
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_1.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_10.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_11.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_12.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_13.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_14.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_15.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_16.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_2.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_3.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_4.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_5.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_6.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_7.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_8.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_9.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_abt.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_fot.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_ovr.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitz_toc.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/blitztiny.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/indirect.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sinsoid.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/slice.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/strideslice.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tensor1.gif
|
||||
@comment @dir %%DOCSDIR%%/doxygen
|
||||
%%PORTDOCS%%%%DOCSDIR%%/indirect.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sinsoid.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/slice.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/strideslice.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tensor1.txt
|
||||
|
Loading…
Reference in New Issue
Block a user