- Upgrade to 5.7.3
Release notes at <http://www.abinit.org/Infos_v5.7/release_notes/release_notes.html> - enable bindings to get the headers This requires makemake and GSL. Approved by: Maho (maintainer)
This commit is contained in:
parent
b09c2f2e36
commit
fefa5eaa8b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=232017
@ -6,30 +6,34 @@
|
||||
#
|
||||
|
||||
PORTNAME= abinit
|
||||
PORTVERSION= 5.6.5
|
||||
PORTVERSION= 5.7.3
|
||||
CATEGORIES= science
|
||||
MASTER_SITES= ftp://ftp.abinit.org/pub/abinitio/ABINIT_v${PORTVERSION}/
|
||||
|
||||
MAINTAINER= maho@FreeBSD.org
|
||||
COMMENT= Abinit calculates electronic structure of systems
|
||||
|
||||
LIB_DEPENDS= netcdff.4:${PORTSDIR}/science/netcdf-ftn
|
||||
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numarray/__init__.py:${PORTSDIR}/math/py-numarray
|
||||
LIB_DEPENDS= netcdff.4:${PORTSDIR}/science/netcdf-ftn \
|
||||
gsl.13:${PORTSDIR}/math/gsl
|
||||
|
||||
USE_FORTRAN= yes
|
||||
USE_GMAKE= yes
|
||||
USE_PYTHON= yes
|
||||
USE_PERL5_BUILD=yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_AUTOTOOLS= autoconf:262 automake:110
|
||||
CONFIGURE_ENV= WGET=${TRUE}
|
||||
CONFIGURE_ARGS= --disable-wannier90 --disable-bigdft --disable-etsf-io \
|
||||
--with-plugins-tardir=/dev/null \
|
||||
--with-netcdf-includes="-I${LOCALBASE}/include" \
|
||||
--enable-bindings --enable-gsl \
|
||||
--with-netcdf-libs="-L${LOCALBASE}/lib -lnetcdff -lnetcdf"
|
||||
ALL_TARGET= all libabinit
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX-base \
|
||||
dvips:${PORTSDIR}/print/dvipsk-tetex \
|
||||
gm4:${PORTSDIR}/devel/m4 \
|
||||
markdown:${PORTSDIR}/textproc/markdown
|
||||
USE_GHOSTSCRIPT_BUILD= yes
|
||||
.endif
|
||||
@ -57,12 +61,18 @@ pre-configure:
|
||||
.if defined(NOPORTEXAMPLES)
|
||||
${REINPLACE_CMD} -e '/^SUBDIRS =/s| tests||' ${WRKSRC}/Makefile.in
|
||||
.endif
|
||||
(cd ${WRKSRC} && ./config/scripts/makemake)
|
||||
${CHMOD} a+x ${WRKSRC}/bindings/parser/*.py
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${PREFIX}/lib
|
||||
${MKDIR} ${PREFIX}/include ${PREFIX}/lib
|
||||
.for lf in libabinip.a libabinis.a
|
||||
${INSTALL_DATA} ${WRKSRC}/${lf} ${PREFIX}/lib
|
||||
.endfor
|
||||
.for lf in ab_dtset_c.h dtset_c.h dtset_c.static.h dtset_f90.inc dtset_py.h \
|
||||
ab_dtset_f90_get.f90
|
||||
${INSTALL_DATA} ${WRKSRC}/bindings/parser/${lf} ${PREFIX}/include
|
||||
.endfor
|
||||
|
||||
regression-test:
|
||||
cd ${WRKSRC}/tests ; ${GMAKE} tests_min
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (abinit-5.6.5.tar.gz) = 167ef71a21c27e52ef82d284a9835c91
|
||||
SHA256 (abinit-5.6.5.tar.gz) = 20b9cfcecb2fa238363e88b9b719e755e7bf2dd156c2216f43ec0c4b7be25fa0
|
||||
SIZE (abinit-5.6.5.tar.gz) = 30213023
|
||||
MD5 (abinit-5.7.3.tar.gz) = 0e7565aa986c2bdd1bee4d01094686e3
|
||||
SHA256 (abinit-5.7.3.tar.gz) = caac56530ceaa5e16326fd4407adcd0b1aede07ded51017f3eb6a6a3696c2867
|
||||
SIZE (abinit-5.7.3.tar.gz) = 31683174
|
||||
|
11
science/abinit/files/patch-bindings_parser_ab_dtset_c.c
Normal file
11
science/abinit/files/patch-bindings_parser_ab_dtset_c.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- bindings/parser/ab_dtset_c.c.orig 2009-02-22 07:08:32.000000000 +0100
|
||||
+++ bindings/parser/ab_dtset_c.c 2009-03-26 22:21:33.000000000 +0100
|
||||
@@ -7,6 +7,8 @@
|
||||
/* g95 : #define FC_MOD_NAME(A) ab_dtset_MP_ ## A */
|
||||
#define FC_MOD_CALL(A,...) FC_MOD_NAME(A)(__VA_ARGS__)
|
||||
|
||||
+typedef unsigned int uint;
|
||||
+
|
||||
/* Fortran interface. */
|
||||
void FC_MOD_NAME(ab_dtset_new)(int *dt, const char *filename, int *len);
|
||||
void FC_MOD_NAME(ab_dtset_new_from_string)(int *dt, const char *string, int *len);
|
129
science/abinit/files/patch-config+m4+init.m4
Normal file
129
science/abinit/files/patch-config+m4+init.m4
Normal file
@ -0,0 +1,129 @@
|
||||
--- ./config/m4/init.m4.orig 2009-03-11 06:12:22.000000000 +0100
|
||||
+++ ./config/m4/init.m4 2009-03-28 16:29:06.000000000 +0100
|
||||
@@ -231,6 +231,101 @@
|
||||
abi_cpu_bits="64"
|
||||
;;
|
||||
|
||||
+ i386-*freebsd*)
|
||||
+ dnl Pentium 3 ?
|
||||
+ if test "${abi_cpu_model}" = ""; then
|
||||
+ abi_cpu_model=`sysctl hw.model | grep 'Pentium III'`
|
||||
+ if test "${abi_cpu_model}" != ""; then
|
||||
+ abi_cpu_model="pentium3"
|
||||
+ abi_cpu_64bits="no"
|
||||
+ abi_cpu_bits="32"
|
||||
+ fi
|
||||
+ fi
|
||||
+ dnl Pentium 4 ?
|
||||
+ if test "${abi_cpu_model}" = ""; then
|
||||
+ abi_cpu_model=`sysctl hw.model | grep 'Intel(R) Pentium(R) 4'`
|
||||
+ if test "${abi_cpu_model}" != ""; then
|
||||
+ abi_cpu_model="pentium4"
|
||||
+ abi_cpu_64bits="no"
|
||||
+ abi_cpu_bits="32"
|
||||
+ fi
|
||||
+ fi
|
||||
+ dnl Pentium 4M ?
|
||||
+ if test "${abi_cpu_model}" = ""; then
|
||||
+ abi_cpu_model=`sysctl hw.model | grep 'Intel(R) Pentium(R) M'`
|
||||
+ if test "${abi_cpu_model}" != ""; then
|
||||
+ abi_cpu_model="pentium4"
|
||||
+ abi_cpu_64bits="no"
|
||||
+ abi_cpu_bits="32"
|
||||
+ fi
|
||||
+ fi
|
||||
+ dnl Unknown
|
||||
+ if test "${abi_cpu_model}" = ""; then
|
||||
+ abi_cpu_model="unknown"
|
||||
+ fi
|
||||
+ dnl The processor is anyway 32-bit
|
||||
+ abi_cpu_64bits="no"
|
||||
+ abi_cpu_bits="32"
|
||||
+ ;;
|
||||
+
|
||||
+ amd64-*freebsd*)
|
||||
+ dnl Opteron ?
|
||||
+ if test "${abi_cpu_model}" = ""; then
|
||||
+ abi_cpu_model=`sysctl hw.model | grep 'Opteron'`
|
||||
+ if test "${abi_cpu_model}" != ""; then
|
||||
+ abi_cpu_model="opteron"
|
||||
+ abi_cpu_64bits="yes"
|
||||
+ abi_cpu_bits="64"
|
||||
+ fi
|
||||
+ fi
|
||||
+ dnl Xeon ?
|
||||
+ if test "${abi_cpu_model}" = ""; then
|
||||
+ abi_cpu_model=`sysctl hw.model | grep 'Intel(R) XEON(TM)'`
|
||||
+ if test "${abi_cpu_model}" != ""; then
|
||||
+ abi_cpu_model="xeon"
|
||||
+ abi_cpu_64bits="yes"
|
||||
+ abi_cpu_bits="64"
|
||||
+ fi
|
||||
+ fi
|
||||
+ dnl Unknown
|
||||
+ if test "${abi_cpu_model}" = ""; then
|
||||
+ abi_cpu_model="unknown"
|
||||
+ fi
|
||||
+ dnl The processor is anyway 64-bit
|
||||
+ abi_cpu_64bits="yes"
|
||||
+ abi_cpu_bits="64"
|
||||
+ ;;
|
||||
+
|
||||
+ ia64-*freebsd*)
|
||||
+ dnl Itanium 1 ?
|
||||
+ if test "${abi_cpu_model}" = ""; then
|
||||
+ abi_cpu_model=`sysctl hw.model | grep 'Itanium 1'`
|
||||
+ if test "${abi_cpu_model}" = ""; then
|
||||
+ abi_cpu_model="itanium1"
|
||||
+ fi
|
||||
+ fi
|
||||
+ dnl Itanium 2 ?
|
||||
+ if test "${abi_cpu_model}" = ""; then
|
||||
+ abi_cpu_model=`sysctl hw.model | grep 'Itanium 2'`
|
||||
+ if test "${abi_cpu_model}" != ""; then
|
||||
+ abi_cpu_model="itanium2"
|
||||
+ fi
|
||||
+ fi
|
||||
+ dnl Unknown
|
||||
+ if test "${abi_cpu_model}" = ""; then
|
||||
+ abi_cpu_model="unknown"
|
||||
+ fi
|
||||
+ dnl The processor is anyway 64-bit
|
||||
+ abi_cpu_64bits="yes"
|
||||
+ abi_cpu_bits="64"
|
||||
+ ;;
|
||||
+
|
||||
+ sparc64-*freebsd*)
|
||||
+ abi_cpu_model="unknown"
|
||||
+ abi_cpu_64bits="yes"
|
||||
+ abi_cpu_bits="64"
|
||||
+ ;;
|
||||
+
|
||||
esac
|
||||
|
||||
AC_SUBST(abi_cpu_vendor)
|
||||
@@ -289,15 +384,15 @@
|
||||
fi
|
||||
|
||||
dnl Set-up all directory names
|
||||
- abinit_bindir="${abinit_prefix}/abinit/${ABINIT_VERSION_BASE}/bin"
|
||||
- abinit_chkdir="${abinit_prefix}/abinit/${ABINIT_VERSION_BASE}/tests"
|
||||
- abinit_datdir="${abinit_prefix}/abinit"
|
||||
- abinit_docdir="${abinit_prefix}/abinit/${ABINIT_VERSION_BASE}/doc"
|
||||
- abinit_incdir="${abinit_prefix}/abinit/${ABINIT_VERSION_BASE}/include"
|
||||
- abinit_libdir="${abinit_prefix}/abinit/${ABINIT_VERSION_BASE}/lib"
|
||||
- abinit_mandir="${abinit_prefix}/abinit/man"
|
||||
- abinit_rundir="${abinit_prefix}/abinit/bin"
|
||||
- abinit_wwwdir="${abinit_prefix}/abinit/${ABINIT_VERSION_BASE}/www"
|
||||
+ abinit_bindir="${abinit_prefix}/bin"
|
||||
+ abinit_chkdir="${abinit_prefix}/share/examples/abinit/tests"
|
||||
+ abinit_datdir="${abinit_prefix}/share/abinit"
|
||||
+ abinit_docdir="${abinit_prefix}/share/doc/abinit/"
|
||||
+ abinit_incdir="${abinit_prefix}/include/abinit"
|
||||
+ abinit_libdir="${abinit_prefix}/lib"
|
||||
+ abinit_mandir="${abinit_prefix}/man"
|
||||
+ abinit_rundir="${abinit_prefix}/bin"
|
||||
+ abinit_wwwdir="${abinit_prefix}/www/abinit"
|
||||
|
||||
dnl Substitute all variables
|
||||
AC_SUBST(abinit_prefix)
|
@ -0,0 +1,11 @@
|
||||
--- ./config/scripts/make-macros-autotools.orig 2009-02-22 07:08:33.000000000 +0100
|
||||
+++ ./config/scripts/make-macros-autotools 2009-03-25 22:34:01.000000000 +0100
|
||||
@@ -413,7 +413,7 @@
|
||||
now = strftime("%Y/%m/%d %H:%M:%S +0000",gmtime())
|
||||
|
||||
# Get Autotools versions
|
||||
-(m4_ret,m4_version) = commands.getstatusoutput("m4 --version")
|
||||
+(m4_ret,m4_version) = commands.getstatusoutput("gm4 --version")
|
||||
(ac_ret,ac_version) = commands.getstatusoutput("autoconf --version")
|
||||
(am_ret,am_version) = commands.getstatusoutput("automake --version")
|
||||
(lt_ret,lt_version) = commands.getstatusoutput("libtool --version")
|
@ -2,7 +2,6 @@ bin/abinetcdf
|
||||
bin/abinis
|
||||
bin/aim
|
||||
bin/anaddb
|
||||
bin/anascr
|
||||
bin/band2eps
|
||||
bin/conducti
|
||||
bin/cut3d
|
||||
@ -13,6 +12,13 @@ bin/mrggkk
|
||||
bin/mrgscr
|
||||
bin/newsp
|
||||
bin/optic
|
||||
include/ab_dtset_c.h
|
||||
include/ab_dtset_f90_get.f90
|
||||
include/dtset_c.h
|
||||
include/dtset_c.static.h
|
||||
include/dtset_f90.inc
|
||||
include/dtset_py.h
|
||||
lib/libabibase.a
|
||||
lib/libabinip.a
|
||||
lib/libabinis.a
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
@ -30,9 +36,9 @@ lib/libabinis.a
|
||||
%%PORTDOCS%%%%DOCSDIR%%/build/preprocessing-macros.tex
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-config.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/alphaev56-compaq_tux.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/alphaev67-compaq_deccint.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/amd-g95_chum.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/amd-g95-mpich_chum.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/amd-g95-openmpi_chum.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/amd-gfortran4.1_chum.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/amd-gfortran4.2_chum.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/amd-gfortran4.3_chum.ac
|
||||
@ -43,20 +49,16 @@ lib/libabinis.a
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/amd-pgi7.2-3_chum.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/amd-sunstudio12_chum.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/fujitsu-fujitsu_eliza.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/i686-g95_sleepy.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/i686-gfortran_mac.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/i686-gfortran_sleepy.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/i686-intel9.0_dummy.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/i686-intel9.0_hemera.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/i686-intel9.1_antarion.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/i686-intel9.1_sirius.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/i686-intel9.1_sleepy.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/i686-pathscale_sleepy.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/i686-pgi4.0_dummy.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/ia64-intel8.1_chpit.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/ia64-intel9.1_arina.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/intel-gfortran4.3_bigmac.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/itanium2-intel9.1_urano.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/macosx-gfortran_gandalf.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/macosx-gfortran_rafael.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/mips-mipspro_spinoza.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/opteron-intel9.1_lemaitre.ac
|
||||
%%PORTDOCS%%%%DOCSDIR%%/config/build-examples/powerpc-ibm_datastar.ac
|
||||
@ -124,6 +126,7 @@ lib/libabinis.a
|
||||
%%PORTDOCS%%%%DOCSDIR%%/features/features_v5.4.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/features/features_v5.5.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/features/features_v5.6.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/features/features_v5.7.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/gallery/Plot1.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/gallery/mode.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/gallery/pcpm.gif
|
||||
@ -179,6 +182,7 @@ lib/libabinis.a
|
||||
%%PORTDOCS%%%%DOCSDIR%%/install_notes/install_v5.4.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/install_notes/install_v5.5.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/install_notes/install_v5.6.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/install_notes/install_v5.7.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/known_problems/known_problems.4.6.x
|
||||
%%PORTDOCS%%%%DOCSDIR%%/macroave/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/macroave/macroave-docs.mk
|
||||
@ -252,6 +256,7 @@ lib/libabinis.a
|
||||
%%PORTDOCS%%%%DOCSDIR%%/release_notes/release_notes_v5.4.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/release_notes/release_notes_v5.5.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/release_notes/release_notes_v5.6.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/release_notes/release_notes_v5.7.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/theory/1WF.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/theory/1WF.tex
|
||||
%%PORTDOCS%%%%DOCSDIR%%/theory/ABINIT-documentation-elasticity.odt
|
||||
@ -312,7 +317,6 @@ lib/libabinis.a
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/lesson_paw1/DOS-2proj.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/lesson_paw1/DOS-4proj.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/lesson_paw1/DOS-6proj.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/lesson_paw1/Thumbs.db
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/lesson_paw1/etotal-acell.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/lesson_paw2.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorial/lesson_paw2/AtompawAbinit.tar.gz
|
||||
@ -419,6 +423,9 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/05b.soft_tm
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/06c.pspgth
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/08o-gga.paw
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/08o.6.blyp.hgh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/08o.6.bp.hgh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/08o.6.olyp.hgh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/08o.pspgth
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/08o_001023.pspfhi
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/09-F.psp
|
||||
@ -477,6 +484,7 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/42mo.pspnc
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/4be.psphgh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/4be.pspnc
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/50sn.paw
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/50sn.psphgh
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/50sn.pspnc
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Psps_for_tests/51Sb_pbe-q5
|
||||
@ -741,6 +749,7 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/etsf_io/Refs/t09.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/etsf_io/Refs/t10.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/etsf_io/tests.cnf
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/etsf_xc/Input/report.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/etsf_xc/Input/t01.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/etsf_xc/Input/t02.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/etsf_xc/Input/t03.in
|
||||
@ -809,6 +818,7 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/fast/Refs/t30.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/fast/tests.cnf
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/netcdf/README
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Input/report.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Input/si_kpt_band_fft.files
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Input/si_kpt_band_fft.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Input/t9.in
|
||||
@ -835,6 +845,8 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Input/tU.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Input/tV.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Input/tW.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Input/tX.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Input/tY.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Input/t_bandfft.files
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Input/t_bandfft.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Input/t_kpt+spin.files
|
||||
@ -936,6 +948,10 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Refs/tV4.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Refs/tW0.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Refs/tW4.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Refs/tX0.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Refs/tX4.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Refs/tY0.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/paral/Refs/tY4.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/physics/Input/ab.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/physics/Input/t11.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/physics/Input/t13.in
|
||||
@ -1934,8 +1950,6 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Input/t08.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Input/t09.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Input/t10.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Input/t100.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Input/t101.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Input/t11.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Input/t12.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Input/t13.in
|
||||
@ -2037,8 +2051,6 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Refs/t08.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Refs/t09.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Refs/t10.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Refs/t100.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Refs/t101.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Refs/t11.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Refs/t12.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v4/Refs/t13.out
|
||||
@ -2177,6 +2189,8 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t33.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t34.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t35.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t36.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t37.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t41.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t42.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t44.in
|
||||
@ -2201,6 +2215,7 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t67.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t68.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t69.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t70.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t81.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t85.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Input/t86.in
|
||||
@ -2242,6 +2257,8 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t33.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t34.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t35.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t36.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t37.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t41.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t42.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t44.out
|
||||
@ -2266,6 +2283,7 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t67.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t68.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t69.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t70.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t81.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t85.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/Refs/t86.ddb.out
|
||||
@ -2280,14 +2298,18 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/v5/tests.cnf
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Input/report.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Input/t01.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Input/t01.wannier90.win
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Input/t01o_w90.win
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Input/t02.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Input/t02.wannier90.win
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Input/t02o_w90.win
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Input/t03.in
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Input/t03o_DS7_w90.win
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/README
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Refs/t01.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Refs/t01.wannier90.wout
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Refs/t01o_w90.wout
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Refs/t02.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Refs/t02.wannier90.wout
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Refs/t02o_w90.wout
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Refs/t03.out
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/Refs/t03o_DS7_w90.wout
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/wannier90/tests.cnf
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tests/wannier90/Refs
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tests/wannier90/Input
|
||||
@ -2327,7 +2349,6 @@ lib/libabinis.a
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tests/paral/Refs
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tests/paral/Input
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tests/paral
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tests/netcdf/Input
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tests/netcdf
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tests/fast/Refs
|
||||
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tests/fast/Input
|
||||
|
Loading…
Reference in New Issue
Block a user