Add barry 0.5.3, a nice KDE frontend to the ports system.
This commit is contained in:
parent
f9270878e3
commit
fef04938ed
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=66948
29
ports-mgmt/barry/Makefile
Normal file
29
ports-mgmt/barry/Makefile
Normal file
@ -0,0 +1,29 @@
|
||||
# New ports collection makefile for: barry
|
||||
# Date created: 19 September 2002
|
||||
# Whom: Brad Davis <so14k@so14k.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= barry
|
||||
PORTVERSION= 0.5.3
|
||||
CATEGORIES= sysutils kde
|
||||
MASTER_SITES= http://frerich.ath.cx/barry/
|
||||
|
||||
MAINTAINER= so14k@so14k.com
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_KDELIBS_VER=3
|
||||
MAKE_ENV= QTDIR="${X11BASE}" KDEDIR="${LOCALBASE}" PREFIX="${PREFIX}"
|
||||
USE_REINPLACE= yes
|
||||
|
||||
pre-build:
|
||||
${REINPLACE_CMD} "s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile
|
||||
|
||||
do-build:
|
||||
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
|
||||
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} .depend)
|
||||
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
|
||||
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS})
|
||||
|
||||
.include <bsd.port.mk>
|
1
ports-mgmt/barry/distinfo
Normal file
1
ports-mgmt/barry/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (barry-0.5.3.tar.bz2) = 9996a2d1861b94b9bf99e046712c605d
|
33
ports-mgmt/barry/files/patch-Makefile
Normal file
33
ports-mgmt/barry/files/patch-Makefile
Normal file
@ -0,0 +1,33 @@
|
||||
--- Makefile Mon Aug 5 17:30:26 2002
|
||||
+++ Makefile.new Fri Sep 20 20:11:35 2002
|
||||
@@ -1,6 +1,7 @@
|
||||
CXX=g++
|
||||
QTDIR?=/usr/X11R6
|
||||
KDEDIR?=/usr/local
|
||||
+PREFIX?=/usr/local
|
||||
MOC=$(QTDIR)/bin/moc
|
||||
INCLUDES=-I$(QTDIR)/include -I$(KDEDIR)/include
|
||||
LIBRARIES=-L$(QTDIR)/lib -L$(KDEDIR)/lib
|
||||
@@ -39,14 +40,14 @@
|
||||
|
||||
install: barry
|
||||
echo Installing barry $(VERSION)...
|
||||
- install -o root -g wheel -p -s -m 755 barry $(KDEDIR)/bin
|
||||
- mkdir -p $(KDEDIR)/share/apps/barry
|
||||
- install -o root -g wheel -p -m 444 barryui.rc $(KDEDIR)/share/apps/barry
|
||||
- install -o root -g wheel -p -m 444 barry.desktop $(KDEDIR)/share/applnk/Utilities
|
||||
- install -o root -g wheel -p -m 444 hi16-app-barry.png $(KDEDIR)/share/icons/hicolor/16x16/apps/barry.png
|
||||
- install -o root -g wheel -p -m 444 hi32-app-barry.png $(KDEDIR)/share/icons/hicolor/32x32/apps/barry.png
|
||||
- install -o root -g wheel -p -m 444 hi48-app-barry.png $(KDEDIR)/share/icons/hicolor/48x48/apps/barry.png
|
||||
- install -o root -g wheel -p -m 444 eventsrc $(KDEDIR)/share/apps/barry
|
||||
+ install -o root -g wheel -p -s -m 755 barry $(PREFIX)/bin
|
||||
+ mkdir -p $(PREFIX)/share/apps/barry
|
||||
+ install -o root -g wheel -p -m 444 barryui.rc $(PREFIX)/share/apps/barry
|
||||
+ install -o root -g wheel -p -m 444 barry.desktop $(PREFIX)/share/applnk/Utilities
|
||||
+ install -o root -g wheel -p -m 444 hi16-app-barry.png $(PREFIX)/share/icons/hicolor/16x16/apps/barry.png
|
||||
+ install -o root -g wheel -p -m 444 hi32-app-barry.png $(PREFIX)/share/icons/hicolor/32x32/apps/barry.png
|
||||
+ install -o root -g wheel -p -m 444 hi48-app-barry.png $(PREFIX)/share/icons/hicolor/48x48/apps/barry.png
|
||||
+ install -o root -g wheel -p -m 444 eventsrc $(PREFIX)/share/apps/barry
|
||||
cd po/; $(MAKE) $(.TARGET)
|
||||
cd splashdata/; $(MAKE) $(.TARGET)
|
||||
|
1
ports-mgmt/barry/pkg-comment
Normal file
1
ports-mgmt/barry/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A nice KDE frontend to the ports system
|
1
ports-mgmt/barry/pkg-descr
Normal file
1
ports-mgmt/barry/pkg-descr
Normal file
@ -0,0 +1 @@
|
||||
A nice KDE frontend to the ports system.
|
23
ports-mgmt/barry/pkg-plist
Normal file
23
ports-mgmt/barry/pkg-plist
Normal file
@ -0,0 +1,23 @@
|
||||
bin/barry
|
||||
share/applnk/Utilities/barry.desktop
|
||||
share/apps/barry/background.png
|
||||
share/apps/barry/barryui.rc
|
||||
share/apps/barry/bgtable.png
|
||||
share/apps/barry/eventsrc
|
||||
share/apps/barry/kdelogo2.png
|
||||
share/apps/barry/khelpcenter.png
|
||||
share/apps/barry/konq.css
|
||||
share/apps/barry/lines.png
|
||||
share/apps/barry/lines2.png
|
||||
share/apps/barry/pointers.png
|
||||
share/apps/barry/shadow1.png
|
||||
share/apps/barry/splashscreen.html
|
||||
share/icons/hicolor/16x16/apps/barry.png
|
||||
share/icons/hicolor/32x32/apps/barry.png
|
||||
share/icons/hicolor/48x48/apps/barry.png
|
||||
share/locale/de/LC_MESSAGES/barry.mo
|
||||
share/locale/es/LC_MESSAGES/barry.mo
|
||||
share/locale/ko/LC_MESSAGES/barry.mo
|
||||
share/locale/nl/LC_MESSAGES/barry.mo
|
||||
share/locale/sv/LC_MESSAGES/barry.mo
|
||||
@dirrm share/apps/barry
|
@ -15,6 +15,7 @@
|
||||
SUBDIR += asfsm
|
||||
SUBDIR += asmem
|
||||
SUBDIR += asmon
|
||||
SUBDIR += barry
|
||||
SUBDIR += battstat-applet
|
||||
SUBDIR += bchunk
|
||||
SUBDIR += bkpupsd
|
||||
|
29
sysutils/barry/Makefile
Normal file
29
sysutils/barry/Makefile
Normal file
@ -0,0 +1,29 @@
|
||||
# New ports collection makefile for: barry
|
||||
# Date created: 19 September 2002
|
||||
# Whom: Brad Davis <so14k@so14k.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= barry
|
||||
PORTVERSION= 0.5.3
|
||||
CATEGORIES= sysutils kde
|
||||
MASTER_SITES= http://frerich.ath.cx/barry/
|
||||
|
||||
MAINTAINER= so14k@so14k.com
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_KDELIBS_VER=3
|
||||
MAKE_ENV= QTDIR="${X11BASE}" KDEDIR="${LOCALBASE}" PREFIX="${PREFIX}"
|
||||
USE_REINPLACE= yes
|
||||
|
||||
pre-build:
|
||||
${REINPLACE_CMD} "s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile
|
||||
|
||||
do-build:
|
||||
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
|
||||
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} .depend)
|
||||
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
|
||||
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS})
|
||||
|
||||
.include <bsd.port.mk>
|
1
sysutils/barry/distinfo
Normal file
1
sysutils/barry/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (barry-0.5.3.tar.bz2) = 9996a2d1861b94b9bf99e046712c605d
|
33
sysutils/barry/files/patch-Makefile
Normal file
33
sysutils/barry/files/patch-Makefile
Normal file
@ -0,0 +1,33 @@
|
||||
--- Makefile Mon Aug 5 17:30:26 2002
|
||||
+++ Makefile.new Fri Sep 20 20:11:35 2002
|
||||
@@ -1,6 +1,7 @@
|
||||
CXX=g++
|
||||
QTDIR?=/usr/X11R6
|
||||
KDEDIR?=/usr/local
|
||||
+PREFIX?=/usr/local
|
||||
MOC=$(QTDIR)/bin/moc
|
||||
INCLUDES=-I$(QTDIR)/include -I$(KDEDIR)/include
|
||||
LIBRARIES=-L$(QTDIR)/lib -L$(KDEDIR)/lib
|
||||
@@ -39,14 +40,14 @@
|
||||
|
||||
install: barry
|
||||
echo Installing barry $(VERSION)...
|
||||
- install -o root -g wheel -p -s -m 755 barry $(KDEDIR)/bin
|
||||
- mkdir -p $(KDEDIR)/share/apps/barry
|
||||
- install -o root -g wheel -p -m 444 barryui.rc $(KDEDIR)/share/apps/barry
|
||||
- install -o root -g wheel -p -m 444 barry.desktop $(KDEDIR)/share/applnk/Utilities
|
||||
- install -o root -g wheel -p -m 444 hi16-app-barry.png $(KDEDIR)/share/icons/hicolor/16x16/apps/barry.png
|
||||
- install -o root -g wheel -p -m 444 hi32-app-barry.png $(KDEDIR)/share/icons/hicolor/32x32/apps/barry.png
|
||||
- install -o root -g wheel -p -m 444 hi48-app-barry.png $(KDEDIR)/share/icons/hicolor/48x48/apps/barry.png
|
||||
- install -o root -g wheel -p -m 444 eventsrc $(KDEDIR)/share/apps/barry
|
||||
+ install -o root -g wheel -p -s -m 755 barry $(PREFIX)/bin
|
||||
+ mkdir -p $(PREFIX)/share/apps/barry
|
||||
+ install -o root -g wheel -p -m 444 barryui.rc $(PREFIX)/share/apps/barry
|
||||
+ install -o root -g wheel -p -m 444 barry.desktop $(PREFIX)/share/applnk/Utilities
|
||||
+ install -o root -g wheel -p -m 444 hi16-app-barry.png $(PREFIX)/share/icons/hicolor/16x16/apps/barry.png
|
||||
+ install -o root -g wheel -p -m 444 hi32-app-barry.png $(PREFIX)/share/icons/hicolor/32x32/apps/barry.png
|
||||
+ install -o root -g wheel -p -m 444 hi48-app-barry.png $(PREFIX)/share/icons/hicolor/48x48/apps/barry.png
|
||||
+ install -o root -g wheel -p -m 444 eventsrc $(PREFIX)/share/apps/barry
|
||||
cd po/; $(MAKE) $(.TARGET)
|
||||
cd splashdata/; $(MAKE) $(.TARGET)
|
||||
|
1
sysutils/barry/pkg-comment
Normal file
1
sysutils/barry/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A nice KDE frontend to the ports system
|
1
sysutils/barry/pkg-descr
Normal file
1
sysutils/barry/pkg-descr
Normal file
@ -0,0 +1 @@
|
||||
A nice KDE frontend to the ports system.
|
23
sysutils/barry/pkg-plist
Normal file
23
sysutils/barry/pkg-plist
Normal file
@ -0,0 +1,23 @@
|
||||
bin/barry
|
||||
share/applnk/Utilities/barry.desktop
|
||||
share/apps/barry/background.png
|
||||
share/apps/barry/barryui.rc
|
||||
share/apps/barry/bgtable.png
|
||||
share/apps/barry/eventsrc
|
||||
share/apps/barry/kdelogo2.png
|
||||
share/apps/barry/khelpcenter.png
|
||||
share/apps/barry/konq.css
|
||||
share/apps/barry/lines.png
|
||||
share/apps/barry/lines2.png
|
||||
share/apps/barry/pointers.png
|
||||
share/apps/barry/shadow1.png
|
||||
share/apps/barry/splashscreen.html
|
||||
share/icons/hicolor/16x16/apps/barry.png
|
||||
share/icons/hicolor/32x32/apps/barry.png
|
||||
share/icons/hicolor/48x48/apps/barry.png
|
||||
share/locale/de/LC_MESSAGES/barry.mo
|
||||
share/locale/es/LC_MESSAGES/barry.mo
|
||||
share/locale/ko/LC_MESSAGES/barry.mo
|
||||
share/locale/nl/LC_MESSAGES/barry.mo
|
||||
share/locale/sv/LC_MESSAGES/barry.mo
|
||||
@dirrm share/apps/barry
|
Loading…
Reference in New Issue
Block a user