- Fix build with gcc 4.x

- Drop USE_X_PREFIX

PR:		ports/114414
Submitted by:	KATO Tsuguru <tkato432 at yahoo.com>
This commit is contained in:
Rong-En Fan 2007-07-11 16:38:55 +00:00
parent 89ee020274
commit fed8c632f6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=195422
6 changed files with 58 additions and 17 deletions

View File

@ -20,20 +20,14 @@ COMMENT= An avifile based .avi and .asf file playback plugin for XMMS
LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
ONLY_FOR_ARCHS= i386
PLIST_FILES= lib/xmms/Input/libavixmms.so
USE_X_PREFIX= yes
USE_SDL= sdl
USE_GNOME= gtk12
USE_SDL= sdl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-win32-path=${LOCALBASE}/lib/win32
USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Does not compile with GCC 4.2
.endif
PLIST_FILES= lib/xmms/Input/libavixmms.so
post-patch:
@${REINPLACE_CMD} \
@ -49,4 +43,4 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/libavixmms.so ${PREFIX}/lib/xmms/Input
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- include/videodecoder.h.orig Fri Dec 15 09:12:07 2000
+++ include/videodecoder.h Mon Jul 2 02:47:03 2007
@@ -55,7 +55,7 @@
CAP_UYVY=8,
CAP_YVYU=16 };
- static IVideoDecoder* IVideoDecoder::Create(const BITMAPINFOHEADER& bh, int depth=24, int flip=0);
+ static IVideoDecoder* Create(const BITMAPINFOHEADER& bh, int depth=24, int flip=0);
virtual ~IVideoDecoder(){}
virtual void Start() =0;

View File

@ -0,0 +1,20 @@
--- lib/audioencoder/lame3.70/lame.c.orig Tue Sep 12 18:12:24 2000
+++ lib/audioencoder/lame3.70/lame.c Mon Jul 2 22:17:43 2007
@@ -46,6 +46,9 @@
#include "asmstuff.h"
#endif
+#ifdef __FreeBSD__
+#include <floatingpoint.h>
+#endif
/* Global variable definitions for lame.c */
static Bit_stream_struc bs;
@@ -1197,7 +1200,6 @@
* Disable floating point exepctions
*/
#ifdef __FreeBSD__
-# include <floatingpoint.h>
{
/* seet floating point mask to the Linux default */
fp_except_t mask;

View File

@ -0,0 +1,11 @@
--- lib/videocodec/DirectShow/interfaces.h.orig Thu Jan 11 00:01:43 2001
+++ lib/videocodec/DirectShow/interfaces.h Mon Jul 2 02:45:54 2007
@@ -30,8 +30,6 @@
struct IMemAllocator;
struct IMediaSample;
-enum PIN_DIRECTION;
-
class IClassFactory2
{
public:

View File

@ -1,10 +1,15 @@
--- lib/audioencoder/lame3.70/quantize-pvt.c.orig Mon Dec 11 18:14:41 2006
+++ lib/audioencoder/lame3.70/quantize-pvt.c Mon Dec 11 18:14:59 2006
@@ -1030,7 +1030,7 @@
--- lib/audioencoder/lame3.70/quantize-pvt.c.orig Tue Sep 12 18:12:33 2000
+++ lib/audioencoder/lame3.70/quantize-pvt.c Wed Jul 11 14:46:01 2007
@@ -1029,8 +1029,12 @@
"jnz loop1\n\n"
: /* no outputs */
+#if __GNUC__ >= 4
+ : "t" (istep), "r" (xr), "r" (adj43asm), "r" (ix), "r" (576 / 4), "g" (rx)
+#else
: "t" (istep), "r" (xr), "r" (adj43asm), "r" (ix), "r" (576 / 4), "m" (rx)
- : "%eax", "%ebx", "memory", "cc"
+#endif
+ : "%eax", /* "%ebx", */ "memory", "cc"
);
}

View File

@ -1,5 +1,5 @@
--- lib/loader/win32.h.orig Mon Dec 11 18:10:09 2006
+++ lib/loader/win32.h Mon Dec 11 18:10:21 2006
@@ -1 +1,2 @@
int ext_unknown();
--- lib/loader/win32.h.orig Tue Sep 12 18:12:21 2000
+++ lib/loader/win32.h Mon Jul 2 02:44:09 2007
@@ -1 +1 @@
-int ext_unknown();
+void* LookupExternalByName(const char* library, const char* name);