games/doomlegacy: update Doom Legacy to version 1.48.12 (rev 1643)
Now have to unset SVN_ENABLE so that run-time SVN revision reporting works, and rename one patch file to match modern naming conventions. Reported by: portscout
This commit is contained in:
parent
c91d99603b
commit
fec8825b72
@ -1,6 +1,5 @@
|
||||
PORTNAME= doomlegacy
|
||||
PORTVERSION= 1.48.8
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.48.12
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/${PORTNAME}/${DISTVERSION:S,_,%20,}/
|
||||
@ -18,7 +17,7 @@ USES= gl gmake sdl tar:bzip2
|
||||
USE_GL= gl glu
|
||||
USE_SDL= mixer sdl
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME} share/doom/legacy.wad
|
||||
PLIST_FILES= bin/${PORTNAME} share/doom/dogs.wad share/doom/legacy.wad
|
||||
PORTDOCS= *
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
@ -53,7 +52,7 @@ pre-build:
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/doomlegacy ${STAGEDIR}${PREFIX}/bin
|
||||
@${MKDIR} ${STAGEDIR}${DMDIR}
|
||||
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${PORTVERSION}/legacy.wad \
|
||||
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${PORTVERSION}_common/*.wad \
|
||||
${STAGEDIR}${DMDIR}
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
|
||||
|
@ -1,5 +1,5 @@
|
||||
TIMESTAMP = 1609626982
|
||||
SHA256 (doomlegacy_1.48.8_source.tar.bz2) = 67040b18891e885331806e7e167193dc45fcdad8779052ce5a95f087dba5b766
|
||||
SIZE (doomlegacy_1.48.8_source.tar.bz2) = 2451682
|
||||
SHA256 (doomlegacy_1.48.8_common.zip) = 1b019edc875f744a682dfb6493c83a568fce87cd94e312f79f02ed82c4b1e49c
|
||||
SIZE (doomlegacy_1.48.8_common.zip) = 1011350
|
||||
TIMESTAMP = 1671410365
|
||||
SHA256 (doomlegacy_1.48.12_source.tar.bz2) = 8378e69730ae8fa57596b0c78d24d158618b90dabe9597793b5bd077324b5c44
|
||||
SIZE (doomlegacy_1.48.12_source.tar.bz2) = 2572064
|
||||
SHA256 (doomlegacy_1.48.12_common.zip) = 94cec77e7674b4c80d3f05812335918030056b33889c08d0389c6fffa28f368b
|
||||
SIZE (doomlegacy_1.48.12_common.zip) = 1055689
|
||||
|
@ -1,7 +1,16 @@
|
||||
--- src/Makefile.orig 2018-07-16 09:17:06 UTC
|
||||
--- src/Makefile.orig 2022-12-18 00:00:15 UTC
|
||||
+++ src/Makefile
|
||||
@@ -554,8 +554,10 @@ LIBS:=
|
||||
LDFLAGS:=
|
||||
@@ -234,7 +234,7 @@ OPTLEV=-O3
|
||||
# Developers with svn can enable this to have svn revision number in executable.
|
||||
# Causes compile error message otherwise.
|
||||
# Until can find test for presence of svn, this is best that can be done.
|
||||
-SVN_ENABLE=1
|
||||
+#SVN_ENABLE=1
|
||||
|
||||
# This Makefile may be invoked from within the src directory,
|
||||
# or invoked from the Main Makefile with SRC=<directory>.
|
||||
@@ -610,8 +610,10 @@ endif
|
||||
OPTINC:=
|
||||
INSTALL_SUPPL:=
|
||||
|
||||
-CFLAGS:=
|
||||
@ -12,16 +21,16 @@
|
||||
ifdef ARCH
|
||||
# if does not have leading -march, -mcpu, -mtune, or similar.
|
||||
ifeq ($(filter -march% -mcpu% -mtune% -m%, $(strip $(ARCH))),)
|
||||
@@ -598,7 +600,7 @@ ifeq ($(SMIF), SDL)
|
||||
# default is Linux, for all unix SDL
|
||||
EXENAME:=doomlegacy
|
||||
LDFLAGS+=-L/usr/X11R6/lib
|
||||
- LIBS+=-lGL -lGLU -lm
|
||||
+ LIBS+=-lGL -lGLU -lm -lipx
|
||||
# -L/usr/X11R6/lib is needed by Linux 2.4 and others that still have
|
||||
# the GLU libraries in an X11 directory.
|
||||
# -lm is needed for pow, powf, and other MATH1 functions.
|
||||
@@ -1001,11 +1003,11 @@ ifdef DEBUG
|
||||
@@ -770,7 +772,7 @@ ifeq ($(SMIF), SDL)
|
||||
# default is Linux, for all unix SDL
|
||||
EXENAME:=doomlegacy
|
||||
LDFLAGS+=-L/usr/X11R6/lib
|
||||
- LIBS+=-lGL -lGLU -lm
|
||||
+ LIBS+=-lGL -lGLU -lm -lipx
|
||||
# -L/usr/X11R6/lib is needed by Linux 2.4 and others that still have
|
||||
# the GLU libraries in an X11 directory.
|
||||
# -lm is needed for pow, powf, and other MATH1 functions.
|
||||
@@ -1305,11 +1307,11 @@ ifdef DEBUG
|
||||
else
|
||||
# build a normal optimized version
|
||||
#CFLAGS+=-O3
|
||||
|
@ -1,11 +1,12 @@
|
||||
--- src/sdl/i_system.c.orig 2014-05-16 20:11:49 UTC
|
||||
--- src/sdl/i_system.c.orig 2022-12-18 00:00:15 UTC
|
||||
+++ src/sdl/i_system.c
|
||||
@@ -508,6 +508,8 @@ void I_SysInit(void)
|
||||
@@ -932,6 +932,9 @@ void I_SysInit(void)
|
||||
|
||||
// Enable unicode key conversion
|
||||
SDL_EnableUNICODE(1);
|
||||
+
|
||||
+ // Enable key auto repeat
|
||||
+ SDL_EnableKeyRepeat(SDL_DEFAULT_REPEAT_DELAY, SDL_DEFAULT_REPEAT_INTERVAL);
|
||||
#endif
|
||||
|
||||
// Initialize the joystick subsystem.
|
||||
I_JoystickInit();
|
Loading…
Reference in New Issue
Block a user