devel/allegro: Update to 4.4.3.1
Some static libraries are now built as shared libraries. Bump revision of consumers. Changes: https://github.com/liballeg/allegro5/blob/4.4.3.1/docs/src/changes._tx Changes: https://github.com/liballeg/allegro5/compare/4.4.2...4.4.3.1 PR: 235477
This commit is contained in:
parent
4e4c470b31
commit
feb6abd72f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=495105
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= dumb
|
||||
PORTVERSION= 0.9.3
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= SF
|
||||
|
||||
|
@ -2,10 +2,9 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= allegro
|
||||
DISTVERSION= 4.4.2
|
||||
PORTREVISION= 8
|
||||
DISTVERSION= 4.4.3.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= SF/alleg/allegro/${PORTVERSION}
|
||||
MASTER_SITES= https://github.com/liballeg/allegro5/releases/download/${DISTVERSION}/
|
||||
|
||||
MAINTAINER= tobik@FreeBSD.org
|
||||
COMMENT= Cross-platform library for games and multimedia programming
|
||||
@ -15,31 +14,29 @@ LICENSE_NAME= Giftware
|
||||
LICENSE_FILE= ${WRKSRC}/docs/txt/license.txt
|
||||
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
|
||||
# Required for building libloadpng.a and liballeggl.a
|
||||
BUILD_DEPENDS= png>0:graphics/png \
|
||||
libGLU>0:graphics/libGLU
|
||||
LIB_DEPENDS= libogg.so:audio/libogg \
|
||||
libpng.so:graphics/png \
|
||||
libvorbis.so:audio/libvorbis
|
||||
|
||||
USES= cmake:insource makeinfo pkgconfig
|
||||
USE_XORG= ice sm x11 xpm xext xcursor xxf86vm xxf86dga
|
||||
USES= cmake gl makeinfo pkgconfig
|
||||
USE_GL= gl glu
|
||||
USE_XORG= ice sm x11 xcursor xext xpm xxf86dga xxf86vm
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
INFO= allegro
|
||||
PORTDOCS= *
|
||||
PORTEXAMPLES= *
|
||||
|
||||
PLIST_SUB= SHLIB_VER="${PORTVERSION}"
|
||||
CMAKE_ARGS= -DDOCDIR="${DOCSDIR}" \
|
||||
-DWANT_MODULES=off \
|
||||
-DWANT_LOGG=on \
|
||||
-DWANT_EXAMPLES=off
|
||||
PLIST_SUB= SHLIB_VER="${PORTVERSION:R}"
|
||||
CMAKE_ARGS= -DDOCDIR="${DOCSDIR}"
|
||||
CMAKE_OFF= WANT_EXAMPLES WANT_MODULES
|
||||
CMAKE_ON= WANT_LOGG
|
||||
|
||||
# Wrong versioning upstream
|
||||
PORTSCOUT= ignore:1
|
||||
|
||||
OPTIONS_DEFINE= EXAMPLES DOCS
|
||||
OPTIONS_MULTI= AUDIO
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
OPTIONS_MULTI= AUDIO
|
||||
OPTIONS_MULTI_AUDIO= ALSA JACK OSS SNDIO
|
||||
OPTIONS_DEFAULT= OSS
|
||||
|
||||
@ -69,7 +66,7 @@ post-patch-JACK-on:
|
||||
${WRKSRC}/src/unix/jack.c
|
||||
|
||||
post-install:
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/man/*.3 ${STAGEDIR}${MAN3PREFIX}/man/man3/
|
||||
${INSTALL_MAN} ${INSTALL_WRKSRC}/docs/man/*.3 ${STAGEDIR}${MAN3PREFIX}/man/man3/
|
||||
|
||||
post-install-EXAMPLES-on:
|
||||
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1483711950
|
||||
SHA256 (allegro-4.4.2.tar.gz) = 1b21e7577dbfada02d85ca4510bd22fedaa6ce76fde7f4838c7c1276eb840fdc
|
||||
SIZE (allegro-4.4.2.tar.gz) = 4674902
|
||||
TIMESTAMP = 1552112646
|
||||
SHA256 (allegro-4.4.3.1.tar.gz) = ec19dbc9a021244582b4819b3583ee594b50141f9fcf6944a4ed8069cbf8d4d4
|
||||
SIZE (allegro-4.4.3.1.tar.gz) = 4663634
|
||||
|
@ -1,15 +1,15 @@
|
||||
--- CMakeLists.txt.orig 2011-03-24 23:18:50 UTC
|
||||
--- CMakeLists.txt.orig 2019-02-02 19:28:46 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -66,7 +66,7 @@ if(WIN32)
|
||||
endif(WIN32)
|
||||
|
||||
set(ALLEGRO_VERSION 4.4.2)
|
||||
set(ALLEGRO_VERSION 4.4.3)
|
||||
-string(REGEX MATCH "^[0-9]+[.][0-9]+" ALLEGRO_SOVERSION ${ALLEGRO_VERSION})
|
||||
+string(REGEX MATCH "^[0-9]" ALLEGRO_SOVERSION ${ALLEGRO_VERSION})
|
||||
+string(REGEX MATCH "^[0-9]+" ALLEGRO_SOVERSION ${ALLEGRO_VERSION})
|
||||
|
||||
# Mac OS X -compatibility_version.
|
||||
# XXX doesn't seem to work
|
||||
@@ -408,6 +408,7 @@ option(WANT_OSS "Build OSS support" on)
|
||||
@@ -403,6 +403,7 @@ option(WANT_OSS "Build OSS support" on)
|
||||
option(WANT_ALSA "Build ALSA support" on)
|
||||
option(WANT_JACK "Build JACK support" on)
|
||||
option(WANT_SGIAUDIO "Build SGI audio support" on)
|
||||
@ -17,7 +17,7 @@
|
||||
|
||||
if(ALLEGRO_UNIX) # not MACOSX
|
||||
find_package(Threads)
|
||||
@@ -471,6 +472,17 @@ if(ALLEGRO_UNIX) # not MACOSX
|
||||
@@ -466,6 +467,17 @@ if(ALLEGRO_UNIX) # not MACOSX
|
||||
endif(SGIAUDIO_FOUND)
|
||||
endif(WANT_SGIAUDIO)
|
||||
|
||||
@ -35,12 +35,12 @@
|
||||
# aRts is obsolete
|
||||
# esd is obsolete
|
||||
endif(ALLEGRO_UNIX)
|
||||
@@ -961,7 +973,7 @@ if(UNIX)
|
||||
@ONLY
|
||||
)
|
||||
install(FILES ${LIBRARY_OUTPUT_PATH}/pkgconfig/${name}${lib_type}.pc
|
||||
- DESTINATION "lib${LIB_SUFFIX}/pkgconfig"
|
||||
+ DESTINATION "libdata/pkgconfig"
|
||||
)
|
||||
endforeach(name)
|
||||
endif(UNIX)
|
||||
@@ -744,7 +756,7 @@ endif(BEOS)
|
||||
|
||||
# On Unix/Mac we don't ever use a -static postfix.
|
||||
if(CMAKE_BUILD_TYPE STREQUAL Debug)
|
||||
- set(BUILD_TYPE_SUFFIX -debug)
|
||||
+ set(BUILD_TYPE_SUFFIX "")
|
||||
elseif(CMAKE_BUILD_TYPE STREQUAL Profile)
|
||||
set(BUILD_TYPE_SUFFIX -profile)
|
||||
else()
|
||||
|
@ -118,10 +118,18 @@ include/xalleg.h
|
||||
lib/liballeg.so
|
||||
lib/liballeg.so.4
|
||||
lib/liballeg.so.%%SHLIB_VER%%
|
||||
lib/liballeggl.a
|
||||
lib/libjpgalleg.a
|
||||
lib/libloadpng.a
|
||||
lib/liblogg.a
|
||||
lib/liballeggl.so
|
||||
lib/liballeggl.so.4
|
||||
lib/liballeggl.so.%%SHLIB_VER%%
|
||||
lib/libjpgalleg.so
|
||||
lib/libjpgalleg.so.4
|
||||
lib/libjpgalleg.so.%%SHLIB_VER%%
|
||||
lib/libloadpng.so
|
||||
lib/libloadpng.so.4
|
||||
lib/libloadpng.so.%%SHLIB_VER%%
|
||||
lib/liblogg.so
|
||||
lib/liblogg.so.4
|
||||
lib/liblogg.so.%%SHLIB_VER%%
|
||||
libdata/pkgconfig/allegro.pc
|
||||
libdata/pkgconfig/allegrogl.pc
|
||||
libdata/pkgconfig/jpgalleg.pc
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= fifechan
|
||||
PORTVERSION= 0.1.4
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= devel games
|
||||
|
||||
MAINTAINER= fiziologus@gmail.com
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= guichan
|
||||
PORTVERSION= 0.8.2
|
||||
PORTREVISION= 11
|
||||
PORTREVISION= 12
|
||||
CATEGORIES= devel games
|
||||
MASTER_SITES= http://pkgs.fedoraproject.org/repo/pkgs/guichan/${DISTFILES}/af535d7f387e774e3197cef8023ea105/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= o2em
|
||||
PORTVERSION= 1.17
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= emulators games
|
||||
MASTER_SITES= SF/${PORTNAME}/OldFiles:1 \
|
||||
http://o2em.sourceforge.net/files/:2
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= alex4
|
||||
PORTVERSION= 1.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/allegator/Alex4/source%20and%20data/ \
|
||||
SF/lifanov-ports-distfiles/games/${PORTNAME}/:icons
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= atanks
|
||||
PORTVERSION= 6.5
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= fargoal
|
||||
PORTVERSION= 20040629
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/squidfighter/${PORTNAME}/20040630
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION}
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= garden-of-coloured-lights
|
||||
PORTVERSION= 1.0.9
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/garden/garden/${PORTVERSION}/
|
||||
DISTNAME= garden-${PORTVERSION}
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= opensurge
|
||||
PORTVERSION= 0.1.r${SVN_REV}
|
||||
PORTREVISION= 6
|
||||
PORTREVISION= 7
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://www.ime.usp.br/~alemart/opensurge_nightly/ \
|
||||
SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= alpng
|
||||
PORTVERSION= 1.3
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= SF
|
||||
DISTNAME= ${PORTNAME}13
|
||||
|
@ -4,7 +4,7 @@
|
||||
PORTNAME= aseprite
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.2.9
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
|
@ -4,7 +4,7 @@
|
||||
PORTNAME= chryzodus
|
||||
PORTVERSION= 0.32
|
||||
DISTVERSIONSUFFIX= -src
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= SF
|
||||
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= alfont
|
||||
PORTVERSION= 2.0.9
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= x11-fonts
|
||||
MASTER_SITES= http://opensnc.sourceforge.net/alfont/mirror/
|
||||
|
Loading…
Reference in New Issue
Block a user