security/palisade: Remove unnecessary patches removing the REQUIRED attribute from cmake's find_package(Threads)
This commit is contained in:
parent
91f48640ba
commit
fe74a86ed0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=551659
@ -9,12 +9,3 @@
|
|||||||
add_cxx_compiler_flag(-Wthread-safety)
|
add_cxx_compiler_flag(-Wthread-safety)
|
||||||
if (HAVE_CXX_FLAG_WTHREAD_SAFETY)
|
if (HAVE_CXX_FLAG_WTHREAD_SAFETY)
|
||||||
cxx_feature_check(THREAD_SAFETY_ATTRIBUTES)
|
cxx_feature_check(THREAD_SAFETY_ATTRIBUTES)
|
||||||
@@ -260,7 +260,7 @@ endif()
|
|
||||||
cxx_feature_check(STEADY_CLOCK)
|
|
||||||
# Ensure we have pthreads
|
|
||||||
set(THREADS_PREFER_PTHREAD_FLAG ON)
|
|
||||||
-find_package(Threads REQUIRED)
|
|
||||||
+find_package(Threads)
|
|
||||||
|
|
||||||
# Set up directories
|
|
||||||
include_directories(${PROJECT_SOURCE_DIR}/include)
|
|
||||||
|
@ -1,10 +0,0 @@
|
|||||||
--- third-party/google-benchmark/test/CMakeLists.txt.orig 2019-12-20 21:45:20 UTC
|
|
||||||
+++ third-party/google-benchmark/test/CMakeLists.txt
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
# Enable the tests
|
|
||||||
|
|
||||||
-find_package(Threads REQUIRED)
|
|
||||||
+find_package(Threads)
|
|
||||||
include(CheckCXXCompilerFlag)
|
|
||||||
|
|
||||||
# NOTE: Some tests use `<cassert>` to perform the test. Therefore we must
|
|
Loading…
Reference in New Issue
Block a user