- Update to 2.4.3

- Provide rc_subr startup script
- Take maintainership

PR:		ports/96872
Submitted by:	Shaun Amott <shaun@inerd.com>
This commit is contained in:
Pav Lucistnik 2006-05-07 21:16:16 +00:00
parent 82d113ee07
commit fde16f4917
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=161643
7 changed files with 76 additions and 38 deletions

View File

@ -6,15 +6,16 @@
#
PORTNAME= inn
PORTVERSION= 2.4.1
PORTREVISION= 1
PORTVERSION= 2.4.3
CATEGORIES= news ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= inn
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
MAINTAINER= shaun@inerd.com
COMMENT= InterNetNews -- the Internet meets Netnews
USE_RC_SUBR= innd.sh
NO_LATEST_LINK= yes
USE_GMAKE= yes
USE_PERL5= yes
@ -51,9 +52,9 @@ WITH_BDB_VER= 4
. if (${WITH_BDB_VER} == 3) || (${WITH_BDB_VER} == 4) || (${WITH_BDB_VER} == 41)
LIB_DEPENDS+= db${WITH_BDB_VER}:${PORTSDIR}/databases/db${WITH_BDB_VER}
. elif ${WITH_BDB_VER} == 2
BROKEN= "Does not compile with db2"
BROKEN= Does not compile with db2
. else
BROKEN= "Unknown BerkeleyDB version"
BROKEN= Unknown BerkeleyDB version
. endif
CONFIGURE_ENV+= DB_VER=db${WITH_BDB_VER}
CONFIGURE_ARGS+= --with-berkeleydb=${LOCALBASE}
@ -65,7 +66,6 @@ CONFIGURE_ARGS+= --with-python
.endif
.if defined(WITH_TCL)
USE_REINPLACE= yes
CONFIGURE_ARGS+= --with-tcl=${LOCALBASE}
BUILD_DEPENDS+= ${LOCALBASE}/include/tcl8.3/tcl.h:${PORTSDIR}/lang/tcl83
.endif
@ -100,7 +100,7 @@ HEADERS= clibrary.h config.h dbz.h libinn.h storage.h
MAN1= convdate.1 fastrm.1 getlist.1 grephistory.1 inews.1 innconfval.1 \
innfeed.1 innmail.1 nntpget.1 pgpverify.1 rnews.1 shlock.1 \
shrinkfile.1 simpleftp.1 sm.1 startinnfeed.1
shrinkfile.1 simpleftp.1 sm.1 startinnfeed.1 pullnews.1
MAN3= clientlib.3 dbz.3 inndcomm.3 libauth.3 libinn.3 libinnhist.3 \
libstorage.3 list.3 parsedate.3 qio.3 tst.3 uwildmat.3
MAN5= active.5 active.times.5 buffindexed.conf.5 control.ctl.5 \
@ -116,7 +116,7 @@ MAN8= actsync.8 actsyncd.8 archive.8 auth_smb.8 batcher.8 buffchan.8 \
innupgrade.8 innwatch.8 innxbatch.8 innxmit.8 mailpost.8 makedbz.8 \
makehistory.8 mod-active.8 news.daily.8 news2mail.8 ninpaths.8 \
nnrpd.8 nntpsend.8 ovdb_init.8 ovdb_monitor.8 ovdb_server.8 \
ovdb_stat.8 overchan.8 perl-nocem.8 prunehistory.8 pullnews.8 \
ovdb_stat.8 overchan.8 perl-nocem.8 prunehistory.8 \
radius.8 rc.news.8 scanlogs.8 send-nntp.8 send-uucp.8 sendinpaths.8 \
tally.control.8 tdx-util.8 writelog.8
@ -166,11 +166,9 @@ post-install:
.for FILE in ${HEADERS}
${INSTALL_DATA} ${WRKSRC}/include/${FILE} ${PREFIX}/news/include/
.endfor
@${SED} <${FILESDIR}/innd.sh >${PREFIX}/etc/rc.d/innd.sh \
s+!!PREFIX!!+${PREFIX}+g && ${CHMOD} +x ${PREFIX}/etc/rc.d/innd.sh
@${CHOWN} root:news ${PREFIX}/news/bin/auth/passwd/ckpasswd
@${CHMOD} 4755 ${PREFIX}/news/bin/auth/passwd/ckpasswd
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF ${ETC_DIR}
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF ${ETC_DIR}
@(if [ ! -f ${PREFIX}/news/db/history ] ; then \
${ECHO} 'Creating empty history database...' ; \
cd ${PREFIX}/news/db ; \

View File

@ -1,3 +1,3 @@
MD5 (inn-2.4.1.tar.gz) = bec635b6e70188071fdb539cd374f2ba
SHA256 (inn-2.4.1.tar.gz) = 11effaebfe81f2755151a6e5acb0d1d747e7699d2e8e121e6ae04105f46954d7
SIZE (inn-2.4.1.tar.gz) = 1849845
MD5 (inn-2.4.3.tar.gz) = 6caa10909a7bf55fb91535685990aec9
SHA256 (inn-2.4.3.tar.gz) = b69679ed4b79ed8384db50e43a09a7d52e4da51712235b912bcfae037e137bf2
SIZE (inn-2.4.3.tar.gz) = 1871994

View File

@ -1,9 +0,0 @@
#!/bin/sh
if [ $# -eq 0 -o x$1 = xstart ]; then
if [ -x !!PREFIX!!/news/bin/rc.news -a -f !!PREFIX!!/news/db/history.dir ]; then
su -fm news -c !!PREFIX!!/news/bin/rc.news && echo ' inn'
fi
fi
if [ x$1 = xstop ]; then
su -fm news -c '!!PREFIX!!/news/bin/rc.news stop'
fi

38
news/inn/files/innd.sh.in Normal file
View File

@ -0,0 +1,38 @@
#!/bin/sh
#
# PROVIDE: innd
# REQUIRE: DAEMON
# KEYWORD: shutdown
#
# $FreeBSD$
#
. %%RC_SUBR%%
name=innd
innd_enable=${innd_enable-"NO"}
innd_user=${innd_user-"news"}
innd_group=${innd_group-"news"}
required_files="%%PREFIX%%/news/db/history.dir"
load_rc_config ${name}
start_cmd=${name}_start
stop_cmd=${name}_stop
rcvar=`set_rcvar`
command=%%PREFIX%%/news/bin/rc.news
innd_start() {
su -fm ${innd_user} -c "${command} start"
}
innd_stop() {
su -fm ${innd_user} -c "${command} stop"
}
load_rc_config ${name}
run_rc_command "$1"

View File

@ -1,11 +1,11 @@
--- configure.orig Tue Sep 2 06:39:30 2003
+++ configure Wed Oct 22 15:23:46 2003
@@ -5826,36 +5826,9 @@
--- configure.orig Mon Mar 20 04:14:57 2006
+++ configure Sat May 6 02:32:58 2006
@@ -7604,36 +7604,9 @@
done
done
fi
- if test x"$BERKELEY_DB_DIR" = xyes ; then
- for v in db41 db4 db3 db2 ; do
- for v in db43 db42 db41 db4 db3 db2 ; do
- if test -d "/usr/local/include/$v" ; then
- BERKELEY_DB_LDFLAGS="-L/usr/local/lib"
- BERKELEY_DB_CFLAGS="-I/usr/local/include/$v"
@ -15,7 +15,7 @@
- fi
- done
- if test x"$BERKELEY_DB_LIB" = x ; then
- for v in db41 db4 db3 db2 ; do
- for v in db43 db42 db41 db4 db3 db2 ; do
- if test -d "/usr/include/$v" ; then
- BERKELEY_DB_CFLAGS="-I/usr/include/$v"
- BERKELEY_DB_LIB="-l$v"

View File

@ -1,8 +1,8 @@
--- site/Makefile.orig Sat Jul 12 21:11:02 2003
+++ site/Makefile Sun Sep 21 12:53:00 2003
@@ -23,29 +23,29 @@
PATH_NNRPAUTH = ${PATHFILTER}/nnrpd_auth.pl
--- site/Makefile.orig Mon Mar 20 04:14:57 2006
+++ site/Makefile Sat May 6 04:15:50 2006
@@ -24,29 +24,29 @@
PATH_NNRPYAUTH = ${PATHFILTER}/nnrpd_auth.py
PATH_NNRPACCESS = ${PATHFILTER}/nnrpd_access.pl
-PATH_CONFIG = ${PATHETC}/inn.conf
-PATH_CONTROLCTL = ${PATHETC}/control.ctl
@ -53,7 +53,7 @@
PATH_ACTIVE = ${PATHDB}/active
PATH_ACTIVE_TIMES = ${PATHDB}/active.times
@@ -71,8 +71,8 @@
@@ -73,8 +73,8 @@
$D$(PATH_NEWSFEEDS) $D$(PATH_INNDHOSTS) \
$D$(PATH_NNRPDTRACK) $D$(PATH_NNTPPASS) \
$D$(PATH_CONFIG) $D$(PATH_MODERATORS) \
@ -64,16 +64,27 @@
$D$(PATH_CTLWATCH) $D$(PATH_DISTPATS) $D$(PATH_SCHEMA) \
$D$(PATH_ACTSYNC_CFG) $D$(PATH_ACTSYNC_IGN) \
$D$(PATH_MOTD) $D$(PATH_STORAGECONF) \
@@ -81,7 +81,7 @@
@@ -83,7 +83,7 @@
$D$(PATH_PERL_FILTER_INND) $D$(PATH_PERL_FILTER_NNRPD) \
$D$(PATH_PYTHON_FILTER_INND) $D$(PATH_PYTHON_INN_MODULE) \
$D$(PATH_TCL_STARTUP) $D$(PATH_TCL_FILTER) \
- $D$(PATH_NNRPAUTH) $D$(PATHETC)/news2mail.cf $D$(PATH_READERSCONF) \
+ $D$(PATH_NNRPAUTH) $D$(PATHETC)/news2mail.cf.dist $D$(PATH_READERSCONF) \
$D$(PATH_RADIUS_CONF) $D$(PATH_NNRPYAUTH) $D$(PATH_OVDB_CONF) \
$D$(PATH_SASL_CONF) $D$(PATH_SUBSCRIPTIONS)
$D$(PATH_SASL_CONF) $D$(PATH_SUBSCRIPTIONS) $D$(PATH_NNRPACCESS)
@@ -170,9 +170,9 @@
@@ -136,8 +136,8 @@
chgrp $(NEWSGROUP) $@
chmod $(FILEMODE) $@
$D$(PATH_HISTORY):
- touch $@
- $(PATHBIN)/makedbz -i -o
+# touch $@
+# $(PATHBIN)/makedbz -i -o
## Remove files that are unchanged from the release version.
clean:
@@ -176,9 +176,9 @@
$D$(PATH_MODERATORS): moderators ; $(COPY_RPUB) $? $@
$D$(PATH_DISTPATS): distrib.pats ; $(COPY_RPUB) $? $@
$D$(PATH_NNTPPASS): passwd.nntp ; $(COPY_RPRI) $? $@

View File

@ -1,4 +1,3 @@
etc/rc.d/innd.sh
news/bin/actmerge
news/bin/actsync
news/bin/actsyncd
@ -36,6 +35,7 @@ news/bin/filter/filter.tcl
news/bin/filter/filter_innd.pl
news/bin/filter/filter_innd.py
news/bin/filter/filter_nnrpd.pl
news/bin/filter/nnrpd_access.pl
news/bin/filter/nnrpd_auth.pl
news/bin/filter/nnrpd_auth.py
news/bin/filter/startup.tcl