mail/mailsync: Fix build with Clang 6.0.0
exit function declared in autoconf 2.59 configure scripts conflicts with Clang 6 because stdlib.h declares it with an attribute for C++11 or later. This is fixed in later versions of autoconf 2.60. - Add USES=autoreconf to regenerate configure, new version of autoconf no longer declares the exit function. [1] - Merge the changes from files/patch-configure and post-patch taget into acinclude/ac_with_{cclient,openssl}.m4 [1] http://git.savannah.gnu.org/cgit/autoconf.git/commit/?id=a71c24a704ec0570ba99be909fffbc044d50908b Reviewed by: koobs, mat Approved by: koobs (mentor) Differential Revision: https://reviews.freebsd.org/D15532 MFH: 2018Q2
This commit is contained in:
parent
b23f789f3a
commit
fdcd202235
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=471197
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= mailsync
|
||||
PORTVERSION= 5.2.1
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= SF
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
|
||||
@ -15,7 +15,7 @@ LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= libc-client4.so:mail/cclient
|
||||
|
||||
USES= gmake ssl
|
||||
USES= autoreconf gmake ssl
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-c-client=${LOCALBASE} \
|
||||
--with-openssl=${OPENSSLBASE}
|
||||
@ -24,10 +24,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|\($withval\),$${OPENSSLLOCATIONS}|\1|g' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/mailsync ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/mailsync.1 ${STAGEDIR}${MANPREFIX}/man/man1
|
||||
|
54
mail/mailsync/files/patch-acinclude_ac__with__cclient.m4
Normal file
54
mail/mailsync/files/patch-acinclude_ac__with__cclient.m4
Normal file
@ -0,0 +1,54 @@
|
||||
FreeBSD sh(1) does not support the Brace Expansion.
|
||||
|
||||
--- acinclude/ac_with_cclient.m4.orig 2018-05-22 07:37:52 UTC
|
||||
+++ acinclude/ac_with_cclient.m4
|
||||
@@ -3,7 +3,7 @@ dnl Output:
|
||||
dnl AC_SUBST: @CCLIENT_INCLUDES@ @CCLIENT_LIBS@ @CCLIENT_CXXFLAGS@
|
||||
dnl AM_CONDITIONAL: HAVE_CCLIENT
|
||||
AC_DEFUN(AC_WITH_CCLIENT,[
|
||||
- CCLIENTLOCATIONS="/usr,/usr/local"
|
||||
+ CCLIENTLOCATIONS=""
|
||||
HAVE_CCLIENT="no"
|
||||
CCLIENT_LIBS=""
|
||||
CCLIENT_INCLUDES=""
|
||||
@@ -16,7 +16,7 @@ AC_DEFUN(AC_WITH_CCLIENT,[
|
||||
if test "$withval" = "no" ; then
|
||||
CCLIENTLOCATIONS=""
|
||||
else
|
||||
- test "$withval" = "yes" || CCLIENTLOCATIONS="$withval,${CCLIENTLOCATIONS}"
|
||||
+ test "$withval" = "yes" || CCLIENTLOCATIONS="$withval"
|
||||
fi
|
||||
]
|
||||
)
|
||||
@@ -28,7 +28,7 @@ AC_DEFUN(AC_WITH_CCLIENT,[
|
||||
dnl Looking for headers c-client headers
|
||||
dnl
|
||||
AC_MSG_CHECKING([for c-client.h])
|
||||
- for p in `eval "echo {${CCLIENTLOCATIONS}}{,/c-client,/lib/c-client,/include/c-client,/include,/include/imap}"` ; do
|
||||
+ p=${CCLIENTLOCATIONS}/include/c-client
|
||||
if test -r "${p}/c-client.h" -a -r "${p}/linkage.h" -a -r "${p}/linkage.c" ; then
|
||||
CCLIENT_INCLUDES="-I${p}"
|
||||
CCLIENT_LINKAGE_H="${p}/linkage.h"
|
||||
@@ -36,7 +36,6 @@ AC_DEFUN(AC_WITH_CCLIENT,[
|
||||
AC_MSG_RESULT([found in ${p}])
|
||||
break
|
||||
fi
|
||||
- done
|
||||
if test -z "${CCLIENT_INCLUDES}" ; then
|
||||
AC_MSG_RESULT([not found])
|
||||
ifelse([$2], , :, [$2])
|
||||
@@ -48,13 +47,12 @@ AC_DEFUN(AC_WITH_CCLIENT,[
|
||||
dnl Looking for c-client libraries
|
||||
dnl
|
||||
AC_MSG_CHECKING([for c-client library])
|
||||
- for l in `eval "echo {${CCLIENTLOCATIONS}}{,/c-client,/lib/c-client,/lib,/lib64}/{libc-client,libc-client4,c-client}{${SOP}}"` ; do
|
||||
+ l=${CCLIENTLOCATIONS}/lib/libc-client4.so
|
||||
if test -r "$l" ; then
|
||||
AC_MSG_RESULT([found ${l}])
|
||||
CCLIENT_LIBS="$l"
|
||||
break
|
||||
fi
|
||||
- done
|
||||
if test -z "${CCLIENT_LIBS}" ; then
|
||||
AC_MSG_RESULT([not found])
|
||||
ifelse([$2], , :, [$2])
|
52
mail/mailsync/files/patch-acinclude_ac__with__openssl.m4
Normal file
52
mail/mailsync/files/patch-acinclude_ac__with__openssl.m4
Normal file
@ -0,0 +1,52 @@
|
||||
FreeBSD sh(1) does not support the Brace Expansion.
|
||||
|
||||
--- acinclude/ac_with_openssl.m4.orig 2018-05-22 07:38:01 UTC
|
||||
+++ acinclude/ac_with_openssl.m4
|
||||
@@ -3,7 +3,7 @@ dnl Output:
|
||||
dnl AC_SUBST: @OPENSSL_INCLUDES@ @OPENSSL_LDFLAGS@ @OPENSSL_LIBS@
|
||||
dnl AM_CONDITIONAL: HAVE_OPENSSL
|
||||
AC_DEFUN(AC_WITH_OPENSSL,[
|
||||
- OPENSSLLOCATIONS="/usr,/usr/local,/usr/local/openssl,/opt/openssl,/usr/local/ssl,/usr/lib/ssl,/usr/ssl"
|
||||
+ OPENSSLLOCATIONS=""
|
||||
HAVE_OPENSSL="no"
|
||||
OPENSSL_LDFLAGS=""
|
||||
OPENSSL_LIBS=""
|
||||
@@ -14,7 +14,7 @@ AC_DEFUN(AC_WITH_OPENSSL,[
|
||||
if test "$withval" = "no" ; then
|
||||
OPENSSLLOCATIONS=""
|
||||
else
|
||||
- test "$withval" = "yes" || OPENSSLLOCATIONS="$withval,${OPENSSLLOCATIONS}"
|
||||
+ test "$withval" = "yes" || OPENSSLLOCATIONS="$withval"
|
||||
fi
|
||||
]
|
||||
)
|
||||
@@ -22,13 +22,12 @@ AC_DEFUN(AC_WITH_OPENSSL,[
|
||||
ifelse([$2], , :, [$2])
|
||||
else
|
||||
AC_MSG_CHECKING([for libssl])
|
||||
- for p in `eval "echo {${OPENSSLLOCATIONS}}{/lib,/lib64}"` ; do
|
||||
+ p=${OPENSSLLOCATIONS}/lib
|
||||
if test -r "${p}/libssl.a" -o -r "${p}/libssl.so" ; then
|
||||
OPENSSL_LDFLAGS="-L${p}"
|
||||
AC_MSG_RESULT([found in ${p}])
|
||||
break
|
||||
fi
|
||||
- done
|
||||
if test -z "${OPENSSL_LDFLAGS}" ; then
|
||||
AC_MSG_RESULT([not found])
|
||||
ifelse([$2], , :, [$2])
|
||||
@@ -50,13 +49,12 @@ AC_DEFUN(AC_WITH_OPENSSL,[
|
||||
ifelse([$2], , :, [$2])
|
||||
else
|
||||
AC_MSG_CHECKING([for openssl/ssl.h])
|
||||
- for p in `eval "echo {${OPENSSLLOCATIONS}}{/include,}"` ; do
|
||||
+ p=${OPENSSLLOCATIONS}/include
|
||||
if test -r "${p}/openssl/ssl.h" ; then
|
||||
OPENSSL_INCLUDES="-I${p}"
|
||||
AC_MSG_RESULT([found in ${p}])
|
||||
break
|
||||
fi
|
||||
- done
|
||||
if test -z "${OPENSSL_INCLUDES}" ; then
|
||||
AC_MSG_RESULT([not found])
|
||||
ifelse([$2], , :, [$2])
|
@ -1,96 +0,0 @@
|
||||
--- configure.orig 2004-06-30 08:04:12 UTC
|
||||
+++ configure
|
||||
@@ -5012,7 +5012,7 @@ fi
|
||||
|
||||
|
||||
|
||||
- OPENSSLLOCATIONS="/usr,/usr/local,/usr/local/openssl,/opt/openssl,/usr/local/ssl,/usr/lib/ssl,/usr/ssl"
|
||||
+ OPENSSLLOCATIONS="/usr"
|
||||
HAVE_OPENSSL="no"
|
||||
OPENSSL_LDFLAGS=""
|
||||
OPENSSL_LIBS=""
|
||||
@@ -5035,14 +5035,13 @@ fi;
|
||||
else
|
||||
echo "$as_me:$LINENO: checking for libssl" >&5
|
||||
echo $ECHO_N "checking for libssl... $ECHO_C" >&6
|
||||
- for p in `eval "echo {${OPENSSLLOCATIONS}}{/lib,/lib64}"` ; do
|
||||
+ p=${OPENSSLLOCATIONS}/lib
|
||||
if test -r "${p}/libssl.a" -o -r "${p}/libssl.so" ; then
|
||||
OPENSSL_LDFLAGS="-L${p}"
|
||||
echo "$as_me:$LINENO: result: found in ${p}" >&5
|
||||
echo "${ECHO_T}found in ${p}" >&6
|
||||
break
|
||||
fi
|
||||
- done
|
||||
if test -z "${OPENSSL_LDFLAGS}" ; then
|
||||
echo "$as_me:$LINENO: result: not found" >&5
|
||||
echo "${ECHO_T}not found" >&6
|
||||
@@ -5190,14 +5189,13 @@ fi
|
||||
else
|
||||
echo "$as_me:$LINENO: checking for openssl/ssl.h" >&5
|
||||
echo $ECHO_N "checking for openssl/ssl.h... $ECHO_C" >&6
|
||||
- for p in `eval "echo {${OPENSSLLOCATIONS}}{/include,}"` ; do
|
||||
+ p=${OPENSSLLOCATIONS}/include
|
||||
if test -r "${p}/openssl/ssl.h" ; then
|
||||
OPENSSL_INCLUDES="-I${p}"
|
||||
echo "$as_me:$LINENO: result: found in ${p}" >&5
|
||||
echo "${ECHO_T}found in ${p}" >&6
|
||||
break
|
||||
fi
|
||||
- done
|
||||
if test -z "${OPENSSL_INCLUDES}" ; then
|
||||
echo "$as_me:$LINENO: result: not found" >&5
|
||||
echo "${ECHO_T}not found" >&6
|
||||
@@ -5447,7 +5445,7 @@ fi
|
||||
|
||||
|
||||
|
||||
- CCLIENTLOCATIONS="/usr,/usr/local"
|
||||
+ CCLIENTLOCATIONS=""
|
||||
HAVE_CCLIENT="no"
|
||||
CCLIENT_LIBS=""
|
||||
CCLIENT_INCLUDES=""
|
||||
@@ -5462,7 +5460,7 @@ if test "${with_c_client+set}" = set; th
|
||||
if test "$withval" = "no" ; then
|
||||
CCLIENTLOCATIONS=""
|
||||
else
|
||||
- test "$withval" = "yes" || CCLIENTLOCATIONS="$withval,${CCLIENTLOCATIONS}"
|
||||
+ test "$withval" = "yes" || CCLIENTLOCATIONS="$withval"
|
||||
fi
|
||||
|
||||
|
||||
@@ -5477,8 +5475,8 @@ echo "$as_me: error: a working c-client
|
||||
|
||||
echo "$as_me:$LINENO: checking for c-client.h" >&5
|
||||
echo $ECHO_N "checking for c-client.h... $ECHO_C" >&6
|
||||
- for p in `eval "echo {${CCLIENTLOCATIONS}}{,/c-client,/lib/c-client,/include/c-client,/include,/include/imap}"` ; do
|
||||
- if test -r "${p}/c-client.h" -a -r "${p}/linkage.h" -a -r "${p}/linkage.c" ; then
|
||||
+ p=${CCLIENTLOCATIONS}/include/c-client
|
||||
+ if test -r "${p}/c-client.h" -a -r "${p}/linkage.h" ; then
|
||||
CCLIENT_INCLUDES="-I${p}"
|
||||
CCLIENT_LINKAGE_H="${p}/linkage.h"
|
||||
CCLIENT_LINKAGE_C="${p}/linkage.c"
|
||||
@@ -5486,7 +5484,6 @@ echo $ECHO_N "checking for c-client.h...
|
||||
echo "${ECHO_T}found in ${p}" >&6
|
||||
break
|
||||
fi
|
||||
- done
|
||||
if test -z "${CCLIENT_INCLUDES}" ; then
|
||||
echo "$as_me:$LINENO: result: not found" >&5
|
||||
echo "${ECHO_T}not found" >&6
|
||||
@@ -5501,14 +5498,13 @@ echo "$as_me: error: a working c-client
|
||||
|
||||
echo "$as_me:$LINENO: checking for c-client library" >&5
|
||||
echo $ECHO_N "checking for c-client library... $ECHO_C" >&6
|
||||
- for l in `eval "echo {${CCLIENTLOCATIONS}}{,/c-client,/lib/c-client,/lib,/lib64}/{libc-client,libc-client4,c-client}{${SOP}}"` ; do
|
||||
+ l=${CCLIENTLOCATIONS}/lib/libc-client4.so
|
||||
if test -r "$l" ; then
|
||||
echo "$as_me:$LINENO: result: found ${l}" >&5
|
||||
echo "${ECHO_T}found ${l}" >&6
|
||||
CCLIENT_LIBS="$l"
|
||||
break
|
||||
fi
|
||||
- done
|
||||
if test -z "${CCLIENT_LIBS}" ; then
|
||||
echo "$as_me:$LINENO: result: not found" >&5
|
||||
echo "${ECHO_T}not found" >&6
|
8
mail/mailsync/files/patch-configure.ac
Normal file
8
mail/mailsync/files/patch-configure.ac
Normal file
@ -0,0 +1,8 @@
|
||||
--- configure.ac.orig 2018-05-22 07:39:19 UTC
|
||||
+++ configure.ac
|
||||
@@ -1,4 +1,5 @@
|
||||
AC_INIT([mailsync], [5.2.1], [tpo_deb@sourcepole.ch])
|
||||
+AC_CONFIG_MACRO_DIR([acinclude])
|
||||
AM_INIT_AUTOMAKE
|
||||
AM_CONFIG_HEADER(config.h)
|
||||
AC_CONFIG_SRCDIR([src/mailsync_main.cc])
|
Loading…
Reference in New Issue
Block a user