- Do not build and link against bundled LZ4 library

- Amend JPEG2000 option description and port description
This commit is contained in:
Alexey Dokuchaev 2020-06-19 16:35:56 +00:00
parent 2a3693c671
commit fda5637ec5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=539668
3 changed files with 28 additions and 3 deletions

View File

@ -16,6 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libglfw.so:graphics/glfw \
liblz4.so:archivers/liblz4 \
libpng.so:graphics/png
USES= cmake:insource compiler:c++11-lang gl jpeg pkgconfig \
@ -66,6 +67,8 @@ WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
WEBP_CMAKE_OFF= -DDISABLE_WEBP_SUPPORT:STRING=1
post-patch:
@${REINPLACE_CMD} -e '/#include/s,lz4/,,' \
${WRKSRC}/src/formats/formatage.cpp
@${REINPLACE_CMD} -e 's,%%DATADIR%%,${DATADIR},' \
${WRKSRC}/src/main.cpp
@ -83,3 +86,5 @@ do-install-EXAMPLES-on:
${INSTALL_DATA} ${WRKSRC}/config.example ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
JPEG2000_DESC+= via OpenJPEG

View File

@ -9,3 +9,22 @@
else()
message(STATUS "* Debug Build *")
add_definitions("-DDEBUG" )
@@ -316,7 +316,6 @@ endif()
message(STATUS "***************************")
add_subdirectory(third-party/imgui)
-add_subdirectory(third-party/lz4)
include_directories("src")
@@ -349,8 +348,8 @@ else()
add_executable(sviewgl ${SVIEW_SOURCES})
endif()
-add_dependencies(sviewgl ImGui LZ4)
-target_link_libraries(sviewgl ImGui LZ4)
+add_dependencies(sviewgl ImGui)
+target_link_libraries(sviewgl ImGui lz4)
if(OPENGL_FOUND)
target_link_libraries(sviewgl ${OPENGL_LIBRARY})

View File

@ -1,10 +1,11 @@
Simple Viewer is small and simple OpenGL based image viewer. Its features:
- Supported formats: PNG, JPEG, PSD, XCF, SVG, GIF, TIFF, TARGA,
ICO, BMP, PNM, DDS, BMP, XWD, SCR (ZX-Spectrum screen), XPM, WebP
- Lightweight and fast: utilizes hardware-accelerated video card
- GIF animation, embedded ICC profiles, and Exif tags support
- Very simple interface, minimum dependencies
- Very simple interface, minimum dependencies, does not require any
specific desktop environment
- Suitable as default (general-purpose) desktop image viewer
- Desktop independent: does not require any specific desktop environment
- Open source, licensed under GNU GPLv2
WWW: https://bitbucket.org/andreyu/simple-viewer-gl