Add tads 2.5.7, a compiler, debugger and runtime interpreter of

adventure games/interactive fiction.  See

  http://www.igs.net/~tril/if/best/

for sample game files.
This commit is contained in:
Kris Kennaway 2003-01-17 08:50:23 +00:00
parent 0bac00d4a5
commit fd6cc2b7ee
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=73320
7 changed files with 71 additions and 0 deletions

View File

@ -295,6 +295,7 @@
SUBDIR += stvef-paks
SUBDIR += stvef-server
SUBDIR += sxsame
SUBDIR += tads
SUBDIR += taipan
SUBDIR += tank
SUBDIR += teg

19
games/tads/Makefile Normal file
View File

@ -0,0 +1,19 @@
# New ports collection makefile for: tds
# Date created: 17 Jan 2003
# Whom: kris@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= tads
PORTVERSION= 2.5.7
CATEGORIES= games
MASTER_SITES= http://www.ifarchive.org/if-archive/programming/tads2/source/
DISTNAME= tads23-unix
MAINTAINER= kris@FreeBSD.org
WRKSRC= ${WRKDIR}/tads/tads2
MAKEFILE= makefile
.include <bsd.port.mk>

1
games/tads/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (tads23-unix.tar.gz) = 33a54946f42f2a8cf5d5189794351e6c

View File

@ -0,0 +1,29 @@
--- makefile.orig Fri Jan 17 00:30:32 2003
+++ makefile Fri Jan 17 00:30:49 2003
@@ -238,16 +238,16 @@
# compatibility libraries installed. It has not been tested with a bare
# FreeBSD system without the Linux libraries.
#
-#CC=gcc
-#OPTIMIZE=
-#UNIXFLAGS=-g -DOSANSI -DUNIX -DHAVE_STRCASECMP
-#SYSFLAGS= -DOS_SYSTEM_NAME=\""FREEBSD_386"\" -DSYSNAME=\""i386+ running FreeBSD"\" -DSYSPL=\"1\" -DPORTER=\""$(DAVE)"\" -DSYSMAINTAINER=\""FreeBSD port maintained by $(DAVE)\n"\"
-#CFLAGS= $(UNIXFLAGS) $(SYSFLAGS) -DFREEBSD_386
-#AFLAGS=
-#OVLFLG=
-#MACHDEP=
-#LIBS=-ltermcap
-#MAKEXEC=touch
+CC?=cc
+OPTIMIZE=
+UNIXFLAGS=-g -DOSANSI -DUNIX -DHAVE_STRCASECMP
+SYSFLAGS= -DOS_SYSTEM_NAME=\""FREEBSD_386"\" -DSYSNAME=\""i386+ running FreeBSD"\" -DSYSPL=\"1\" -DPORTER=\""$(DAVE)"\" -DSYSMAINTAINER=\""FreeBSD port maintained by $(DAVE)\n"\"
+CFLAGS+= $(UNIXFLAGS) $(SYSFLAGS) -DFREEBSD_386
+AFLAGS=
+OVLFLG=
+MACHDEP=
+LIBS=-ltermcap
+MAKEXEC=touch
# OpenBSD 3.0 with gcc 2.95.3
# This has been compiled on an i386 system running OPENBSD 3.0

1
games/tads/pkg-comment Normal file
View File

@ -0,0 +1 @@
TADS compiler/interpreter for interactive fiction

17
games/tads/pkg-descr Normal file
View File

@ -0,0 +1,17 @@
TADS is a set of programming tools specially designed for writing
adventure games. TADS consists of:
* A programming language, which resembles C and Java.
* A compiler, which reads a set of source files written in the
TADS programming language and produces a portable binary game
file.
* A library, which provides a set of generic adventure game
definitions.
* An interactive debugger, which lets you examine
your program's execution in order to find and fix programming
errors.
* An interpreter, which a player uses to run your game.
See http://www.plover.net/~textfire/raiffaq/ifaq/ for more
information about obtaining game files.
WWW: http://www.tads.org/

3
games/tads/pkg-plist Normal file
View File

@ -0,0 +1,3 @@
bin/tadsc
bin/tadsr
bin/tdb