- Update pgrouting to 2.3.0
PR: 213066 Submitted by: lbartoletti@tuxfamily.org (maintainer)
This commit is contained in:
parent
a0ccc4ef5e
commit
fd41b0e1e6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=424022
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pgrouting
|
||||
PORTVERSION= 2.2.4
|
||||
PORTVERSION= 2.3.0
|
||||
DISTVERSIONPREFIX= ${PORTNAME}-
|
||||
CATEGORIES= databases geography
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1470845051
|
||||
SHA256 (pgRouting-pgrouting-pgrouting-2.2.4_GH0.tar.gz) = 34ccf2b1acd076ad7da92c0692a114d0b607b84771fdfd4e131246ef2c66bf84
|
||||
SIZE (pgRouting-pgrouting-pgrouting-2.2.4_GH0.tar.gz) = 4374276
|
||||
TIMESTAMP = 1474949998
|
||||
SHA256 (pgRouting-pgrouting-pgrouting-2.3.0_GH0.tar.gz) = cadeed30bfc57f6e77bc48a10301b26e5d71d8e86f366ed60ab5b0eaa0c45662
|
||||
SIZE (pgRouting-pgrouting-pgrouting-2.3.0_GH0.tar.gz) = 6546737
|
||||
|
@ -1,27 +0,0 @@
|
||||
--- CMakeLists.txt.orig 2016-05-15 23:38:54 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -224,20 +224,20 @@ if(APPLE)
|
||||
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
|
||||
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -O2 -g -frounding-math -Wno-deprecated")
|
||||
else()
|
||||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -O2 -std=c++0x -g -Wno-deprecated")
|
||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -O2 -std=c++11 -g -Wno-deprecated")
|
||||
endif()
|
||||
|
||||
elseif(UNIX) # UNIX system variable include UNIX like system(i.e. APPLE and CYGWIN)
|
||||
#set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 -fPIC -O2 -g -Wall -Wconversion -pedantic -fmax-errors=10 -Wmissing-prototypes -frounding-math")
|
||||
- #set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x -fPIC -O2 -g -Wall -Wconversion -pedantic -fmax-errors=10 -Wextra -frounding-math -Wno-deprecated")
|
||||
+ #set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -fPIC -O2 -g -Wall -Wconversion -pedantic -fmax-errors=10 -Wextra -frounding-math -Wno-deprecated")
|
||||
|
||||
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC -O2 -g -frounding-math")
|
||||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -O2 -g -std=c++0x -frounding-math -Wno-deprecated")
|
||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -O2 -g -std=c++11 -frounding-math -Wno-deprecated")
|
||||
|
||||
elseif(WIN32)
|
||||
# currently, support MinGW only
|
||||
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O2 -frounding-math")
|
||||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O2 -std=c++0x -frounding-math -Wno-deprecated")
|
||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O2 -std=c++11 -frounding-math -Wno-deprecated")
|
||||
endif()
|
||||
|
||||
# List variable to collect module SQL file names
|
@ -1,7 +1,7 @@
|
||||
--- src/trsp/src/GraphDefinition.cpp.orig 2016-05-15 23:38:54 UTC
|
||||
--- src/trsp/src/GraphDefinition.cpp.orig 2016-09-26 14:22:29 UTC
|
||||
+++ src/trsp/src/GraphDefinition.cpp
|
||||
@@ -26,7 +26,7 @@ Foundation, Inc., 51 Franklin Street, Fi
|
||||
#include <windows.h>
|
||||
@@ -28,7 +28,7 @@ Foundation, Inc., 51 Franklin Street, Fi
|
||||
#undef max
|
||||
#endif
|
||||
|
||||
-
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- src/trsp/src/trsp_core.cpp.orig 2016-05-15 23:38:54 UTC
|
||||
+++ src/trsp/src/trsp_core.cpp
|
||||
--- src/trsp/src/trsp_driver.cpp.orig 2016-09-26 14:22:29 UTC
|
||||
+++ src/trsp/src/trsp_driver.cpp
|
||||
@@ -25,6 +25,7 @@ Foundation, Inc., 51 Franklin Street, Fi
|
||||
#include <windows.h>
|
||||
#endif
|
@ -1,10 +0,0 @@
|
||||
--- src/tsp/src/tsplib.c.orig 2016-05-15 23:38:54 UTC
|
||||
+++ src/tsp/src/tsplib.c
|
||||
@@ -85,6 +85,7 @@ THE SOFTWARE.
|
||||
//#include <winsock2.h>
|
||||
//#endif
|
||||
#include <postgres.h>
|
||||
+#include <stdlib.h>
|
||||
#include <string.h> /* memcpy */
|
||||
#include <math.h> /* exp */
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/vrp_basic/src/VRP_Solver.cpp.orig 2016-05-16 20:28:00 UTC
|
||||
+++ src/vrp_basic/src/VRP_Solver.cpp
|
||||
@@ -28,6 +28,8 @@ Foundation, Inc., 51 Franklin Street, Fi
|
||||
|
||||
#include <algorithm>
|
||||
#include "VRP_Solver.h"
|
||||
+#include <cstdlib>
|
||||
+#include <cmath>
|
||||
|
||||
#undef PGR_LOGGER_ON
|
||||
#define PGR_LOGGER_LOC
|
@ -1,10 +1,11 @@
|
||||
lib/postgresql/libpgrouting-2.2.so
|
||||
share/postgresql/extension/pgrouting--2.0.0--2.2.4.sql
|
||||
share/postgresql/extension/pgrouting--2.0.1--2.2.4.sql
|
||||
share/postgresql/extension/pgrouting--2.1.0--2.2.4.sql
|
||||
share/postgresql/extension/pgrouting--2.2.0--2.2.4.sql
|
||||
share/postgresql/extension/pgrouting--2.2.1--2.2.4.sql
|
||||
share/postgresql/extension/pgrouting--2.2.2--2.2.4.sql
|
||||
share/postgresql/extension/pgrouting--2.2.3--2.2.4.sql
|
||||
share/postgresql/extension/pgrouting--2.2.4.sql
|
||||
lib/postgresql/libpgrouting-2.3.so
|
||||
share/postgresql/extension/pgrouting--2.0.0--2.3.0.sql
|
||||
share/postgresql/extension/pgrouting--2.0.1--2.3.0.sql
|
||||
share/postgresql/extension/pgrouting--2.1.0--2.3.0.sql
|
||||
share/postgresql/extension/pgrouting--2.2.0--2.3.0.sql
|
||||
share/postgresql/extension/pgrouting--2.2.1--2.3.0.sql
|
||||
share/postgresql/extension/pgrouting--2.2.2--2.3.0.sql
|
||||
share/postgresql/extension/pgrouting--2.2.3--2.3.0.sql
|
||||
share/postgresql/extension/pgrouting--2.2.4--2.3.0.sql
|
||||
share/postgresql/extension/pgrouting--2.3.0.sql
|
||||
share/postgresql/extension/pgrouting.control
|
||||
|
Loading…
Reference in New Issue
Block a user