Updated to 1.6.3
PR: 13640 Submitted by: maintainer
This commit is contained in:
parent
a1f39d4413
commit
fcf47fd4e3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=21417
@ -1,55 +1,34 @@
|
||||
# New ports collection makefile for: gd
|
||||
# Version required: 1.3+kanji.patch
|
||||
# New ports collection makefile for: gd
|
||||
# Version required: 1.6.3
|
||||
# Date created: 19 Aug 1998
|
||||
# Whom: ichiro@ichiro.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= gd1.3
|
||||
PKGNAME= ja-gd-1.3
|
||||
DISTNAME= gd-1.6.3
|
||||
PKGNAME= ja-gd-1.6.3
|
||||
CATEGORIES= japanese graphics
|
||||
MASTER_SITES= http://www.boutell.com/gd/http/ \
|
||||
MASTER_SITES= http://www.boutell.com/gd/http/ \
|
||||
ftp://ftp.boutell.com/pub/boutell/gd/
|
||||
|
||||
PATCH_SITES= http://pg.cni.co.jp/GD/
|
||||
PATCHFILES= gd1.3.kanji.patch-fix1.gz
|
||||
PATCH_DIST_STRIP= # empty
|
||||
PATCH_SITES= ftp://ftp.ipc.chiba-u.ac.jp/pub/pub.yamaga/gd/1.6.3
|
||||
PATCHFILES= gd-1.6.3.ttf-kanji.patch.990731
|
||||
|
||||
MAINTAINER= ichiro@ichiro.org
|
||||
|
||||
BUILD_DEPENDS= ${PREFIX}/lib/libVFlib2.so:${PORTSDIR}/japanese/vflib
|
||||
|
||||
RESTRICTED= unavailable from master site due to legal problems
|
||||
LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png
|
||||
|
||||
FETCH_BEFORE_ARGS= -b
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
|
||||
CONFIGURE_ARGS+= --includedir=${PREFIX}/include/gd \
|
||||
--libdir=${PREFIX}/lib
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
CFLAGS= -DJISX0208
|
||||
|
||||
pre-install:
|
||||
${MKDIR} ${PREFIX}/include/gd
|
||||
${MKDIR} ${PREFIX}/share/examples/gd
|
||||
|
||||
do-install:
|
||||
for i in libgd.a libgd.so.1; do \
|
||||
${INSTALL} -c -o bin -g bin -m 555 ${WRKSRC}/$$i \
|
||||
${PREFIX}/lib; \
|
||||
done
|
||||
( cd ${PREFIX}/lib; ${LN} -sf libgd.so.1 libgd.so )
|
||||
for i in gddemo giftogd webgif; do \
|
||||
${INSTALL} -c -o bin -g bin -m 755 ${WRKSRC}/$$i \
|
||||
${PREFIX}/bin; \
|
||||
done
|
||||
for i in gd.h gdfontt.h gdfonts.h gdfontmb.h gdfontl.h gdfontg.h; do \
|
||||
${INSTALL} -c -o root -g bin -m 644 ${WRKSRC}/$$i \
|
||||
${PREFIX}/include/gd; \
|
||||
done
|
||||
for i in index.html demoin.gif ; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/$$i \
|
||||
${PREFIX}/share/examples/gd; \
|
||||
done
|
||||
|
||||
post-install:
|
||||
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (gd1.3.tar.gz) = ff3de2c851c4b1fc6af6f14dcfbc6532
|
||||
MD5 (gd1.3.kanji.patch-fix1.gz) = 2c573152add343feb105cc490986bd15
|
||||
MD5 (gd-1.6.3.tar.gz) = 519bfbb55e3b315dd3d5a37ab56c2d84
|
||||
MD5 (gd-1.6.3.ttf-kanji.patch.990731) = 4031e7c027f3d2ba418c6620f60428e2
|
||||
|
20
japanese/gd/files/patch-ab
Normal file
20
japanese/gd/files/patch-ab
Normal file
@ -0,0 +1,20 @@
|
||||
--- Makefile.in.orig Mon Aug 30 00:23:49 1999
|
||||
+++ Makefile.in Mon Aug 30 00:24:49 1999
|
||||
@@ -88,7 +88,7 @@
|
||||
libgd_la_SOURCES = gd.c gd_io.c gd_io_file.c gd_io_dp.c gd_io_ss.c gd_png.c gd_ss.c gd_gd.c gd_gd2.c gdfontt.c gdfonts.c gdfontmb.c gdfontl.c gdfontg.c gdttf.c gdcache.c gdkanji.c gd.h gdcache.h gdfontl.h gdfonts.h gd_io.h gdfontg.h gdfontmb.h gdfontt.h jisx0208.h
|
||||
|
||||
|
||||
-libgd_la_LIBADD = @LIBS@
|
||||
+libgd_la_LIBADD = @LIBS@ -lm -L$(libdir) -lpng
|
||||
|
||||
bin_PROGRAMS = pngtogd pngtogd2 gdtopng gd2topng gd2copypal gdparttopng webpng
|
||||
|
||||
@@ -136,7 +136,7 @@
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
|
||||
|
||||
-DEFS = @DEFS@ -I. -I$(srcdir)
|
||||
+DEFS = @DEFS@ -I. -I$(srcdir) -I$(includedir)
|
||||
CPPFLAGS = @CPPFLAGS@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
LIBS = @LIBS@
|
@ -1 +1 @@
|
||||
A graphics library for fast GIF creation w/ Japanese Kanji patch
|
||||
A graphics library for fast GIF creation
|
||||
|
@ -1,7 +1,12 @@
|
||||
bin/gddemo
|
||||
bin/giftogd
|
||||
bin/webgif
|
||||
bin/pngtogd
|
||||
bin/pngtogd2
|
||||
bin/gdtopng
|
||||
bin/gd2topng
|
||||
bin/gd2copypal
|
||||
bin/gdparttopng
|
||||
bin/webpng
|
||||
include/gd/gd.h
|
||||
include/gd/gd_io.h
|
||||
include/gd/gdfontg.h
|
||||
include/gd/gdfontl.h
|
||||
include/gd/gdfontmb.h
|
||||
@ -9,10 +14,7 @@ include/gd/gdfonts.h
|
||||
include/gd/gdfontt.h
|
||||
lib/libgd.a
|
||||
lib/libgd.so
|
||||
lib/libgd.so.1.3
|
||||
share/examples/gd/demoin.gif
|
||||
share/examples/gd/index.html
|
||||
@dirrm include/gd
|
||||
@dirrm share/examples/gd
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %D/lib
|
||||
lib/libgd.so.0
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
@dirrm include/gd
|
||||
|
@ -1,55 +1,34 @@
|
||||
# New ports collection makefile for: gd
|
||||
# Version required: 1.3+kanji.patch
|
||||
# New ports collection makefile for: gd
|
||||
# Version required: 1.6.3
|
||||
# Date created: 19 Aug 1998
|
||||
# Whom: ichiro@ichiro.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= gd1.3
|
||||
PKGNAME= ja-gd-1.3
|
||||
DISTNAME= gd-1.6.3
|
||||
PKGNAME= ja-gd-1.6.3
|
||||
CATEGORIES= japanese graphics
|
||||
MASTER_SITES= http://www.boutell.com/gd/http/ \
|
||||
MASTER_SITES= http://www.boutell.com/gd/http/ \
|
||||
ftp://ftp.boutell.com/pub/boutell/gd/
|
||||
|
||||
PATCH_SITES= http://pg.cni.co.jp/GD/
|
||||
PATCHFILES= gd1.3.kanji.patch-fix1.gz
|
||||
PATCH_DIST_STRIP= # empty
|
||||
PATCH_SITES= ftp://ftp.ipc.chiba-u.ac.jp/pub/pub.yamaga/gd/1.6.3
|
||||
PATCHFILES= gd-1.6.3.ttf-kanji.patch.990731
|
||||
|
||||
MAINTAINER= ichiro@ichiro.org
|
||||
|
||||
BUILD_DEPENDS= ${PREFIX}/lib/libVFlib2.so:${PORTSDIR}/japanese/vflib
|
||||
|
||||
RESTRICTED= unavailable from master site due to legal problems
|
||||
LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png
|
||||
|
||||
FETCH_BEFORE_ARGS= -b
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
|
||||
CONFIGURE_ARGS+= --includedir=${PREFIX}/include/gd \
|
||||
--libdir=${PREFIX}/lib
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
CFLAGS= -DJISX0208
|
||||
|
||||
pre-install:
|
||||
${MKDIR} ${PREFIX}/include/gd
|
||||
${MKDIR} ${PREFIX}/share/examples/gd
|
||||
|
||||
do-install:
|
||||
for i in libgd.a libgd.so.1; do \
|
||||
${INSTALL} -c -o bin -g bin -m 555 ${WRKSRC}/$$i \
|
||||
${PREFIX}/lib; \
|
||||
done
|
||||
( cd ${PREFIX}/lib; ${LN} -sf libgd.so.1 libgd.so )
|
||||
for i in gddemo giftogd webgif; do \
|
||||
${INSTALL} -c -o bin -g bin -m 755 ${WRKSRC}/$$i \
|
||||
${PREFIX}/bin; \
|
||||
done
|
||||
for i in gd.h gdfontt.h gdfonts.h gdfontmb.h gdfontl.h gdfontg.h; do \
|
||||
${INSTALL} -c -o root -g bin -m 644 ${WRKSRC}/$$i \
|
||||
${PREFIX}/include/gd; \
|
||||
done
|
||||
for i in index.html demoin.gif ; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/$$i \
|
||||
${PREFIX}/share/examples/gd; \
|
||||
done
|
||||
|
||||
post-install:
|
||||
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (gd1.3.tar.gz) = ff3de2c851c4b1fc6af6f14dcfbc6532
|
||||
MD5 (gd1.3.kanji.patch-fix1.gz) = 2c573152add343feb105cc490986bd15
|
||||
MD5 (gd-1.6.3.tar.gz) = 519bfbb55e3b315dd3d5a37ab56c2d84
|
||||
MD5 (gd-1.6.3.ttf-kanji.patch.990731) = 4031e7c027f3d2ba418c6620f60428e2
|
||||
|
20
japanese/gd1/files/patch-ab
Normal file
20
japanese/gd1/files/patch-ab
Normal file
@ -0,0 +1,20 @@
|
||||
--- Makefile.in.orig Mon Aug 30 00:23:49 1999
|
||||
+++ Makefile.in Mon Aug 30 00:24:49 1999
|
||||
@@ -88,7 +88,7 @@
|
||||
libgd_la_SOURCES = gd.c gd_io.c gd_io_file.c gd_io_dp.c gd_io_ss.c gd_png.c gd_ss.c gd_gd.c gd_gd2.c gdfontt.c gdfonts.c gdfontmb.c gdfontl.c gdfontg.c gdttf.c gdcache.c gdkanji.c gd.h gdcache.h gdfontl.h gdfonts.h gd_io.h gdfontg.h gdfontmb.h gdfontt.h jisx0208.h
|
||||
|
||||
|
||||
-libgd_la_LIBADD = @LIBS@
|
||||
+libgd_la_LIBADD = @LIBS@ -lm -L$(libdir) -lpng
|
||||
|
||||
bin_PROGRAMS = pngtogd pngtogd2 gdtopng gd2topng gd2copypal gdparttopng webpng
|
||||
|
||||
@@ -136,7 +136,7 @@
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
|
||||
|
||||
-DEFS = @DEFS@ -I. -I$(srcdir)
|
||||
+DEFS = @DEFS@ -I. -I$(srcdir) -I$(includedir)
|
||||
CPPFLAGS = @CPPFLAGS@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
LIBS = @LIBS@
|
@ -1 +1 @@
|
||||
A graphics library for fast GIF creation w/ Japanese Kanji patch
|
||||
A graphics library for fast GIF creation
|
||||
|
@ -1,7 +1,12 @@
|
||||
bin/gddemo
|
||||
bin/giftogd
|
||||
bin/webgif
|
||||
bin/pngtogd
|
||||
bin/pngtogd2
|
||||
bin/gdtopng
|
||||
bin/gd2topng
|
||||
bin/gd2copypal
|
||||
bin/gdparttopng
|
||||
bin/webpng
|
||||
include/gd/gd.h
|
||||
include/gd/gd_io.h
|
||||
include/gd/gdfontg.h
|
||||
include/gd/gdfontl.h
|
||||
include/gd/gdfontmb.h
|
||||
@ -9,10 +14,7 @@ include/gd/gdfonts.h
|
||||
include/gd/gdfontt.h
|
||||
lib/libgd.a
|
||||
lib/libgd.so
|
||||
lib/libgd.so.1.3
|
||||
share/examples/gd/demoin.gif
|
||||
share/examples/gd/index.html
|
||||
@dirrm include/gd
|
||||
@dirrm share/examples/gd
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %D/lib
|
||||
lib/libgd.so.0
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
@dirrm include/gd
|
||||
|
Loading…
Reference in New Issue
Block a user