Fix build on powerpc
PR: 237200 Submitted by: pkubaj
This commit is contained in:
parent
6a0beb045a
commit
fce7c8290b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=499489
@ -12,7 +12,7 @@ COMMENT= Thread-safe connection pool library
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= gmake libtool localbase pathfix
|
||||
USES= compiler:c11 gmake libtool localbase pathfix
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
@ -29,7 +29,16 @@ PGSQL_CONFIGURE_WITH= postgresql=${LOCALBASE}/bin/pg_config
|
||||
PGSQL_USES= pgsql
|
||||
SQLITE_CONFIGURE_WITH= sqlite=${LOCALBASE}
|
||||
SQLITE_USES= sqlite
|
||||
SSL_CONFIGURE_ENABLE= openssl=${OPENSSLBASE}
|
||||
SSL_USES= ssl
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MSSL}
|
||||
.if ${SSL_DEFAULT} == base
|
||||
CONFIGURE_ARGS+= --enable-openssl
|
||||
.else
|
||||
CONFIGURE_ARGS+= --enable-openssl=${OPENSSLBASE}
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
7
databases/libzdb/files/patch-test-zdbpp.cpp
Normal file
7
databases/libzdb/files/patch-test-zdbpp.cpp
Normal file
@ -0,0 +1,7 @@
|
||||
--- test/zdbpp.cpp.orig 2019-04-03 23:00:49 UTC
|
||||
+++ test/zdbpp.cpp
|
||||
@@ -1,3 +1,4 @@
|
||||
+#include <cassert>
|
||||
#include <iostream>
|
||||
#include <string>
|
||||
#include <map>
|
Loading…
Reference in New Issue
Block a user