This is a keyboard for typesetting Ancient Greek with precomposed Unicode

characters. It is written in Keyman Keyboard Language by SIL Non-Roman Script
Initiative (NRSI).

The main purpose of the keyboards is to provide a wide range of keying options,
so many characters can be entered in multiple ways. The features include:

  * preserving the context when deleting;
  * choosing the correct code for the sigma depending upon the encoding and
    the context (so the correct final form is used when appropriate);
  * understanding the context of gamma so that it can be typed as 'n' before
    kappa, xi or chi and as 'ng' before another gamma.
  * support for Greek punctuation.

WWW: http://scripts.sil.org/KeymanKeyboardLinks#e9f80714

PR:		ports/138447
Submitted by:	Nikola Lecic <nikola.lecic at anthesphoria.net>
This commit is contained in:
Martin Wilke 2009-09-02 17:26:54 +00:00
parent df43c95b1e
commit fcb480eff1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=240753
9 changed files with 235 additions and 0 deletions

View File

@ -1068,6 +1068,7 @@
SUBDIR += scim-kmfl-european-latin
SUBDIR += scim-kmfl-imengine
SUBDIR += scim-kmfl-sil-ezra
SUBDIR += scim-kmfl-sil-galatia
SUBDIR += scim-kmfl-sil-ipa-unicode5
SUBDIR += scim-kmfl-sil-panafrican-latin
SUBDIR += scim-kmfl-sil-yi

View File

@ -0,0 +1,62 @@
# New ports collection makefile for: scim-kmfl-sil-galatia
# Date created: 24 August 2009
# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
#
# $FreeBSD$
#
PORTNAME= scim-kmfl-sil-galatia
PORTVERSION= 1.02
CATEGORIES= textproc
MASTER_SITES= http://scripts.sil.org/cms/scripts/render_download.php?site_id=nrsi&format=file&media_id=GrkPolyComp_Src&filename=/ \
http://anthesphoria.net/FreeBSD/ports/distfiles/${DIST_SUBDIR}/
DISTNAME= GrkPolyComp_Src
DIST_SUBDIR= kmfl
MAINTAINER= nikola.lecic@anthesphoria.net
COMMENT= SCIM KMFL IMEngine Unicode keyboard for typesetting Ancient Greek
RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp \
${LOCALBASE}/lib/scim-1.0/1.4.0/IMEngine/kmfl.so:${PORTSDIR}/textproc/scim-kmfl-imengine
WRKSRC= ${WRKDIR}/GrkPolyComp_Src
USE_DOS2UNIX= GrkPolyComp.KMN
NO_BUILD= yes
USE_ZIP= yes
DOCSDIR_REL= share/doc/kmfl/${PORTNAME}
DOCSDIR= ${PREFIX}/${DOCSDIR_REL}
SCIM_KMFL_DIR= share/scim/kmfl
SCIM_KMFL_ICONS_DIR= share/scim/kmfl/icons
PORTDOCS= *
DOCSLIST= Greek\ Poly\ Comp\ Kbrd\ Layout.pdf \
welcome.htm
PLIST_FILES= ${SCIM_KMFL_DIR}/GrkPolyComp.kmn \
${SCIM_KMFL_ICONS_DIR}/ALPHA.bmp
do-install:
${CP} -f ${WRKSRC}/GrkPolyComp.KMN ${WRKSRC}/GrkPolyComp.kmn
${INSTALL_DATA} ${WRKSRC}/GrkPolyComp.kmn ${LOCALBASE}/${SCIM_KMFL_DIR}
${INSTALL_DATA} ${WRKSRC}/ALPHA.bmp ${LOCALBASE}/${SCIM_KMFL_ICONS_DIR}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
for doc in ${DOCSLIST} ; do \
${INSTALL_DATA} "${WRKSRC}/$$doc" ${DOCSDIR} ; \
done
.endif
post-install:
@${ECHO_MSG} "--------------------------------------------------------"
@${ECHO_MSG} " You should now have the new keyboard in the section"
@${ECHO_MSG} " \"Others\" in your SCIM menu. If you don't see it,"
@${ECHO_MSG} " restart X."
.if !defined(NOPORTDOCS)
@${ECHO_MSG}
@${ECHO_MSG} " The documentation is installed into:"
@${ECHO_MSG} " ${DOCSDIR}"
.endif
@${ECHO_MSG} "--------------------------------------------------------"
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (kmfl/GrkPolyComp_Src.zip) = 5e7bf6186a3917d796f1abb710bed539
SHA256 (kmfl/GrkPolyComp_Src.zip) = 59b4ad7f7a31f66a674f1867979baf07ae5143957cec6575e3d1428f5acf66e7
SIZE (kmfl/GrkPolyComp_Src.zip) = 197829

View File

@ -0,0 +1,37 @@
--- GrkPolyComp.KMN.orig 2009-08-24 13:49:16.000000000 +0200
+++ GrkPolyComp.KMN 2009-08-24 14:03:17.000000000 +0200
@@ -24,9 +24,9 @@
c See REVISION.TXT
c ----------------------------------------------------------------------------
-NAME "Greek (polytonic precomposed) Unicode 1.02"
+NAME "Galatia Greek (polytonic precomposed) Unicode 1.02"
VERSION 6.0
-BITMAP ALPHA
+BITMAP ALPHA.bmp
HOTKEY "^+G"
COPYRIGHT "© 2002-2008 SIL International"
MESSAGE "The Greek (polytonic precomposed) Unicode keyboard is distributed under the X11 free software license (http://scripts.sil.org/X11License)."
@@ -520,9 +520,9 @@
any(vUIoSm0) + any(K_Io) > index(vUIoSm,1) c >A_
any(vUIo2) + any(K_Ro) > index(vUIoRo,1) c A_<
any(vUIoRo0) + any(K_Io) > index(vUIoRo,1) c <A_
-any(vUIoSm) + any(K_Gr) > index(vUIoSmGr,1) c A_>\
+any(vUIoSm) + any(K_Gr) > index(vUIoSmGr,1) c A_>\ c
any(vUIoSmGr0) + any(K_Io) > index(vUIoSmGr,1) c >\A_
-any(vUIoRo) + any(K_Gr) > index(vUIoRoGr,1) c A_<\
+any(vUIoRo) + any(K_Gr) > index(vUIoRoGr,1) c A_<\ c
any(vUIoRoGr0) + any(K_Io) > index(vUIoRoGr,1) c <\A_
any(vUIoSm) + any(K_Ac) > index(vUIoSmAc,1) c A_>/
any(vUIoSmAc0) + any(K_Io) > index(vUIoSmAc,1) c >/A_
@@ -668,8 +668,8 @@
any(GC_Ci) + any(K_Gr) > index(GC_Gr,1) c a^ + \ a\.
any(Ac) + any(K_Gr) > outs(Gr) c / + \ \.
any(Ci) + any(K_Gr) > outs(Gr) c ^ + \ \.
-any(lowvRo) + any(K_Gr) > index(lowvRoGr,1) c >a + \ a>\
-any(lowvSm) + any(K_Gr) > index(lowvSmGr,1) c <a + \ a<\
+any(lowvRo) + any(K_Gr) > index(lowvRoGr,1) c >a + \ a>\ c
+any(lowvSm) + any(K_Gr) > index(lowvSmGr,1) c <a + \ a<\ c
any(upV) + any(K_Gr) > index(upVGr,1) c A + \ >A
any(upVSm_Sm) + any(K_Gr) > index(upVSmGr,1) c >A + \ >\A
any(upVSm_Gr) + any(K_Sm) > index(upVSmGr,1) c >A + \ >\A

View File

@ -0,0 +1,15 @@
This is a keyboard for typesetting Ancient Greek with precomposed Unicode
characters. It is written in Keyman Keyboard Language by SIL Non-Roman Script
Initiative (NRSI).
The main purpose of the keyboards is to provide a wide range of keying options,
so many characters can be entered in multiple ways. The features include:
* preserving the context when deleting;
* choosing the correct code for the sigma depending upon the encoding and
the context (so the correct final form is used when appropriate);
* understanding the context of gamma so that it can be typed as 'n' before
kappa, xi or chi and as 'ng' before another gamma.
* support for Greek punctuation.
WWW: http://scripts.sil.org/KeymanKeyboardLinks#e9f80714

View File

@ -0,0 +1,62 @@
# New ports collection makefile for: scim-kmfl-sil-galatia
# Date created: 24 August 2009
# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
#
# $FreeBSD$
#
PORTNAME= scim-kmfl-sil-galatia
PORTVERSION= 1.02
CATEGORIES= textproc
MASTER_SITES= http://scripts.sil.org/cms/scripts/render_download.php?site_id=nrsi&format=file&media_id=GrkPolyComp_Src&filename=/ \
http://anthesphoria.net/FreeBSD/ports/distfiles/${DIST_SUBDIR}/
DISTNAME= GrkPolyComp_Src
DIST_SUBDIR= kmfl
MAINTAINER= nikola.lecic@anthesphoria.net
COMMENT= SCIM KMFL IMEngine Unicode keyboard for typesetting Ancient Greek
RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp \
${LOCALBASE}/lib/scim-1.0/1.4.0/IMEngine/kmfl.so:${PORTSDIR}/textproc/scim-kmfl-imengine
WRKSRC= ${WRKDIR}/GrkPolyComp_Src
USE_DOS2UNIX= GrkPolyComp.KMN
NO_BUILD= yes
USE_ZIP= yes
DOCSDIR_REL= share/doc/kmfl/${PORTNAME}
DOCSDIR= ${PREFIX}/${DOCSDIR_REL}
SCIM_KMFL_DIR= share/scim/kmfl
SCIM_KMFL_ICONS_DIR= share/scim/kmfl/icons
PORTDOCS= *
DOCSLIST= Greek\ Poly\ Comp\ Kbrd\ Layout.pdf \
welcome.htm
PLIST_FILES= ${SCIM_KMFL_DIR}/GrkPolyComp.kmn \
${SCIM_KMFL_ICONS_DIR}/ALPHA.bmp
do-install:
${CP} -f ${WRKSRC}/GrkPolyComp.KMN ${WRKSRC}/GrkPolyComp.kmn
${INSTALL_DATA} ${WRKSRC}/GrkPolyComp.kmn ${LOCALBASE}/${SCIM_KMFL_DIR}
${INSTALL_DATA} ${WRKSRC}/ALPHA.bmp ${LOCALBASE}/${SCIM_KMFL_ICONS_DIR}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
for doc in ${DOCSLIST} ; do \
${INSTALL_DATA} "${WRKSRC}/$$doc" ${DOCSDIR} ; \
done
.endif
post-install:
@${ECHO_MSG} "--------------------------------------------------------"
@${ECHO_MSG} " You should now have the new keyboard in the section"
@${ECHO_MSG} " \"Others\" in your SCIM menu. If you don't see it,"
@${ECHO_MSG} " restart X."
.if !defined(NOPORTDOCS)
@${ECHO_MSG}
@${ECHO_MSG} " The documentation is installed into:"
@${ECHO_MSG} " ${DOCSDIR}"
.endif
@${ECHO_MSG} "--------------------------------------------------------"
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (kmfl/GrkPolyComp_Src.zip) = 5e7bf6186a3917d796f1abb710bed539
SHA256 (kmfl/GrkPolyComp_Src.zip) = 59b4ad7f7a31f66a674f1867979baf07ae5143957cec6575e3d1428f5acf66e7
SIZE (kmfl/GrkPolyComp_Src.zip) = 197829

View File

@ -0,0 +1,37 @@
--- GrkPolyComp.KMN.orig 2009-08-24 13:49:16.000000000 +0200
+++ GrkPolyComp.KMN 2009-08-24 14:03:17.000000000 +0200
@@ -24,9 +24,9 @@
c See REVISION.TXT
c ----------------------------------------------------------------------------
-NAME "Greek (polytonic precomposed) Unicode 1.02"
+NAME "Galatia Greek (polytonic precomposed) Unicode 1.02"
VERSION 6.0
-BITMAP ALPHA
+BITMAP ALPHA.bmp
HOTKEY "^+G"
COPYRIGHT "© 2002-2008 SIL International"
MESSAGE "The Greek (polytonic precomposed) Unicode keyboard is distributed under the X11 free software license (http://scripts.sil.org/X11License)."
@@ -520,9 +520,9 @@
any(vUIoSm0) + any(K_Io) > index(vUIoSm,1) c >A_
any(vUIo2) + any(K_Ro) > index(vUIoRo,1) c A_<
any(vUIoRo0) + any(K_Io) > index(vUIoRo,1) c <A_
-any(vUIoSm) + any(K_Gr) > index(vUIoSmGr,1) c A_>\
+any(vUIoSm) + any(K_Gr) > index(vUIoSmGr,1) c A_>\ c
any(vUIoSmGr0) + any(K_Io) > index(vUIoSmGr,1) c >\A_
-any(vUIoRo) + any(K_Gr) > index(vUIoRoGr,1) c A_<\
+any(vUIoRo) + any(K_Gr) > index(vUIoRoGr,1) c A_<\ c
any(vUIoRoGr0) + any(K_Io) > index(vUIoRoGr,1) c <\A_
any(vUIoSm) + any(K_Ac) > index(vUIoSmAc,1) c A_>/
any(vUIoSmAc0) + any(K_Io) > index(vUIoSmAc,1) c >/A_
@@ -668,8 +668,8 @@
any(GC_Ci) + any(K_Gr) > index(GC_Gr,1) c a^ + \ a\.
any(Ac) + any(K_Gr) > outs(Gr) c / + \ \.
any(Ci) + any(K_Gr) > outs(Gr) c ^ + \ \.
-any(lowvRo) + any(K_Gr) > index(lowvRoGr,1) c >a + \ a>\
-any(lowvSm) + any(K_Gr) > index(lowvSmGr,1) c <a + \ a<\
+any(lowvRo) + any(K_Gr) > index(lowvRoGr,1) c >a + \ a>\ c
+any(lowvSm) + any(K_Gr) > index(lowvSmGr,1) c <a + \ a<\ c
any(upV) + any(K_Gr) > index(upVGr,1) c A + \ >A
any(upVSm_Sm) + any(K_Gr) > index(upVSmGr,1) c >A + \ >\A
any(upVSm_Gr) + any(K_Sm) > index(upVSmGr,1) c >A + \ >\A

View File

@ -0,0 +1,15 @@
This is a keyboard for typesetting Ancient Greek with precomposed Unicode
characters. It is written in Keyman Keyboard Language by SIL Non-Roman Script
Initiative (NRSI).
The main purpose of the keyboards is to provide a wide range of keying options,
so many characters can be entered in multiple ways. The features include:
* preserving the context when deleting;
* choosing the correct code for the sigma depending upon the encoding and
the context (so the correct final form is used when appropriate);
* understanding the context of gamma so that it can be typed as 'n' before
kappa, xi or chi and as 'ng' before another gamma.
* support for Greek punctuation.
WWW: http://scripts.sil.org/KeymanKeyboardLinks#e9f80714