Add new cfengine37 port.

This commit is contained in:
Cy Schubert 2015-07-27 06:39:28 +00:00
parent 56c9e78d95
commit fc86aa5704
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=392964
11 changed files with 634 additions and 1 deletions

View File

@ -124,6 +124,7 @@
SUBDIR += cfengine34
SUBDIR += cfengine35
SUBDIR += cfengine36
SUBDIR += cfengine37
SUBDIR += chgrep
SUBDIR += cinnamon-control-center
SUBDIR += cinnamon-settings-daemon

View File

@ -1,6 +1,6 @@
# $FreeBSD$
VERSIONS= 22 32 33 34 35 36
VERSIONS= 22 32 33 34 35 36 37
CFENGINE_VERSION?= 36
MASTERDIR= ${.CURDIR}/../cfengine${CFENGINE_VERSION}

View File

@ -0,0 +1,67 @@
# Created by: jrhett@netconsonance.com
# $FreeBSD$
PORTNAME= cfengine
PORTVERSION= 3.7.0
CATEGORIES= sysutils
MASTER_SITES= https://s3.amazonaws.com/cfengine-package-repos/tarballs/
DISTNAME= cfengine-3.7.0-2
WRKSRC= ${WRKDIR}/cfengine-3.7.0
MAINTAINER= cy@FreeBSD.org
# gjb@FreeBSD.org is also committer for this port
COMMENT= Systems administration tool for networks
LICENSE= GPLv3
CPE_VENDOR= gnu
.if !defined(MASTERDIR)
PKGNAMESUFFIX= 37
LATEST_LINK= cfengine37
.endif
FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
CONFLICTS= cfengine-[234]*
USE_RC_SUBR= cf-execd cf-serverd cf-monitord
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USES= autoreconf cpe gmake libtool
CFLAGS+= -Wno-return-type
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
# EXAMPLESDIR= ${PREFIX}/share/examples/cfengine3
DOCSDIR= ${PREFIX}/share/doc/cfengine
CONFIGURE_ARGS= --docdir=${DOCSDIR} \
--htmldir=${DOCSDIR}/html \
--libexecdir=${PREFIX}/libexec \
--libdir=${PREFIX}/libexec \
--mandir=${PREFIX}/man \
--with-workdir=/var/cfengine \
--with-pcre=${LOCALBASE} \
--with-lmdb=${LOCALBASE} \
--enable-fhs
INSTALL_TARGET= install-strip
LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre \
liblmdb.so:${PORTSDIR}/databases/lmdb
OPTIONS_DEFINE= PGSQL MYSQL LIBVIRT
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-postgresql=${LOCALBASE}
MYSQL_USE= MYSQL=yes
MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}
MYSQL_LIB_DEPENDS= libmysqlclient.so:${PORTSDIR}/${_MYSQL_CLIENT}
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
LIBVIRT_CONFIGURE_ON= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS+= libvirt.so:${PORTSDIR}/devel/libvirt
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
SHA256 (cfengine-3.7.0-2.tar.gz) = 53e3fcae50b14d29a7a86920e13586cafed4eb5e2d081597dc9a7e34393c7f77
SIZE (cfengine-3.7.0-2.tar.gz) = 2087953

View File

@ -0,0 +1,28 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: cf-execd
# REQUIRE: LOGIN
# KEYWORD: shutdown
#
# Add the following line to /etc/rc.conf[.local] to enable cf-execd(8)
#
# cf_execd_enable (bool): Set to "NO" by default.
# Set it to "YES" to enable cf-execd.
# cf_execd_flags (str): Custom additional arguments to be passed
# to cf-execd (default empty).
#
. /etc/rc.subr
name="cf_execd"
rcvar=cf_execd_enable
command="%%PREFIX%%/sbin/cf-execd"
load_rc_config $name
: ${cf_execd_enable="NO"}
run_rc_command "$1"

View File

@ -0,0 +1,28 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: cf-monitord
# REQUIRE: LOGIN
# KEYWORD: shutdown
#
# Add the following line to /etc/rc.conf[.local] to enable cf-monitord(8)
#
# cf_monitord_enable (bool): Set to "NO" by default.
# Set it to "YES" to enable cf-monitord.
# cf_monitord_flags (str): Custom additional arguments to be passed
# to cf-monitord (default empty).
#
. /etc/rc.subr
name="cf_monitord"
rcvar=cf_monitord_enable
command="%%PREFIX%%/sbin/cf-monitord"
load_rc_config $name
: ${cf_monitord_enable="NO"}
run_rc_command "$1"

View File

@ -0,0 +1,28 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: cf-serverd
# REQUIRE: LOGIN
# KEYWORD: shutdown
#
# Add the following line to /etc/rc.conf[.local] to enable cf-serverd(8)
#
# cf_serverd_enable (bool): Set to "NO" by default.
# Set it to "YES" to enable cf-serverd.
# cf_serverd_flags (str): Custom additional arguments to be passed
# to cf-serverd (default empty).
#
. /etc/rc.subr
name="cf_serverd"
rcvar=cf_serverd_enable
command="%%PREFIX%%/sbin/cf-serverd"
load_rc_config $name
: ${cf_serverd_enable="NO"}
run_rc_command "$1"

View File

@ -0,0 +1,54 @@
--- /dev/null 2014-07-29 08:00:54.000000000 -0700
+++ m4/strndup.m4 2014-07-29 08:01:42.499328796 -0700
@@ -0,0 +1,51 @@
+# strndup.m4 serial 21
+dnl Copyright (C) 2002-2003, 2005-2013 Free Software Foundation, Inc.
+dnl This file is free software; the Free Software Foundation
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+
+AC_DEFUN([cf3_FUNC_STRNDUP],
+[
+ AC_REQUIRE([AC_CANONICAL_HOST]) dnl for cross-compiles
+ AC_CHECK_DECLS([strndup])
+ AC_REPLACE_FUNCS([strndup])
+ if test $ac_cv_have_decl_strndup = no; then
+ HAVE_DECL_STRNDUP=0
+ fi
+
+ if test $ac_cv_func_strndup = yes; then
+ HAVE_STRNDUP=1
+ # AIX 5.3 has a function that tries to copy the entire range specified
+ # by n, instead of just the length of src.
+ AC_CACHE_CHECK([for working strndup], [cf3_cv_func_strndup_works],
+ [AC_RUN_IFELSE([
+ AC_LANG_PROGRAM([[#include <string.h>
+ #include <stdlib.h>]], [[
+#if !HAVE_DECL_STRNDUP
+ extern
+ #ifdef __cplusplus
+ "C"
+ #endif
+ char *strndup (const char *, size_t);
+#endif
+ char *s;
+ // Will crash if strndup tries to traverse all 2GB.
+ s = strndup ("string", 2000000000);
+ return 0;]])],
+ [cf3_cv_func_strndup_works=yes],
+ [cf3_cv_func_strndup_works=no],
+ [
+changequote(,)dnl
+ case $host_os in
+ aix | aix[3-6]*) cf3_cv_func_strndup_works="guessing no";;
+ *) cf3_cv_func_strndup_works="guessing yes";;
+ esac
+changequote([,])dnl
+ ])])
+ case $cf3_cv_func_strndup_works in
+ *no) AC_LIBOBJ([strndup]) ;;
+ esac
+ else
+ HAVE_STRNDUP=0
+ fi
+])

View File

@ -0,0 +1,56 @@
Index: m4/strndup.m4
===================================================================
--- /dev/null 2014-07-29 08:00:54.000000000 -0700
+++ m4/strndup.m4 2014-07-29 08:01:42.499328796 -0700
@@ -0,0 +1,51 @@
+# strndup.m4 serial 21
+dnl Copyright (C) 2002-2003, 2005-2013 Free Software Foundation, Inc.
+dnl This file is free software; the Free Software Foundation
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+
+AC_DEFUN([cf3_FUNC_STRNDUP],
+[
+ AC_REQUIRE([AC_CANONICAL_HOST]) dnl for cross-compiles
+ AC_CHECK_DECLS([strndup])
+ AC_REPLACE_FUNCS([strndup])
+ if test $ac_cv_have_decl_strndup = no; then
+ HAVE_DECL_STRNDUP=0
+ fi
+
+ if test $ac_cv_func_strndup = yes; then
+ HAVE_STRNDUP=1
+ # AIX 5.3 has a function that tries to copy the entire range specified
+ # by n, instead of just the length of src.
+ AC_CACHE_CHECK([for working strndup], [cf3_cv_func_strndup_works],
+ [AC_RUN_IFELSE([
+ AC_LANG_PROGRAM([[#include <string.h>
+ #include <stdlib.h>]], [[
+#if !HAVE_DECL_STRNDUP
+ extern
+ #ifdef __cplusplus
+ "C"
+ #endif
+ char *strndup (const char *, size_t);
+#endif
+ char *s;
+ // Will crash if strndup tries to traverse all 2GB.
+ s = strndup ("string", 2000000000);
+ return 0;]])],
+ [cf3_cv_func_strndup_works=yes],
+ [cf3_cv_func_strndup_works=no],
+ [
+changequote(,)dnl
+ case $host_os in
+ aix | aix[3-6]*) cf3_cv_func_strndup_works="guessing no";;
+ *) cf3_cv_func_strndup_works="guessing yes";;
+ esac
+changequote([,])dnl
+ ])])
+ case $cf3_cv_func_strndup_works in
+ *no) AC_LIBOBJ([strndup]) ;;
+ esac
+ else
+ HAVE_STRNDUP=0
+ fi
+])

View File

@ -0,0 +1,10 @@
Cfengine is an automated suite of programs for configuring and
maintaining Unix-like computers. It has been used on computing arrays
of between 1 and 20,000 computers since 1993 by a wide range of
organizations. Cfengine is supported by active research and was the
first autonomic, hands-free management system for Unix-like operating
systems. Cfengine is an autonomic maintenance system not merely a
change management roll-out tool. Cfengine has a history of security
and adaptability.
WWW: http://www.cfengine.org/

View File

@ -0,0 +1,359 @@
libexec/cfengine/libpromises.so
libexec/cfengine/libpromises.so.3
libexec/cfengine/libpromises.so.3.0.6
sbin/cf-agent
sbin/cf-execd
sbin/cf-key
sbin/cf-monitord
sbin/cf-promises
sbin/cf-runagent
sbin/cf-serverd
sbin/cf-upgrade
sbin/rpmvercmp
%%DOCSDIR%%/ChangeLog
%%DOCSDIR%%/README.md
%%DOCSDIR%%/examples/abort.cf
%%DOCSDIR%%/examples/accessed_before.cf
%%DOCSDIR%%/examples/accessedbefore.cf
%%DOCSDIR%%/examples/accumulated_time.cf
%%DOCSDIR%%/examples/acl.cf
%%DOCSDIR%%/examples/acl_generic.cf
%%DOCSDIR%%/examples/acl_ntfs.cf
%%DOCSDIR%%/examples/acl_secret.cf
%%DOCSDIR%%/examples/active_directory.cf
%%DOCSDIR%%/examples/activedirectory_listusers.cf
%%DOCSDIR%%/examples/activedirectory_showuser.cf
%%DOCSDIR%%/examples/ago.cf
%%DOCSDIR%%/examples/app_baseline.cf
%%DOCSDIR%%/examples/appgroups.cf
%%DOCSDIR%%/examples/arrays.cf
%%DOCSDIR%%/examples/backreferences_files.cf
%%DOCSDIR%%/examples/badpromise.cf
%%DOCSDIR%%/examples/badtype.cf
%%DOCSDIR%%/examples/bsdflags.cf
%%DOCSDIR%%/examples/bundle_return_values.cf
%%DOCSDIR%%/examples/bundlesmatching.cf
%%DOCSDIR%%/examples/bundlestate.cf
%%DOCSDIR%%/examples/canonify.cf
%%DOCSDIR%%/examples/cf2_integration.cf
%%DOCSDIR%%/examples/change_detect.cf
%%DOCSDIR%%/examples/changedbefore.cf
%%DOCSDIR%%/examples/chdir.cf
%%DOCSDIR%%/examples/classes_global.cf
%%DOCSDIR%%/examples/classesmatching.cf
%%DOCSDIR%%/examples/classmatch.cf
%%DOCSDIR%%/examples/classvar_convergence.cf
%%DOCSDIR%%/examples/commands.cf
%%DOCSDIR%%/examples/compare.cf
%%DOCSDIR%%/examples/container_iteration.cf
%%DOCSDIR%%/examples/container_key_iteration.cf
%%DOCSDIR%%/examples/control_expand.cf
%%DOCSDIR%%/examples/controlclasses.cf
%%DOCSDIR%%/examples/copy.cf
%%DOCSDIR%%/examples/copy_classes.cf
%%DOCSDIR%%/examples/copy_copbl.cf
%%DOCSDIR%%/examples/copy_edit.cf
%%DOCSDIR%%/examples/copydir_copbl.cf
%%DOCSDIR%%/examples/copylinks.cf
%%DOCSDIR%%/examples/countclassesmatching.cf
%%DOCSDIR%%/examples/countlinesmatching.cf
%%DOCSDIR%%/examples/create_filedir.cf
%%DOCSDIR%%/examples/createdb.cf
%%DOCSDIR%%/examples/customize_by_named_list.cf
%%DOCSDIR%%/examples/data_readstringarray.cf
%%DOCSDIR%%/examples/datastate.cf
%%DOCSDIR%%/examples/defaults.cf
%%DOCSDIR%%/examples/defaults2.cf
%%DOCSDIR%%/examples/defaults3.cf
%%DOCSDIR%%/examples/definitions.cf
%%DOCSDIR%%/examples/deletelines.cf
%%DOCSDIR%%/examples/depends_on.cf
%%DOCSDIR%%/examples/depends_on2.cf
%%DOCSDIR%%/examples/data_expand.cf
%%DOCSDIR%%/examples/data_regextract.cf
%%DOCSDIR%%/examples/difference.cf
%%DOCSDIR%%/examples/dirname.cf
%%DOCSDIR%%/examples/disable.cf
%%DOCSDIR%%/examples/disable_and_rotate_files.cf
%%DOCSDIR%%/examples/diskfree.cf
%%DOCSDIR%%/examples/dollar.cf
%%DOCSDIR%%/examples/edit_column_files.cf
%%DOCSDIR%%/examples/edit_comment_lines.cf
%%DOCSDIR%%/examples/edit_deletenotmatch.cf
%%DOCSDIR%%/examples/edit_insert_fuzzylines.cf
%%DOCSDIR%%/examples/edit_insert_lines.cf
%%DOCSDIR%%/examples/edit_insert_lines_silly.cf
%%DOCSDIR%%/examples/edit_passwd_file.cf
%%DOCSDIR%%/examples/edit_passwd_file_basic.cf
%%DOCSDIR%%/examples/edit_replace_string.cf
%%DOCSDIR%%/examples/edit_sectioned_file.cf
%%DOCSDIR%%/examples/edit_setvar.cf
%%DOCSDIR%%/examples/edit_template.cf
%%DOCSDIR%%/examples/edit_triggerclass.cf
%%DOCSDIR%%/examples/edit_xml.cf
%%DOCSDIR%%/examples/ensure_line_present_prepend_append.cf
%%DOCSDIR%%/examples/env.cf
%%DOCSDIR%%/examples/epimenides.cf
%%DOCSDIR%%/examples/escape.cf
%%DOCSDIR%%/examples/eval.cf
%%DOCSDIR%%/examples/every.cf
%%DOCSDIR%%/examples/exec_args.cf
%%DOCSDIR%%/examples/exec_in_sequence.cf
%%DOCSDIR%%/examples/execd.cf
%%DOCSDIR%%/examples/execresult.cf
%%DOCSDIR%%/examples/expand.cf
%%DOCSDIR%%/examples/failedcommand.cf
%%DOCSDIR%%/examples/failsafe.cf
%%DOCSDIR%%/examples/file_change_detection.cf
%%DOCSDIR%%/examples/file_hash.cf
%%DOCSDIR%%/examples/file_owner_list_template.cf
%%DOCSDIR%%/examples/fileexists.cf
%%DOCSDIR%%/examples/filenames.cf
%%DOCSDIR%%/examples/fileperms.cf
%%DOCSDIR%%/examples/filesexist.cf
%%DOCSDIR%%/examples/filesexist2.cf
%%DOCSDIR%%/examples/filesize.cf
%%DOCSDIR%%/examples/filestat.cf
%%DOCSDIR%%/examples/filter.cf
%%DOCSDIR%%/examples/findfiles.cf
%%DOCSDIR%%/examples/fix_names.cf
%%DOCSDIR%%/examples/format.cf
%%DOCSDIR%%/examples/getclassmetatags.cf
%%DOCSDIR%%/examples/getenv.cf
%%DOCSDIR%%/examples/getfields.cf
%%DOCSDIR%%/examples/getgid.cf
%%DOCSDIR%%/examples/getindices.cf
%%DOCSDIR%%/examples/getindices_and_values.cf
%%DOCSDIR%%/examples/getmacaddress.cf
%%DOCSDIR%%/examples/getregistry.cf
%%DOCSDIR%%/examples/getuid.cf
%%DOCSDIR%%/examples/getusers.cf
%%DOCSDIR%%/examples/getvalues.cf
%%DOCSDIR%%/examples/getvariablemetatags.cf
%%DOCSDIR%%/examples/global_list_expansion.cf
%%DOCSDIR%%/examples/global_list_expansion_2.cf
%%DOCSDIR%%/examples/grep.cf
%%DOCSDIR%%/examples/groupexists.cf
%%DOCSDIR%%/examples/guest_environment_kvm.cf
%%DOCSDIR%%/examples/hash.cf
%%DOCSDIR%%/examples/hashcomment.cf
%%DOCSDIR%%/examples/hashmatch.cf
%%DOCSDIR%%/examples/hashuncomment.cf
%%DOCSDIR%%/examples/helloworld.cf
%%DOCSDIR%%/examples/host2ip.cf
%%DOCSDIR%%/examples/hostrange.cf
%%DOCSDIR%%/examples/hostsseen.cf
%%DOCSDIR%%/examples/hostswithclass.cf
%%DOCSDIR%%/examples/hub.cf
%%DOCSDIR%%/examples/id.cf
%%DOCSDIR%%/examples/inherit.cf
%%DOCSDIR%%/examples/insert_users.cf
%%DOCSDIR%%/examples/intarray.cf
%%DOCSDIR%%/examples/intersection.cf
%%DOCSDIR%%/examples/inventory_cpu.cf
%%DOCSDIR%%/examples/ip2host.cf
%%DOCSDIR%%/examples/iprange.cf
%%DOCSDIR%%/examples/irange.cf
%%DOCSDIR%%/examples/isdir.cf
%%DOCSDIR%%/examples/isexecutable.cf
%%DOCSDIR%%/examples/isgreaterthan.cf
%%DOCSDIR%%/examples/islessthan.cf
%%DOCSDIR%%/examples/islink.cf
%%DOCSDIR%%/examples/isnewerthan.cf
%%DOCSDIR%%/examples/isplain.cf
%%DOCSDIR%%/examples/isvariable.cf
%%DOCSDIR%%/examples/iteration.cf
%%DOCSDIR%%/examples/join.cf
%%DOCSDIR%%/examples/knowledge_driver.cf
%%DOCSDIR%%/examples/knowledge_txt.cf
%%DOCSDIR%%/examples/lastnode.cf
%%DOCSDIR%%/examples/ldap.cf
%%DOCSDIR%%/examples/length.cf
%%DOCSDIR%%/examples/linking.cf
%%DOCSDIR%%/examples/literal_server.cf
%%DOCSDIR%%/examples/locate_files_and_compress.cf
%%DOCSDIR%%/examples/log_private.cf
%%DOCSDIR%%/examples/loops.cf
%%DOCSDIR%%/examples/lsdir.cf
%%DOCSDIR%%/examples/maparray.cf
%%DOCSDIR%%/examples/mapdata.cf
%%DOCSDIR%%/examples/maplist.cf
%%DOCSDIR%%/examples/max-min-mean-variance.cf
%%DOCSDIR%%/examples/measure_log.cf
%%DOCSDIR%%/examples/measurements.cf
%%DOCSDIR%%/examples/menu.cf
%%DOCSDIR%%/examples/mergedata.cf
%%DOCSDIR%%/examples/meta.cf
%%DOCSDIR%%/examples/method.cf
%%DOCSDIR%%/examples/method_polymorph.cf
%%DOCSDIR%%/examples/method_validate.cf
%%DOCSDIR%%/examples/method_var.cf
%%DOCSDIR%%/examples/method_var2.cf
%%DOCSDIR%%/examples/module_exec.cf
%%DOCSDIR%%/examples/module_exec_2.cf
%%DOCSDIR%%/examples/monitord.cf
%%DOCSDIR%%/examples/motd.cf
%%DOCSDIR%%/examples/mount_fs.cf
%%DOCSDIR%%/examples/multipassvars.cf
%%DOCSDIR%%/examples/namespace.cf
%%DOCSDIR%%/examples/namespace1.cf
%%DOCSDIR%%/examples/namespace2.cf
%%DOCSDIR%%/examples/namespace3.cf
%%DOCSDIR%%/examples/namespace_class1.cf
%%DOCSDIR%%/examples/namespace_classes.cf
%%DOCSDIR%%/examples/namespace_var_meta.cf
%%DOCSDIR%%/examples/namespace_var_meta2.cf
%%DOCSDIR%%/examples/neighbourhood_watch.cf
%%DOCSDIR%%/examples/none.cf
%%DOCSDIR%%/examples/nth.cf
%%DOCSDIR%%/examples/null_config.cf
%%DOCSDIR%%/examples/occurrences.cf
%%DOCSDIR%%/examples/orchestrate_chain1.cf
%%DOCSDIR%%/examples/orchestrate_chain2.cf
%%DOCSDIR%%/examples/orchestrate_delay_trigger.cf
%%DOCSDIR%%/examples/orchestrate_dominoes1.cf
%%DOCSDIR%%/examples/orchestrate_dominoes2.cf
%%DOCSDIR%%/examples/orchestrate_dragon.cf
%%DOCSDIR%%/examples/orchestrate_dragon_load_balancer.cf
%%DOCSDIR%%/examples/orchestrate_n_of_m.cf
%%DOCSDIR%%/examples/orchestration_hostlist.cf
%%DOCSDIR%%/examples/ordering.cf
%%DOCSDIR%%/examples/package_apt.cf
%%DOCSDIR%%/examples/package_bundles.cf
%%DOCSDIR%%/examples/package_freebsd.cf
%%DOCSDIR%%/examples/package_latest.cf
%%DOCSDIR%%/examples/package_msi_file.cf
%%DOCSDIR%%/examples/package_msi_version.cf
%%DOCSDIR%%/examples/package_rpm.cf
%%DOCSDIR%%/examples/package_solaris.cf
%%DOCSDIR%%/examples/package_windows_feature.cf
%%DOCSDIR%%/examples/package_yum.cf
%%DOCSDIR%%/examples/package_zypper.cf
%%DOCSDIR%%/examples/packagesmatching.cf
%%DOCSDIR%%/examples/parallel_exec.cf
%%DOCSDIR%%/examples/parseintrealstringarray.cf
%%DOCSDIR%%/examples/parsestringarray.cf
%%DOCSDIR%%/examples/parsestringarrayidx.cf
%%DOCSDIR%%/examples/pathtype.cf
%%DOCSDIR%%/examples/pattern_and_edit.cf
%%DOCSDIR%%/examples/peerleader.cf
%%DOCSDIR%%/examples/peerleaders.cf
%%DOCSDIR%%/examples/peers.cf
%%DOCSDIR%%/examples/postfix.cf
%%DOCSDIR%%/examples/process_kill.cf
%%DOCSDIR%%/examples/process_matching.cf
%%DOCSDIR%%/examples/process_matching2.cf
%%DOCSDIR%%/examples/process_matching3.cf
%%DOCSDIR%%/examples/process_restart.cf
%%DOCSDIR%%/examples/process_restart_basic.cf
%%DOCSDIR%%/examples/process_signalling.cf
%%DOCSDIR%%/examples/product.cf
%%DOCSDIR%%/examples/promise_knowledge.cf
%%DOCSDIR%%/examples/promises.cf
%%DOCSDIR%%/examples/readcsv.cf
%%DOCSDIR%%/examples/readdata.cf
%%DOCSDIR%%/examples/randomint.cf
%%DOCSDIR%%/examples/readfile.cf
%%DOCSDIR%%/examples/readintrealstringlist.cf
%%DOCSDIR%%/examples/readlist.cf
%%DOCSDIR%%/examples/readtcp.cf
%%DOCSDIR%%/examples/reg_multiline.cf
%%DOCSDIR%%/examples/regarray.cf
%%DOCSDIR%%/examples/regcmp.cf
%%DOCSDIR%%/examples/regex_win.cf
%%DOCSDIR%%/examples/regextract.cf
%%DOCSDIR%%/examples/registry.cf
%%DOCSDIR%%/examples/registry_cache.cf
%%DOCSDIR%%/examples/registryvalue.cf
%%DOCSDIR%%/examples/regline.cf
%%DOCSDIR%%/examples/reglist.cf
%%DOCSDIR%%/examples/remake_outputs.pl
%%DOCSDIR%%/examples/remoteclasses.cf
%%DOCSDIR%%/examples/remoteclasses2.cf
%%DOCSDIR%%/examples/remotescalar.cf
%%DOCSDIR%%/examples/remove_deadlinks.cf
%%DOCSDIR%%/examples/rename.cf
%%DOCSDIR%%/examples/repairedcommand.cf
%%DOCSDIR%%/examples/report_custom.cf
%%DOCSDIR%%/examples/report_diffs.cf
%%DOCSDIR%%/examples/report_state.cf
%%DOCSDIR%%/examples/reporting.cf
%%DOCSDIR%%/examples/reporttofile.cf
%%DOCSDIR%%/examples/resolveconf.cf
%%DOCSDIR%%/examples/returnszero.cf
%%DOCSDIR%%/examples/reverse.cf
%%DOCSDIR%%/examples/root_passwd.cf
%%DOCSDIR%%/examples/select_class.cf
%%DOCSDIR%%/examples/select_mode.cf
%%DOCSDIR%%/examples/select_region.cf
%%DOCSDIR%%/examples/select_size.cf
%%DOCSDIR%%/examples/selectservers.cf
%%DOCSDIR%%/examples/server_callback.cf
%%DOCSDIR%%/examples/server_copy_localhost.cf
%%DOCSDIR%%/examples/server_copy_purge.cf
%%DOCSDIR%%/examples/server_copy_remote.cf
%%DOCSDIR%%/examples/server_flatcopy_localhost.cf
%%DOCSDIR%%/examples/service_catalogue.cf
%%DOCSDIR%%/examples/service_catalogue_separate.cf
%%DOCSDIR%%/examples/service_disable.cf
%%DOCSDIR%%/examples/service_start.cf
%%DOCSDIR%%/examples/services_concept.cf
%%DOCSDIR%%/examples/services_win.cf
%%DOCSDIR%%/examples/setuidlog.cf
%%DOCSDIR%%/examples/setvar.cf
%%DOCSDIR%%/examples/shuffle.cf
%%DOCSDIR%%/examples/software_dist.cf
%%DOCSDIR%%/examples/software_update_version_yum.cf
%%DOCSDIR%%/examples/some.cf
%%DOCSDIR%%/examples/sort.cf
%%DOCSDIR%%/examples/splitstring.cf
%%DOCSDIR%%/examples/sql_table_structure.cf
%%DOCSDIR%%/examples/storage.cf
%%DOCSDIR%%/examples/strcmp.cf
%%DOCSDIR%%/examples/strftime.cf
%%DOCSDIR%%/examples/string_downcase.cf
%%DOCSDIR%%/examples/string_head.cf
%%DOCSDIR%%/examples/string_length.cf
%%DOCSDIR%%/examples/string_mustache.cf
%%DOCSDIR%%/examples/string_reverse.cf
%%DOCSDIR%%/examples/string_split.cf
%%DOCSDIR%%/examples/string_tail.cf
%%DOCSDIR%%/examples/string_upcase.cf
%%DOCSDIR%%/examples/stringarray.cf
%%DOCSDIR%%/examples/sublist.cf
%%DOCSDIR%%/examples/sum.cf
%%DOCSDIR%%/examples/switchcase.cf
%%DOCSDIR%%/examples/syslog.cf
%%DOCSDIR%%/examples/syslog2.cf
%%DOCSDIR%%/examples/template.cf
%%DOCSDIR%%/examples/template2.cf
%%DOCSDIR%%/examples/test_environment.cf
%%DOCSDIR%%/examples/tidy_all_files.cf
%%DOCSDIR%%/examples/translatepath.cf
%%DOCSDIR%%/examples/unique.cf
%%DOCSDIR%%/examples/unpack_method_calls.cf
%%DOCSDIR%%/examples/update.cf
%%DOCSDIR%%/examples/user_edit.cf
%%DOCSDIR%%/examples/user_edit_method.cf
%%DOCSDIR%%/examples/userexists.cf
%%DOCSDIR%%/examples/users_type.cf
%%DOCSDIR%%/examples/varclass.cf
%%DOCSDIR%%/examples/varexpansion.cf
%%DOCSDIR%%/examples/variablesmatching.cf
%%DOCSDIR%%/examples/varnet.cf
%%DOCSDIR%%/examples/vars.cf
%%DOCSDIR%%/examples/warnifline.cf
%%DOCSDIR%%/examples/webserver.cf
%%DOCSDIR%%/examples/win_dns_client.cf
%%DOCSDIR%%/examples/win_emergency.cf
%%DOCSDIR%%/examples/win_registry.cf
%%DOCSDIR%%/examples/win_schedule.cf
%%DOCSDIR%%/examples/zenoss.cf
@dir %%DOCSDIR%%/examples
@dir %%DOCSDIR%%
@dir libexec/cfengine
@unexec rmdir "/var/cfengine/inputs" >/dev/null 2>&1 || :
@unexec rmdir "/var/cfengine/modules" >/dev/null 2>&1 || :
@unexec rmdir "/var/cfengine/outputs" >/dev/null 2>&1 || :
@unexec rmdir "/var/cfengine/ppkeys" >/dev/null 2>&1 || :
@unexec rmdir "/var/cfengine" >/dev/null 2>&1 || :