mail/py-milter: fix runtime crash; pass on MAINTAINER

- Import patch to resolve crash during IPv6 connection handling. Submitter
  has coordinated fix with upstream; it can be removed next update.
- Pass on MAINTAINER to from ports@ to submitter.
- While here, move DIST_SUBDIR to appease portlint.

PR:		214317
Submitted by:	schmidt@ze.tum.de
MFH:		2016Q4 (blanket)
This commit is contained in:
Jason Unovitch 2016-12-01 23:41:24 +00:00
parent 9bbc91bba2
commit fc7645d0ef
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=427533
2 changed files with 14 additions and 3 deletions

View File

@ -3,13 +3,14 @@
PORTNAME= milter
PORTVERSION= 1.0
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= mail python
MASTER_SITES= SF/${PYPORTNAME}/${PYPORTNAME}/${DISTNAME}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${PYPORTNAME}-${PORTVERSION}
DIST_SUBDIR= python
MAINTAINER= ports@FreeBSD.org
MAINTAINER= estartu@augusta.de
COMMENT= Python interface to Sendmail milter API
LICENSE= GPLv2+
@ -22,7 +23,6 @@ CFLAGS+= -I${LOCALBASE}/include
PYPORTNAME= ${PKGNAMEPREFIX:C/[0-9]+-//}${PORTNAME}
DIST_SUBDIR= python
USES= python:2
USE_PYTHON= distutils autoplist

View File

@ -0,0 +1,11 @@
--- miltermodule.c.orig 2013-03-15 20:50:01 UTC
+++ miltermodule.c
@@ -285,7 +285,7 @@ $ python setup.py help
* published. Unfortunately I know of no good way to do this
* other than with OS-specific tests.
*/
-#if defined(__FreeBSD_kernel__) || defined(__linux__)
+#if defined(__FreeBSD__) || defined(__linux__)
#define HAVE_IPV6_RFC2553
#include <arpa/inet.h>
#endif