net/py-oauth2: Fix tests from being installed in site-packages
- Patch setup.py to exclude tests from install (CONFLICT) [1][2] - pkg-descr: Tab->space in WWW: (portlint) - Bump PORTREVISION [1] This Python package uses packages=find_packages() with a tests module in the root that contains an __init__.py file, which results in the tests module being installed in site-packages. The correct way of including tests in a pypi package using sdist, while excluding tests in the root from being installed it to use: * packages = find_packages(exclude='tests'), * A MANIFEST.in containing "include tests/*" or equivalent [2] https://github.com/simplegeo/python-oauth2/issues/139 Reported by: antoine Approved by: maintainer (via Twitter)
This commit is contained in:
parent
f2daee3ad6
commit
fc6119645e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=348331
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= oauth2
|
||||
PORTVERSION= 1.5.211
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
11
net/py-oauth2/files/patch-setup.py
Normal file
11
net/py-oauth2/files/patch-setup.py
Normal file
@ -0,0 +1,11 @@
|
||||
--- ./setup.py.orig 2014-03-15 23:48:44.604925965 +1100
|
||||
+++ ./setup.py 2014-03-15 23:49:01.462781884 +1100
|
||||
@@ -31,7 +31,7 @@
|
||||
author="Joe Stump",
|
||||
author_email="joe@simplegeo.com",
|
||||
url="http://github.com/simplegeo/python-oauth2",
|
||||
- packages = find_packages(),
|
||||
+ packages = find_packages(exclude=['tests']),
|
||||
install_requires = ['httplib2'],
|
||||
license = "MIT License",
|
||||
keywords="oauth",
|
@ -11,4 +11,4 @@ forefathers:
|
||||
* The library is likely no longer compatible with Python 2.3.
|
||||
* The Client class works and extends from httplib2.
|
||||
|
||||
WWW: http://github.com/simplegeo/python-oauth2
|
||||
WWW: http://github.com/simplegeo/python-oauth2
|
||||
|
Loading…
Reference in New Issue
Block a user