Upgrade to 1.64.

Install the binaries, not just libtool wrapper scripts.

Install library (required for the binaries to work), headers, and pkgconfig.

Modernize: new LIB_DEPENDS, USES=libtool, staging, strip libraries.

Take maintainership.

Approved by:	maintainer timeout (implicit: no maintainer updates since 2008)
This commit is contained in:
Brooks Davis 2014-06-26 21:02:37 +00:00
parent e4c7ebc3c4
commit fc1f191349
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=359419
4 changed files with 265 additions and 54 deletions

View File

@ -2,72 +2,57 @@
# $FreeBSD$
PORTNAME= srecord
PORTVERSION= 1.59
PORTREVISION= 1
PORTVERSION= 1.64
CATEGORIES= devel
MASTER_SITES= SF
MAINTAINER= abwang@gmail.com
MAINTAINER= brooks@FreeBSD.org
COMMENT= Collection of powerful tools for manipulating EPROM load files
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
BUILD_DEPENDS= ps2pdf:${PORTSDIR}/print/ghostscript9 \
${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs \
libtool:${PORTSDIR}/devel/libtool
LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
USES= libtool
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
LDFLAGS+= -L${LOCALBASE}/lib
USE_AUTOTOOLS= libtool
STRIP=
HEADER_DIRS= input \
input/file \
input/filter \
input/filter/checksum \
input/filter/interval \
input/filter/message \
input/generator \
memory \
memory/walker \
output \
output/file \
quit
PLIST_FILES= bin/srec_cat \
bin/srec_cmp \
bin/srec_info
post-build:
cd ${WRKSRC} && ${MAKE_CMD} libdir/pkgconfig/srecord.pc
MAN1= srec_cat.1 \
srec_cmp.1 \
srec_examples.1 \
srec_info.1 \
srec_input.1 \
srec_license.1
MAN5= srec_aomf.5 \
srec_ascii_hex.5 \
srec_atmel_generic.5 \
srec_binary.5 \
srec_brecord.5 \
srec_cosmac.5 \
srec_dec_binary.5 \
srec_emon52.5 \
srec_fairchild.5 \
srec_fastload.5 \
srec_formatted_binary.5 \
srec_fpc.5 \
srec_intel.5 \
srec_intel16.5 \
srec_mos_tech.5 \
srec_motorola.5 \
srec_needham.5 \
srec_os65v.5 \
srec_signetics.5 \
srec_spasm.5 \
srec_spectrum.5 \
srec_stewie.5 \
srec_tektronix.5 \
srec_tektronix_extended.5 \
srec_ti_tagged.5 \
srec_ti_tagged_16.5 \
srec_ti_txt.5 \
srec_vmem.5 \
srec_wilson.5
pre-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${MKDIR} ${STAGEDIR}${PREFIX}/include/${PORTNAME}
${MKDIR} ${HEADER_DIRS:S,^,${STAGEDIR}${PREFIX}/include/${PORTNAME}/,}
NO_STAGE= yes
do-install:
@${INSTALL_PROGRAM} ${PLIST_FILES:S,^,${WRKSRC}/,} ${PREFIX}/bin/
@${INSTALL_MAN} ${MAN1:S,^,${WRKSRC}/man/man1/,} ${MAN1PREFIX}/man/man1/
@${INSTALL_MAN} ${MAN5:S,^,${WRKSRC}/man/man5/,} ${MAN5PREFIX}/man/man5/
post-install:
chmod 644 ${STAGEDIR}${PREFIX}/lib/libsrecord.so.0
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsrecord.so.0
chmod 444 ${STAGEDIR}${PREFIX}/lib/libsrecord.so.0
${INSTALL_DATA} ${WRKSRC}/libdir/pkgconfig/srecord.pc \
${STAGEDIR}${PREFIX}/libdata/pkgconfig
test:
@cd ${WRKSRC} && ${MAKE} sure
build-plist:
${RM} -f ${PLIST}
${MAKE} makeplist | \
${GREP} -v /you/have/to/check/what/makeplist/gives/you >> ${PLIST}
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (srecord-1.59.tar.gz) = 97d441ee62b948a47935adfab8b8fb01a7a654b1656b32b299a4a041e36bd351
SIZE (srecord-1.59.tar.gz) = 889036
SHA256 (srecord-1.64.tar.gz) = 49a4418733c508c03ad79a29e95acec9a2fbc4c7306131d2a8f5ef32012e67e2
SIZE (srecord-1.64.tar.gz) = 942513

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- Makefile.in.orig
+++ Makefile.in
@@ -4594,7 +4594,7 @@
# to install the *.a and *.so* files as well, which is why you don't see them
# explicitly mentioned here.
#
-install-libdir: $(libdir)/libsrecord.la $(libdir)/pkgconfig/srecord.pc
+install-libdir: $(libdir)/libsrecord.la
install-man: $(mandir)/man1/srec_cat.1 $(mandir)/man1/srec_cmp.1 \
$(mandir)/man1/srec_examples.1 $(mandir)/man1/srec_info.1 \

212
devel/srecord/pkg-plist Normal file
View File

@ -0,0 +1,212 @@
bin/srec_cat
bin/srec_cmp
bin/srec_info
include/srecord/adler16.h
include/srecord/adler32.h
include/srecord/crc16.h
include/srecord/crc32.h
include/srecord/defcon.h
include/srecord/endian.h
include/srecord/fletcher16.h
include/srecord/fletcher32.h
include/srecord/format_printf.h
include/srecord/input.h
include/srecord/input/catenate.h
include/srecord/input/file.h
include/srecord/input/file/aomf.h
include/srecord/input/file/ascii_hex.h
include/srecord/input/file/atmel_generic.h
include/srecord/input/file/binary.h
include/srecord/input/file/brecord.h
include/srecord/input/file/cosmac.h
include/srecord/input/file/dec_binary.h
include/srecord/input/file/emon52.h
include/srecord/input/file/fairchild.h
include/srecord/input/file/fastload.h
include/srecord/input/file/formatted_binary.h
include/srecord/input/file/four_packed_code.h
include/srecord/input/file/intel.h
include/srecord/input/file/logisim.h
include/srecord/input/file/mif.h
include/srecord/input/file/mips_flash.h
include/srecord/input/file/mos_tech.h
include/srecord/input/file/msbin.h
include/srecord/input/file/needham.h
include/srecord/input/file/os65v.h
include/srecord/input/file/ppb.h
include/srecord/input/file/ppx.h
include/srecord/input/file/signetics.h
include/srecord/input/file/spasm.h
include/srecord/input/file/spectrum.h
include/srecord/input/file/stewie.h
include/srecord/input/file/tektronix.h
include/srecord/input/file/tektronix_extended.h
include/srecord/input/file/ti_tagged.h
include/srecord/input/file/ti_tagged_16.h
include/srecord/input/file/ti_txt.h
include/srecord/input/file/trs80.h
include/srecord/input/file/vmem.h
include/srecord/input/file/wilson.h
include/srecord/input/filter.h
include/srecord/input/filter/and.h
include/srecord/input/filter/bitrev.h
include/srecord/input/filter/byte_swap.h
include/srecord/input/filter/checksum.h
include/srecord/input/filter/checksum/bitnot.h
include/srecord/input/filter/checksum/negative.h
include/srecord/input/filter/checksum/positive.h
include/srecord/input/filter/crop.h
include/srecord/input/filter/fill.h
include/srecord/input/filter/interval.h
include/srecord/input/filter/interval/length.h
include/srecord/input/filter/interval/maximum.h
include/srecord/input/filter/interval/minimum.h
include/srecord/input/filter/message.h
include/srecord/input/filter/message/adler16.h
include/srecord/input/filter/message/adler32.h
include/srecord/input/filter/message/crc16.h
include/srecord/input/filter/message/crc32.h
include/srecord/input/filter/message/fletcher16.h
include/srecord/input/filter/message/fletcher32.h
include/srecord/input/filter/message/gcrypt.h
include/srecord/input/filter/not.h
include/srecord/input/filter/offset.h
include/srecord/input/filter/or.h
include/srecord/input/filter/random_fill.h
include/srecord/input/filter/sequence.h
include/srecord/input/filter/split.h
include/srecord/input/filter/unfill.h
include/srecord/input/filter/unsplit.h
include/srecord/input/filter/xor.h
include/srecord/input/generator.h
include/srecord/input/generator/constant.h
include/srecord/input/generator/random.h
include/srecord/input/generator/repeat.h
include/srecord/interval.h
include/srecord/memory.h
include/srecord/memory/chunk.h
include/srecord/memory/walker.h
include/srecord/memory/walker/compare.h
include/srecord/memory/walker/continuity.h
include/srecord/memory/walker/gcrypt.h
include/srecord/memory/walker/writer.h
include/srecord/output.h
include/srecord/output/file.h
include/srecord/output/file/aomf.h
include/srecord/output/file/ascii_hex.h
include/srecord/output/file/asm.h
include/srecord/output/file/atmel_generic.h
include/srecord/output/file/basic.h
include/srecord/output/file/binary.h
include/srecord/output/file/brecord.h
include/srecord/output/file/c.h
include/srecord/output/file/cosmac.h
include/srecord/output/file/dec_binary.h
include/srecord/output/file/emon52.h
include/srecord/output/file/fairchild.h
include/srecord/output/file/fastload.h
include/srecord/output/file/formatted_binary.h
include/srecord/output/file/forth.h
include/srecord/output/file/four_packed_code.h
include/srecord/output/file/hexdump.h
include/srecord/output/file/intel.h
include/srecord/output/file/intel16.h
include/srecord/output/file/logisim.h
include/srecord/output/file/mif.h
include/srecord/output/file/mips_flash.h
include/srecord/output/file/mos_tech.h
include/srecord/output/file/msbin.h
include/srecord/output/file/needham.h
include/srecord/output/file/os65v.h
include/srecord/output/file/ppb.h
include/srecord/output/file/ppx.h
include/srecord/output/file/signetics.h
include/srecord/output/file/spasm.h
include/srecord/output/file/spectrum.h
include/srecord/output/file/stewie.h
include/srecord/output/file/tektronix.h
include/srecord/output/file/tektronix_extended.h
include/srecord/output/file/ti_tagged.h
include/srecord/output/file/ti_tagged_16.h
include/srecord/output/file/ti_txt.h
include/srecord/output/file/trs80.h
include/srecord/output/file/vhdl.h
include/srecord/output/file/vmem.h
include/srecord/output/file/wilson.h
include/srecord/quit.h
include/srecord/quit/exception.h
include/srecord/quit/normal.h
include/srecord/quit/prefix.h
include/srecord/record.h
include/srecord/srecord.h
include/srecord/string.h
lib/libsrecord.a
lib/libsrecord.so
lib/libsrecord.so.0
libdata/pkgconfig/srecord.pc
man/man1/srec_cat.1.gz
man/man1/srec_cmp.1.gz
man/man1/srec_examples.1.gz
man/man1/srec_info.1.gz
man/man1/srec_input.1.gz
man/man1/srec_license.1.gz
man/man3/srecord.3.gz
man/man3/srecord_license.3.gz
man/man5/srec_aomf.5.gz
man/man5/srec_ascii_hex.5.gz
man/man5/srec_atmel_generic.5.gz
man/man5/srec_binary.5.gz
man/man5/srec_brecord.5.gz
man/man5/srec_coe.5.gz
man/man5/srec_cosmac.5.gz
man/man5/srec_dec_binary.5.gz
man/man5/srec_emon52.5.gz
man/man5/srec_fairchild.5.gz
man/man5/srec_fastload.5.gz
man/man5/srec_formatted_binary.5.gz
man/man5/srec_forth.5.gz
man/man5/srec_fpc.5.gz
man/man5/srec_idt.5.gz
man/man5/srec_intel.5.gz
man/man5/srec_intel16.5.gz
man/man5/srec_logisim.5.gz
man/man5/srec_mem.5.gz
man/man5/srec_mif.5.gz
man/man5/srec_mips_flash.5.gz
man/man5/srec_mos_tech.5.gz
man/man5/srec_motorola.5.gz
man/man5/srec_msbin.5.gz
man/man5/srec_needham.5.gz
man/man5/srec_os65v.5.gz
man/man5/srec_ppb.5.gz
man/man5/srec_ppx.5.gz
man/man5/srec_signetics.5.gz
man/man5/srec_spasm.5.gz
man/man5/srec_spectrum.5.gz
man/man5/srec_stewie.5.gz
man/man5/srec_tektronix.5.gz
man/man5/srec_tektronix_extended.5.gz
man/man5/srec_ti_tagged.5.gz
man/man5/srec_ti_tagged_16.5.gz
man/man5/srec_ti_txt.5.gz
man/man5/srec_trs80.5.gz
man/man5/srec_vmem.5.gz
man/man5/srec_wilson.5.gz
%%PORTDOCS%%%%DOCSDIR%%/BUILDING.pdf
%%PORTDOCS%%%%DOCSDIR%%/README.pdf
%%PORTDOCS%%%%DOCSDIR%%/change_log.pdf
%%PORTDOCS%%%%DOCSDIR%%/reference.pdf
@dirrmtry include/srecord/input/file
@dirrmtry include/srecord/input/filter/checksum
@dirrmtry include/srecord/input/filter/interval
@dirrmtry include/srecord/input/filter/message
@dirrmtry include/srecord/input/filter
@dirrmtry include/srecord/input/generator
@dirrmtry include/srecord/input
@dirrmtry include/srecord/memory/walker
@dirrmtry include/srecord/memory
@dirrmtry include/srecord/output/file
@dirrmtry include/srecord/output
@dirrmtry include/srecord/quit
@dirrmtry include/srecord
%%PORTDOCS%%@dirrmtry %%DOCSDIR%%