Fix Imakefile breakage under XFree86 4.x

Respect CXX/CXXFLAGS

PR:		21977
Submitted by:	Ports Fury
This commit is contained in:
Ade Lovett 2000-10-14 19:49:51 +00:00
parent e20215f357
commit fba7b30d45
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33837
2 changed files with 32 additions and 9 deletions

View File

@ -5,18 +5,18 @@
# $FreeBSD$
#
PORTNAME= xspacewarp
PORTVERSION= 1.2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
PORTNAME= xspacewarp
PORTVERSION= 1.2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= games
MAINTAINER= ports@FreeBSD.org
MAINTAINER= ports@FreeBSD.org
USE_IMAKE= yes
USE_IMAKE= yes
NO_INSTALL_MANPAGES= yes
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/xspacewarp ${PREFIX}/bin
@ ${INSTALL_DATA} ${WRKSRC}/XSpacewarp.app_def ${X11BASE}/lib/X11/app-defaults/XSpacewarp
post-extract:
@${CP} ${WRKSRC}/XSpacewarp.app_def ${WRKSRC}/XSpacewarp.ad
.include <bsd.port.mk>

View File

@ -0,0 +1,23 @@
--- Imakefile.orig Fri Dec 29 16:39:19 1995
+++ Imakefile Sat Oct 14 06:14:22 2000
@@ -2,12 +2,7 @@
XCOMM Use the C++ compiler of your choice.
-CC = g++
-
-XCOMM Suffix rule for ".cc" files
-
-.cc.o:
- $(CC) $(CFLAGS) -c $<
+CC = $(CXX)
LOCAL_LIBRARIES = XawClientLibs
SYS_LIBRARIES = -lm
@@ -26,4 +21,5 @@
draw_summary.o draw_intro.o draw_mission.o draw_orientation.o \
draw_winlose.o
-ComplexProgramTarget(xspacewarp)
+ComplexProgramTargetNoMan(xspacewarp)
+InstallAppDefaults(XSpacewarp)