lang/zig: Update to 0.5.0
Changes: https://ziglang.org/download/0.5.0/release-notes.html
This commit is contained in:
parent
3fb8ce0418
commit
fba7135f7e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=513455
@ -1,7 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= zig
|
||||
DISTVERSION= 0.4.0
|
||||
DISTVERSION= 0.5.0
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= https://ziglang.org/download/${DISTVERSION}/
|
||||
|
||||
@ -11,7 +11,10 @@ COMMENT= Language designed for robustness, optimality, and maintainability
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
_LLVM_VER= 80
|
||||
BROKEN_i386= static_assert failed "static_assert(sizeof(ZigClangAPValue) == sizeof(clang::APValue), "")"
|
||||
IGNORE_FreeBSD_11= expects getrandom(2) which is unavailable on FreeBSD < 12.0
|
||||
|
||||
_LLVM_VER= 90
|
||||
BUILD_DEPENDS= llvm${_LLVM_VER}>=0:devel/llvm${_LLVM_VER}
|
||||
|
||||
USES= cmake compiler:c++11-lang tar:xz
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1569067124
|
||||
SHA256 (zig-0.4.0.tar.xz) = fec1f3f6b359a3d942e0a7f9157b3b30cde83927627a0e1ea95c54de3c526cfc
|
||||
SIZE (zig-0.4.0.tar.xz) = 5348776
|
||||
TIMESTAMP = 1569904957
|
||||
SHA256 (zig-0.5.0.tar.xz) = 55ae16960f152bcb9cf98b4f8570902d0e559a141abf927f0d3555b7cc838a31
|
||||
SIZE (zig-0.5.0.tar.xz) = 10956132
|
||||
|
@ -1,38 +0,0 @@
|
||||
https://github.com/ziglang/zig/commit/81767a658d07219a402384f98a7553abcbbd2e70
|
||||
https://github.com/ziglang/zig/commit/40fe6afdad1a8676b5d3a5dd23d6d50d6ea9f059
|
||||
|
||||
--- CMakeLists.txt.orig 2019-04-08 19:41:41 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -62,6 +62,16 @@ endif()
|
||||
|
||||
set(ZIG_CPP_LIB_DIR "${CMAKE_BINARY_DIR}/zig_cpp")
|
||||
|
||||
+# Handle multi-config builds and place each into a common lib. The VS generator
|
||||
+# for example will append a Debug folder by default if not explicitly specified.
|
||||
+set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${ZIG_CPP_LIB_DIR})
|
||||
+set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${ZIG_CPP_LIB_DIR})
|
||||
+foreach(CONFIG_TYPE ${CMAKE_CONFIGURATION_TYPES})
|
||||
+ string(TOUPPER ${CONFIG_TYPE} CONFIG_TYPE)
|
||||
+ set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY_${CONFIG_TYPE} ${ZIG_CPP_LIB_DIR})
|
||||
+ set(CMAKE_LIBRARY_OUTPUT_DIRECTORY_${CONFIG_TYPE} ${ZIG_CPP_LIB_DIR})
|
||||
+endforeach(CONFIG_TYPE CMAKE_CONFIGURATION_TYPES)
|
||||
+
|
||||
if(ZIG_FORCE_EXTERNAL_LLD)
|
||||
find_package(lld)
|
||||
include_directories(${LLVM_INCLUDE_DIRS})
|
||||
@@ -257,7 +267,6 @@ else()
|
||||
embedded_lld_wasm
|
||||
embedded_lld_lib
|
||||
)
|
||||
- install(TARGETS embedded_lld_elf embedded_lld_coff embedded_lld_mingw embedded_lld_wasm embedded_lld_lib DESTINATION "${ZIG_CPP_LIB_DIR}")
|
||||
endif()
|
||||
|
||||
# No patches have been applied to SoftFloat-3e
|
||||
@@ -6670,7 +6679,6 @@ if(MSVC OR MINGW)
|
||||
target_link_libraries(zig LINK_PUBLIC version)
|
||||
endif()
|
||||
install(TARGETS zig DESTINATION bin)
|
||||
-install(TARGETS zig_cpp DESTINATION "${ZIG_CPP_LIB_DIR}")
|
||||
|
||||
foreach(file ${ZIG_C_HEADER_FILES})
|
||||
get_filename_component(file_dir "${C_HEADERS_DEST}/${file}" DIRECTORY)
|
2924
lang/zig/pkg-plist
2924
lang/zig/pkg-plist
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user