Fix build on i386
This commit is contained in:
parent
f9a88a2fae
commit
fb928f6909
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=541719
@ -15,8 +15,6 @@ COMMENT= Free Worms-like turn based strategy game
|
||||
LICENSE= GPLv2 GFDL
|
||||
LICENSE_COMB= multi
|
||||
|
||||
BROKEN_i386= uSound.pas: hGetContents: invalid argument (invalid byte sequence)
|
||||
|
||||
LIB_DEPENDS= libphysfs.so:devel/physfs \
|
||||
libpng.so:graphics/png
|
||||
|
||||
@ -40,6 +38,8 @@ PLIST_FILES= bin/${PORTNAME} bin/hwengine \
|
||||
lib/libphyslayer.so.1.0
|
||||
PORTDATA= *
|
||||
|
||||
USE_LOCALE= en_US.UTF-8
|
||||
|
||||
OPTIONS_DEFINE= VIDEOREC
|
||||
OPTIONS_DEFAULT=VIDEOREC
|
||||
OPTIONS_EXCLUDE_i386= VIDEOREC # some pascal issues preventing to use it
|
||||
|
22
games/hedgewars/files/patch-CMakeLists.txt
Normal file
22
games/hedgewars/files/patch-CMakeLists.txt
Normal file
@ -0,0 +1,22 @@
|
||||
--- CMakeLists.txt.orig 2019-10-10 13:38:46 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -180,19 +180,6 @@ else()
|
||||
endif()
|
||||
|
||||
|
||||
-#build engine without freepascal
|
||||
-if(BUILD_ENGINE_C AND NOT BUILD_ENGINE_JS)
|
||||
- find_package(Clang REQUIRED)
|
||||
-
|
||||
- if(${CLANG_VERSION} VERSION_LESS "3.0")
|
||||
- message(FATAL_ERROR "LLVM/Clang compiler required version is 3.0 but version ${CLANG_VERSION} was found!")
|
||||
- endif()
|
||||
-
|
||||
- set(CMAKE_C_COMPILER ${CLANG_EXECUTABLE})
|
||||
- set(CMAKE_CXX_COMPILER ${CLANG_EXECUTABLE})
|
||||
-endif()
|
||||
-
|
||||
-
|
||||
#server
|
||||
if(NOT NOSERVER)
|
||||
add_subdirectory(gameServer)
|
16
games/hedgewars/files/patch-QTfrontend_CMakeLists.txt
Normal file
16
games/hedgewars/files/patch-QTfrontend_CMakeLists.txt
Normal file
@ -0,0 +1,16 @@
|
||||
--- QTfrontend/CMakeLists.txt.orig 2019-10-10 13:38:46 UTC
|
||||
+++ QTfrontend/CMakeLists.txt
|
||||
@@ -247,13 +247,6 @@ if(WIN32 AND NOT UNIX)
|
||||
)
|
||||
endif()
|
||||
|
||||
-if(CMAKE_CXX_COMPILER MATCHES "clang*")
|
||||
- list(APPEND HW_LINK_LIBS stdc++ m)
|
||||
- if(NOT APPLE)
|
||||
- list(APPEND HW_LINK_LIBS atomic)
|
||||
- endif()
|
||||
-endif()
|
||||
-
|
||||
if(WIN32 AND VCPKG_TOOLCHAIN)
|
||||
list(APPEND HW_LINK_LIBS Qt5::WinMain)
|
||||
endif()
|
Loading…
Reference in New Issue
Block a user