Add libelysium 0.2.6, a library of utility functions used by

several Elysium (yet another GNU/Linux distro) projects.
This commit is contained in:
Maxim Sobolev 2001-12-10 10:03:32 +00:00
parent 0d8c0cb73a
commit fb37a4b86c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51306
9 changed files with 108 additions and 0 deletions

View File

@ -110,6 +110,7 @@
SUBDIR += kwatch
SUBDIR += lc
SUBDIR += less
SUBDIR += libelysium
SUBDIR += libh
SUBDIR += libmcal
SUBDIR += lifelines

28
misc/libelysium/Makefile Normal file
View File

@ -0,0 +1,28 @@
# Ports collection Makefile for: libelysium
# Date created: 10 December 2001
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= libelysium
PORTVERSION= 0.2.6
CATEGORIES= misc gnome
MASTER_SITES= http://elysium.zoned.net/${PORTNAME}/
MAINTAINER= sobomax@FreeBSD.org
USE_GLIB= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>

1
misc/libelysium/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (libelysium-0.2.6.tar.gz) = 388c2c543d3746499254053c62efe512

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- Makefile.in 2001/12/10 09:35:00 1.1
+++ Makefile.in 2001/12/10 09:35:18
@@ -85,7 +85,7 @@
EXTRA_DIST = libelysium.spec.in libelysiumConf.sh.in
-confexecdir = $(libdir)
+confexecdir = $(sysconfdir)
confexec_DATA = libelysiumConf.sh
CLEANFILES = libelysiumConf.sh

View File

@ -0,0 +1,25 @@
$FreeBSD$
--- configure.orig Mon Dec 10 11:37:09 2001
+++ configure Mon Dec 10 11:53:37 2001
@@ -952,7 +952,7 @@
ELYSIUM_LIBDIR='-L${libdir}'
ELYSIUM_INCLUDEDIR='-I${includedir}'
-ELYSIUM_LIBS="-lelysium -lglib"
+ELYSIUM_LIBS="-lelysium `$GLIB_CONFIG --libs`"
echo $ac_n "checking whether to enable maintainer-specific portions of Makefiles""... $ac_c" 1>&6
echo "configure:959: checking whether to enable maintainer-specific portions of Makefiles" >&5
@@ -5462,8 +5462,8 @@
-CFLAGS="`glib-config --cflags`"
-LDFLAGS="`glib-config --libs`"
+CFLAGS="`$GLIB_CONFIG --cflags`"
+LDFLAGS="`$GLIB_CONFIG --libs`"

View File

@ -0,0 +1,28 @@
$FreeBSD$
--- ltmain.sh 2001/08/27 09:51:26 1.1
+++ ltmain.sh 2001/08/27 09:51:42
@@ -2408,6 +2408,9 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test "$build_libtool_need_lc" = "yes"; then
@@ -4175,10 +4178,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -0,0 +1 @@
A library of utility functions used by several Elysium projects

View File

@ -0,0 +1,3 @@
LibElysium is a library of utility functions used by several Elysium projects.
WWW: http://elysium.zoned.net/libelysium/index.html

View File

@ -0,0 +1,7 @@
etc/libelysiumConf.sh
include/libelysium/elysium-file.h
include/libelysium/encompass-uri.h
lib/libelysium.a
lib/libelysium.so
lib/libelysium.so.0
@dirrm include/libelysium