databases/kbibtex: update to 0.9.3.1

Changelog:
  - Fixing crashes with newer Qt versions (Albert Astals Cid
    <aacid@kde.org>)
  - Revamping various online searches by backporting updates from branch
    'kbibtex/0.10':
    ACM's Digital Library, SpringerLink, JStor, NASA Astrophysics Data
    System, bioRxiv
  - Fixing minor issues with build system
  - Fixing potential crash in BibTeX importer code
  - KDE Bug 459150: Fix creation of URL from user input

Port changes:
  * Add backport of
    4cad9a994c
    to enable documentation and translations.
  * Regenerate existing patch.
This commit is contained in:
Tobias C. Berner 2023-01-25 19:00:10 +01:00
parent 59207909da
commit fb36734ae8
4 changed files with 33 additions and 14 deletions

View File

@ -1,8 +1,7 @@
PORTNAME= kbibtex
DISTVERSION= 0.9.2
PORTREVISION= 41
DISTVERSION= 0.9.3.1
CATEGORIES= databases kde
MASTER_SITES= KDE/stable/KBibTeX/${DISTVERSION}
MASTER_SITES= KDE/stable/KBibTeX/${DISTVERSION:R}
MAINTAINER= kde@FreeBSD.org
COMMENT= Bibliography editor for KDE
@ -14,15 +13,15 @@ LIB_DEPENDS= libicuuc.so:devel/icu \
libqoauth-qt5.so:net/qoauth-qt5
USES= cmake compiler:c++11-lang desktop-file-utils gettext gnome \
iconv kde:5 qca qt:5 shared-mime-info tar:xz xorg
iconv kde:5 pkgconfig qca qt:5 shared-mime-info tar:xz xorg
USE_GNOME= libxml2 libxslt
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash ecm i18n iconthemes itemviews jobwidgets \
kio parts service solid sonnet syntaxhighlighting texteditor \
coreaddons crash ecm i18n iconthemes itemviews jobwidgets kio \
parts service solid sonnet syntaxhighlighting texteditor \
textwidgets wallet widgetsaddons windowsystem xmlgui \
doctools:build
USE_QT= concurrent core dbus declarative gui location network \
printsupport webchannel widgets xml xmlpatterns \
networkauth printsupport webchannel widgets xml xmlpatterns \
buildtools:build qmake:build
USE_XORG= x11
USE_LDCONFIG= yes

View File

@ -1,3 +1,5 @@
TIMESTAMP = 1587962652
SHA256 (kbibtex-0.9.2.tar.xz) = d98651fba99de8ebaf1a19bd8b3c3ac660a34cea33e4c587be30fd61466fac27
SIZE (kbibtex-0.9.2.tar.xz) = 4196896
TIMESTAMP = 1674848560
SHA256 (kbibtex-0.9.3.1.tar.xz) = 907fc4e71bfd766ccced6ac8325182a38cb45efffb5c7a3010b24fdce273f244
SIZE (kbibtex-0.9.3.1.tar.xz) = 4219496
SHA256 (4cad9a994ccd685e23a94bd13ced36f56336e056.diff) = 0d11ef88e1f97d2a315f8b875295f5503462ef93e7346ea992d06d74cc8ec392
SIZE (4cad9a994ccd685e23a94bd13ced36f56336e056.diff) = 854

View File

@ -0,0 +1,18 @@
Backport of
https://invent.kde.org/office/kbibtex/-/commit/4cad9a994ccd685e23a94bd13ced36f56336e056
to readd translations.
--- CMakeLists.txt.orig 2023-01-12 19:04:52 UTC
+++ CMakeLists.txt
@@ -253,9 +253,11 @@ if(KF5DocTools_FOUND)
)
if(KF5DocTools_FOUND)
add_subdirectory(doc)
+ kdoctools_install(po)
endif()
# macro_optional_add_subdirectory(
# po
# )
+ki18n_install(po)
feature_summary(WHAT ALL INCLUDE_QUIET_PACKAGES FATAL_ON_MISSING_REQUIRED_PACKAGES)

View File

@ -1,8 +1,8 @@
--- src/data/file.cpp.orig 2015-08-09 18:14:19 UTC
--- src/data/file.cpp.orig 2023-01-12 18:57:44 UTC
+++ src/data/file.cpp
@@ -42,8 +42,8 @@ const QString File::ProtectCasing = QLat
const QString File::NameFormatting = QLatin1String("NameFormatting");
const QString File::ListSeparator = QLatin1String("ListSeparator");
@@ -44,8 +44,8 @@ const QString File::ListSeparator = QStringLiteral("Li
const QString File::NameFormatting = QStringLiteral("NameFormatting");
const QString File::ListSeparator = QStringLiteral("ListSeparator");
-const quint64 valid = 0x08090a0b0c0d0e0f;
-const quint64 invalid = 0x0102030405060708;