math/libformfactor: New port: Library for computation of scattering form factors of polyhedra

This commit is contained in:
Yuri Victorovich 2023-01-24 00:33:11 -08:00
parent e7e2d494e8
commit fb235ec928
6 changed files with 51 additions and 0 deletions

View File

@ -441,6 +441,7 @@
SUBDIR += libdivide
SUBDIR += libfixmath
SUBDIR += libflame
SUBDIR += libformfactor
SUBDIR += libhomfly
SUBDIR += libmesh
SUBDIR += libmissing

View File

@ -0,0 +1,22 @@
PORTNAME= libformfactor
DISTVERSION= 0.1.3
CATEGORIES= math
MASTER_SITES= https://jugit.fz-juelich.de/mlz/libformfactor/-/archive/v${DISTVERSION}/
DISTNAME= ${PORTNAME}-v${DISTVERSION}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Library for computation of scattering form factors of polyhedra
WWW= https://jugit.fz-juelich.de/mlz/libformfactor
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= libheinz>0:devel/libheinz
USES= cmake:testing
USE_LDCONFIG= yes
CMAKE_OFF= BUILD_TESTING
CMAKE_TESTING_ON= BUILD_TESTING
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1674545116
SHA256 (libformfactor-v0.1.3.tar.gz) = 933f1f0e4f0c7e4c5e14994d1550d242070ad09f9315e0548dd874cecba66032
SIZE (libformfactor-v0.1.3.tar.gz) = 141200

View File

@ -0,0 +1,12 @@
--- CMakeLists.txt.orig 2023-01-24 07:39:32 UTC
+++ CMakeLists.txt
@@ -42,7 +42,9 @@ message(STATUS "LibHeinz: found=${LibHeinz_FOUND}, inc
include(CTest)
add_subdirectory(ff)
+if (BUILD_TESTING)
add_subdirectory(test)
+endif()
## CPack settings.

View File

@ -0,0 +1,2 @@
libformfactor performs efficient computation of scattering form factors
(Fourier shape transforms) of arbitrary polyhedra.

View File

@ -0,0 +1,11 @@
cmake/formfactorConfig.cmake
cmake/formfactorConfigVersion.cmake
cmake/formfactorTargets-%%CMAKE_BUILD_TYPE%%.cmake
cmake/formfactorTargets.cmake
include/ff/Platonic.h
include/ff/PolyhedralComponents.h
include/ff/PolyhedralTopology.h
include/ff/Polyhedron.h
include/ff/Prism.h
lib/libformfactor.so
lib/libformfactor.so.0.1.3