add borzoi
An Elliptic Curve Cryptography Library
This commit is contained in:
parent
6f412654c4
commit
fb1741b002
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46689
@ -12,6 +12,7 @@
|
||||
SUBDIR += beecrypt
|
||||
SUBDIR += bfbtester
|
||||
SUBDIR += bjorb
|
||||
SUBDIR += borzoi
|
||||
SUBDIR += bro
|
||||
SUBDIR += bugs
|
||||
SUBDIR += ca-roots
|
||||
|
27
security/borzoi/Makefile
Normal file
27
security/borzoi/Makefile
Normal file
@ -0,0 +1,27 @@
|
||||
# ex:ts=8
|
||||
# New ports collection makefile for: borZoi
|
||||
# Date created: Aug 23, 2001
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= borzoi
|
||||
PORTVERSION= 0.8.3
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www1.kcn.ne.jp/~anthony/software/
|
||||
DISTNAME= borZoi-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libntl.a:${PORTSDIR}/math/ntl
|
||||
RUN_DEPENDS= ${LOCALBASE}/lib/libntl.a:${PORTSDIR}/math/ntl
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/src/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/borzoi/distinfo
Normal file
1
security/borzoi/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (borZoi-0.8.3.tar.gz) = a1275a99b401fc441ac3ccd8ade35f39
|
11
security/borzoi/files/patch-configure
Normal file
11
security/borzoi/files/patch-configure
Normal file
@ -0,0 +1,11 @@
|
||||
--- configure.orig Thu Aug 23 15:26:31 2001
|
||||
+++ configure Thu Aug 23 15:26:49 2001
|
||||
@@ -461,7 +461,7 @@
|
||||
|
||||
# A filename unique to this package, relative to the directory that
|
||||
# configure is in, which we can look for to find out if srcdir is correct.
|
||||
-ac_unique_file=src/borZoi.h
|
||||
+ac_unique_file=src/borzoi.h
|
||||
|
||||
# Find the source files, if location was not specified.
|
||||
if test -z "$srcdir"; then
|
20
security/borzoi/files/patch-src::Makefile.in
Normal file
20
security/borzoi/files/patch-src::Makefile.in
Normal file
@ -0,0 +1,20 @@
|
||||
--- src/Makefile.in.orig Sun Jun 24 08:15:31 2001
|
||||
+++ src/Makefile.in Thu Aug 23 15:52:25 2001
|
||||
@@ -73,7 +73,7 @@
|
||||
RANLIB = @RANLIB@
|
||||
VERSION = @VERSION@
|
||||
|
||||
-INCLUDES = -I$(top_srcdir)/src
|
||||
+INCLUDES = -I%%LOCALBASE%%/include -I$(top_srcdir)/src
|
||||
|
||||
lib_LTLIBRARIES = libborzoi.la
|
||||
|
||||
@@ -92,7 +92,7 @@
|
||||
|
||||
borzoi_SOURCES = test.cpp fips186_2.h
|
||||
|
||||
-borzoi_LDADD = @BORZOI_LIBS@ -lntl
|
||||
+borzoi_LDADD = @BORZOI_LIBS@ -lntl -L%%LOCALBASE%%/lib
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_CLEAN_FILES =
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
1
security/borzoi/pkg-comment
Normal file
1
security/borzoi/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
An Elliptic Curve Cryptography Library
|
3
security/borzoi/pkg-descr
Normal file
3
security/borzoi/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
||||
borZoi - An Elliptic Curve Cryptography Library
|
||||
|
||||
WWW: http://www1.kcn.ne.jp/~anthony/software/
|
9
security/borzoi/pkg-plist
Normal file
9
security/borzoi/pkg-plist
Normal file
@ -0,0 +1,9 @@
|
||||
bin/borzoi
|
||||
include/borzoi.h
|
||||
include/borzoi_util.h
|
||||
include/fips186_2.h
|
||||
include/rijndael-alg-fst.h
|
||||
include/rng.h
|
||||
lib/libborzoi.a
|
||||
lib/libborzoi.so
|
||||
lib/libborzoi.so.0
|
Loading…
Reference in New Issue
Block a user