Upgrade from 1.2.2b to 1.2.7.

Install header-files, which make the port's shared library usable by
other applications -- such as, most importantly, OpenOffice.

While here, ensure, the already installed -lintl is used, and configure
in the use of readline too.

Rephrase COMMENT to ease the confusion, that the port is only of
interest to Hungarian-speakers. It is not -- the software is an improved
version of myspell and can work with any dictionary.

Approved by:	maintainer
This commit is contained in:
Mikhail Teterin 2008-09-03 18:54:24 +00:00
parent 13739c4a7e
commit fac8ce0a26
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=219789
12 changed files with 146 additions and 94 deletions

View File

@ -6,22 +6,27 @@
#
PORTNAME= hunspell
PORTVERSION= 1.2.2b
PORTREVISION= 1
PORTVERSION= 1.2.7
CATEGORIES= hungarian textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S@$@:code@:S@%SUBDIR%@${PORTNAME}@} \
${MASTER_SITE_SOURCEFORGE:S@$@:data@:S@%SUBDIR%@magyarispell@}
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:code hu_HU-${DICTVERSION}${EXTRACT_SUFX}:data
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:code \
hu_HU-${DICTVERSION}${EXTRACT_SUFX}:data
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Improved Hungarian spelling checker
COMMENT= Improved spell-checker for Hungarian and other languages
#EXTRACT_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
USE_GETTEXT= yes
USE_ICONV= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= "--with-ui"
CONFIGURE_ARGS= --with-ui --with-libintl-prefix=${PREFIX} --with-readline
CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LDFLAGS=-L${PREFIX}/lib
EXTRACT_AFTER_ARGS=|${TAR} -xpf - --exclude intl
ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
MAN1= hunspell.1
MAN4= hunspell.4
@ -31,13 +36,6 @@ PORTDOCS= README README.myspell
.include <bsd.port.pre.mk>
# Ugly workaround for FreeBSD versions before the import of NetBSD gzip.
#do-extract:
# @${RM} -rf ${WRKDIR}; \
# ${MKDIR} ${WRKDIR}; \
# cd ${WRKDIR} && ${TAR} -xzf ${_DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX};\
# ${UNZIP_CMD} -qo ${_DISTDIR}/hu_HU.zip -d ${WRKDIR}
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/src/tools/hunspell.cxx
@ -46,15 +44,18 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/man/hunspell.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/man/hunspell.4 ${PREFIX}/man/man4
${INSTALL_PROGRAM} ${WRKSRC}/src/tools/.libs/hunspell ${PREFIX}/bin
${MKDIR} ${PREFIX}/include/hunspell
${INSTALL_DATA} ${WRKSRC}/src/hunspell/*.h* ${PREFIX}/include/hunspell/
${INSTALL_DATA} ${WRKSRC}/src/hunspell/.libs/libhunspell-1.2.a ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/src/hunspell/.libs/libhunspell-1.2.lai ${PREFIX}/lib/libhunspell-1.1.la
${INSTALL_DATA} ${WRKSRC}/src/hunspell/.libs/libhunspell-1.2.so.0 ${PREFIX}/lib
${LN} -s ${LOCALBASE}/lib/libhunspell-1.2.so.0 ${PREFIX}/lib/libhunspell-1.2.so
${MKDIR} ${PREFIX}/share/myspell/ && \
${MKDIR} ${PREFIX}/share/myspell/
${INSTALL_DATA} ${WRKDIR}/hu_HU-${DICTVERSION}/hu_HU.dic \
${PREFIX}/share/myspell/ && \
${INSTALL_DATA} ${WRKDIR}/hu_HU-${DICTVERSION}/hu_HU.aff \
${PREFIX}/share/myspell/
${WRKDIR}/hu_HU-${DICTVERSION}/hu_HU.aff \
${PREFIX}/share/myspell/
${MKDIR} ${PREFIX}/lib/pkgconfig
${INSTALL_DATA} ${WRKSRC}/hunspell.pc ${PREFIX}/lib/pkgconfig
${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/magyar.dic
${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/hungarian.dic
${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/default.dic

View File

@ -1,6 +1,6 @@
MD5 (hunspell-1.2.2b.tar.gz) = 46aecfa635868f2618b204968f4bebd1
SHA256 (hunspell-1.2.2b.tar.gz) = 91a67974af4ee5cdfdcd0c0840009356aa3ce1b8d25820dc56c9a594684dad0e
SIZE (hunspell-1.2.2b.tar.gz) = 745643
MD5 (hunspell-1.2.7.tar.gz) = 9a4f345c3cfaeb8e6306285488a3127a
SHA256 (hunspell-1.2.7.tar.gz) = 37d0de21d39a28bcefdc0cb3f24fe8ea10992ff8752139a54807698ec2653046
SIZE (hunspell-1.2.7.tar.gz) = 782364
MD5 (hu_HU-1.3.tar.gz) = 498c47666414fcebdd328e3a5ae20e05
SHA256 (hu_HU-1.3.tar.gz) = 4f7d61e3f06d4cfb61aecbde457474a8f03b664a9500718d34015c253fff5a06
SIZE (hu_HU-1.3.tar.gz) = 1384493

View File

@ -1,11 +0,0 @@
--- src/parsers/latexparser.cxx.orig 2008-04-23 17:56:27.000000000 +0200
+++ src/parsers/latexparser.cxx 2008-04-23 17:57:00.000000000 +0200
@@ -82,7 +82,7 @@
{ { "\\url", NULL } , 1 }
};
-#define PATTERN_LEN (sizeof(PATTERN) / ((sizeof(char *) * 2) + sizeof(int)))
+#define PATTERN_LEN (sizeof(PATTERN) / sizeof(PATTERN[0]))
LaTeXParser::LaTeXParser(const char * wordchars)
{

View File

@ -1,16 +1,14 @@
$FreeBSD$
--- src/tools/hunspell.cxx.orig
+++ src/tools/hunspell.cxx
@@ -59,16 +59,12 @@
#include "manparser.hxx"
#include "firstparser.hxx"
-#define LIBDIR "/usr/share/hunspell:/usr/share/myspell"
+#define LIBDIR "%%PREFIX%%/share/hunspell:%%PREFIX%%/share/myspell"
#define USEROOODIR ".openoffice.org2/user/wordbook"
-#define OOODIR "/opt/openoffice.org2.3/share/dict/ooo:" \
--- src/tools/hunspell.cxx 2008-08-15 06:06:33.000000000 -0400
+++ src/tools/hunspell.cxx 2008-08-26 06:24:36.000000000 -0400
@@ -70,18 +70,12 @@
".openoffice.org2/user/wordbook:" \
".openoffice.org2.0/user/wordbook"
#define OOODIR \
- "/opt/openoffice.org/basis3.0/share/dict/ooo:" \
- "/usr/lib/openoffice.org/basis3.0/share/dict/ooo:" \
- "/opt/openoffice.org2.4/share/dict/ooo:" \
- "/usr/lib/openoffice.org2.4/share/dict/ooo:" \
- "/opt/openoffice.org2.3/share/dict/ooo:" \
- "/usr/lib/openoffice.org2.3/share/dict/ooo:" \
- "/opt/openoffice.org2.2/share/dict/ooo:" \
- "/usr/lib/openoffice.org2.2/share/dict/ooo:" \
@ -18,10 +16,12 @@ $FreeBSD$
- "/usr/lib/openoffice.org2.1/share/dict/ooo:" \
- "/opt/openoffice.org2.0/share/dict/ooo:" \
- "/usr/lib/openoffice.org2.0/share/dict/ooo"
+#define OOODIR "%%PREFIX%%/openoffice.org-2.3/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org-2.2/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org-2.1/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org2.0/share/dict/ooo"
+ "%%PREFIX%%/openoffice.org-DEV300_m29/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org-3.0.0.b2/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org-2.4/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org-2.2/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org-2.1/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org2.0/share/dict/ooo"
#define HOME getenv("HOME")
#define DICBASENAME ".hunspell_"
#define LOGFILE "/tmp/hunspell.log"

View File

@ -0,0 +1,18 @@
--- configure 2008-08-14 05:53:13.000000000 -0400
+++ configure 2008-08-26 06:35:15.000000000 -0400
@@ -24576,5 +24576,5 @@
-ac_config_files="$ac_config_files Makefile hunspell.pc man/Makefile man/hu/Makefile intl/Makefile po/Makefile.in m4/Makefile src/Makefile src/hunspell/Makefile src/parsers/Makefile src/tools/Makefile src/win_api/Makefile tests/Makefile tests/suggestiontest/Makefile"
+ac_config_files="$ac_config_files Makefile hunspell.pc man/Makefile man/hu/Makefile po/Makefile.in m4/Makefile src/Makefile src/hunspell/Makefile src/parsers/Makefile src/tools/Makefile src/win_api/Makefile tests/Makefile tests/suggestiontest/Makefile"
cat >confcache <<\_ACEOF
--- Makefile.in 2008-08-14 05:53:15.000000000 -0400
+++ Makefile.in 2008-08-26 06:37:41.000000000 -0400
@@ -230,5 +230,5 @@
top_srcdir = @top_srcdir@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = intl po src man m4 tests
+SUBDIRS = po src man m4 tests
pkgconfdir = $(libdir)/pkgconfig
pkgconf_DATA = hunspell.pc

View File

@ -1,8 +1,26 @@
bin/hunspell
include/hunspell/affentry.hxx
include/hunspell/affixmgr.hxx
include/hunspell/atypes.hxx
include/hunspell/baseaffix.hxx
include/hunspell/csutil.hxx
include/hunspell/dictmgr.hxx
include/hunspell/filemgr.hxx
include/hunspell/hashmgr.hxx
include/hunspell/htypes.hxx
include/hunspell/hunspell.h
include/hunspell/hunspell.hxx
include/hunspell/hunzip.hxx
include/hunspell/langnum.hxx
include/hunspell/license.hunspell
include/hunspell/phonet.hxx
include/hunspell/suggestmgr.hxx
include/hunspell/w_char.hxx
lib/libhunspell-1.2.a
lib/libhunspell-1.1.la
lib/libhunspell-1.2.so.0
lib/libhunspell-1.2.so
lib/pkgconfig/hunspell.pc
share/myspell/hu_HU.aff
share/myspell/hu_HU.dic
share/myspell/hungarian.aff

View File

@ -6,22 +6,27 @@
#
PORTNAME= hunspell
PORTVERSION= 1.2.2b
PORTREVISION= 1
PORTVERSION= 1.2.7
CATEGORIES= hungarian textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S@$@:code@:S@%SUBDIR%@${PORTNAME}@} \
${MASTER_SITE_SOURCEFORGE:S@$@:data@:S@%SUBDIR%@magyarispell@}
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:code hu_HU-${DICTVERSION}${EXTRACT_SUFX}:data
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:code \
hu_HU-${DICTVERSION}${EXTRACT_SUFX}:data
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Improved Hungarian spelling checker
COMMENT= Improved spell-checker for Hungarian and other languages
#EXTRACT_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
USE_GETTEXT= yes
USE_ICONV= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= "--with-ui"
CONFIGURE_ARGS= --with-ui --with-libintl-prefix=${PREFIX} --with-readline
CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LDFLAGS=-L${PREFIX}/lib
EXTRACT_AFTER_ARGS=|${TAR} -xpf - --exclude intl
ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
MAN1= hunspell.1
MAN4= hunspell.4
@ -31,13 +36,6 @@ PORTDOCS= README README.myspell
.include <bsd.port.pre.mk>
# Ugly workaround for FreeBSD versions before the import of NetBSD gzip.
#do-extract:
# @${RM} -rf ${WRKDIR}; \
# ${MKDIR} ${WRKDIR}; \
# cd ${WRKDIR} && ${TAR} -xzf ${_DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX};\
# ${UNZIP_CMD} -qo ${_DISTDIR}/hu_HU.zip -d ${WRKDIR}
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/src/tools/hunspell.cxx
@ -46,15 +44,18 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/man/hunspell.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/man/hunspell.4 ${PREFIX}/man/man4
${INSTALL_PROGRAM} ${WRKSRC}/src/tools/.libs/hunspell ${PREFIX}/bin
${MKDIR} ${PREFIX}/include/hunspell
${INSTALL_DATA} ${WRKSRC}/src/hunspell/*.h* ${PREFIX}/include/hunspell/
${INSTALL_DATA} ${WRKSRC}/src/hunspell/.libs/libhunspell-1.2.a ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/src/hunspell/.libs/libhunspell-1.2.lai ${PREFIX}/lib/libhunspell-1.1.la
${INSTALL_DATA} ${WRKSRC}/src/hunspell/.libs/libhunspell-1.2.so.0 ${PREFIX}/lib
${LN} -s ${LOCALBASE}/lib/libhunspell-1.2.so.0 ${PREFIX}/lib/libhunspell-1.2.so
${MKDIR} ${PREFIX}/share/myspell/ && \
${MKDIR} ${PREFIX}/share/myspell/
${INSTALL_DATA} ${WRKDIR}/hu_HU-${DICTVERSION}/hu_HU.dic \
${PREFIX}/share/myspell/ && \
${INSTALL_DATA} ${WRKDIR}/hu_HU-${DICTVERSION}/hu_HU.aff \
${PREFIX}/share/myspell/
${WRKDIR}/hu_HU-${DICTVERSION}/hu_HU.aff \
${PREFIX}/share/myspell/
${MKDIR} ${PREFIX}/lib/pkgconfig
${INSTALL_DATA} ${WRKSRC}/hunspell.pc ${PREFIX}/lib/pkgconfig
${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/magyar.dic
${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/hungarian.dic
${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/default.dic

View File

@ -1,6 +1,6 @@
MD5 (hunspell-1.2.2b.tar.gz) = 46aecfa635868f2618b204968f4bebd1
SHA256 (hunspell-1.2.2b.tar.gz) = 91a67974af4ee5cdfdcd0c0840009356aa3ce1b8d25820dc56c9a594684dad0e
SIZE (hunspell-1.2.2b.tar.gz) = 745643
MD5 (hunspell-1.2.7.tar.gz) = 9a4f345c3cfaeb8e6306285488a3127a
SHA256 (hunspell-1.2.7.tar.gz) = 37d0de21d39a28bcefdc0cb3f24fe8ea10992ff8752139a54807698ec2653046
SIZE (hunspell-1.2.7.tar.gz) = 782364
MD5 (hu_HU-1.3.tar.gz) = 498c47666414fcebdd328e3a5ae20e05
SHA256 (hu_HU-1.3.tar.gz) = 4f7d61e3f06d4cfb61aecbde457474a8f03b664a9500718d34015c253fff5a06
SIZE (hu_HU-1.3.tar.gz) = 1384493

View File

@ -1,11 +0,0 @@
--- src/parsers/latexparser.cxx.orig 2008-04-23 17:56:27.000000000 +0200
+++ src/parsers/latexparser.cxx 2008-04-23 17:57:00.000000000 +0200
@@ -82,7 +82,7 @@
{ { "\\url", NULL } , 1 }
};
-#define PATTERN_LEN (sizeof(PATTERN) / ((sizeof(char *) * 2) + sizeof(int)))
+#define PATTERN_LEN (sizeof(PATTERN) / sizeof(PATTERN[0]))
LaTeXParser::LaTeXParser(const char * wordchars)
{

View File

@ -1,16 +1,14 @@
$FreeBSD$
--- src/tools/hunspell.cxx.orig
+++ src/tools/hunspell.cxx
@@ -59,16 +59,12 @@
#include "manparser.hxx"
#include "firstparser.hxx"
-#define LIBDIR "/usr/share/hunspell:/usr/share/myspell"
+#define LIBDIR "%%PREFIX%%/share/hunspell:%%PREFIX%%/share/myspell"
#define USEROOODIR ".openoffice.org2/user/wordbook"
-#define OOODIR "/opt/openoffice.org2.3/share/dict/ooo:" \
--- src/tools/hunspell.cxx 2008-08-15 06:06:33.000000000 -0400
+++ src/tools/hunspell.cxx 2008-08-26 06:24:36.000000000 -0400
@@ -70,18 +70,12 @@
".openoffice.org2/user/wordbook:" \
".openoffice.org2.0/user/wordbook"
#define OOODIR \
- "/opt/openoffice.org/basis3.0/share/dict/ooo:" \
- "/usr/lib/openoffice.org/basis3.0/share/dict/ooo:" \
- "/opt/openoffice.org2.4/share/dict/ooo:" \
- "/usr/lib/openoffice.org2.4/share/dict/ooo:" \
- "/opt/openoffice.org2.3/share/dict/ooo:" \
- "/usr/lib/openoffice.org2.3/share/dict/ooo:" \
- "/opt/openoffice.org2.2/share/dict/ooo:" \
- "/usr/lib/openoffice.org2.2/share/dict/ooo:" \
@ -18,10 +16,12 @@ $FreeBSD$
- "/usr/lib/openoffice.org2.1/share/dict/ooo:" \
- "/opt/openoffice.org2.0/share/dict/ooo:" \
- "/usr/lib/openoffice.org2.0/share/dict/ooo"
+#define OOODIR "%%PREFIX%%/openoffice.org-2.3/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org-2.2/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org-2.1/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org2.0/share/dict/ooo"
+ "%%PREFIX%%/openoffice.org-DEV300_m29/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org-3.0.0.b2/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org-2.4/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org-2.2/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org-2.1/share/dict/ooo:" \
+ "%%PREFIX%%/openoffice.org2.0/share/dict/ooo"
#define HOME getenv("HOME")
#define DICBASENAME ".hunspell_"
#define LOGFILE "/tmp/hunspell.log"

View File

@ -0,0 +1,18 @@
--- configure 2008-08-14 05:53:13.000000000 -0400
+++ configure 2008-08-26 06:35:15.000000000 -0400
@@ -24576,5 +24576,5 @@
-ac_config_files="$ac_config_files Makefile hunspell.pc man/Makefile man/hu/Makefile intl/Makefile po/Makefile.in m4/Makefile src/Makefile src/hunspell/Makefile src/parsers/Makefile src/tools/Makefile src/win_api/Makefile tests/Makefile tests/suggestiontest/Makefile"
+ac_config_files="$ac_config_files Makefile hunspell.pc man/Makefile man/hu/Makefile po/Makefile.in m4/Makefile src/Makefile src/hunspell/Makefile src/parsers/Makefile src/tools/Makefile src/win_api/Makefile tests/Makefile tests/suggestiontest/Makefile"
cat >confcache <<\_ACEOF
--- Makefile.in 2008-08-14 05:53:15.000000000 -0400
+++ Makefile.in 2008-08-26 06:37:41.000000000 -0400
@@ -230,5 +230,5 @@
top_srcdir = @top_srcdir@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = intl po src man m4 tests
+SUBDIRS = po src man m4 tests
pkgconfdir = $(libdir)/pkgconfig
pkgconf_DATA = hunspell.pc

View File

@ -1,8 +1,26 @@
bin/hunspell
include/hunspell/affentry.hxx
include/hunspell/affixmgr.hxx
include/hunspell/atypes.hxx
include/hunspell/baseaffix.hxx
include/hunspell/csutil.hxx
include/hunspell/dictmgr.hxx
include/hunspell/filemgr.hxx
include/hunspell/hashmgr.hxx
include/hunspell/htypes.hxx
include/hunspell/hunspell.h
include/hunspell/hunspell.hxx
include/hunspell/hunzip.hxx
include/hunspell/langnum.hxx
include/hunspell/license.hunspell
include/hunspell/phonet.hxx
include/hunspell/suggestmgr.hxx
include/hunspell/w_char.hxx
lib/libhunspell-1.2.a
lib/libhunspell-1.1.la
lib/libhunspell-1.2.so.0
lib/libhunspell-1.2.so
lib/pkgconfig/hunspell.pc
share/myspell/hu_HU.aff
share/myspell/hu_HU.dic
share/myspell/hungarian.aff