Fix the gtk2 dnd implementation broken, see more details in the bugzilla. This
patch[1] was created by Matthias Clasen <mclasen@redhat.com>. This bug was started to reproduce with least 2.10.7 version of gtk2. PR: ports/107689 Reported by: a few users Bugzilla: https://bugzilla.mozilla.org/show_bug.cgi?id=355248 https://bugzilla.mozilla.org/show_bug.cgi?id=367203 [1] http://bugzilla.gnome.org/show_bug.cgi?id=394525
This commit is contained in:
parent
cf7f380693
commit
faa1047dd9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=182762
@ -8,6 +8,7 @@
|
||||
|
||||
PORTNAME= thunderbird
|
||||
DISTVERSION= 1.5.0.9
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= mail ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
|
||||
MASTER_SITE_SUBDIR= thunderbird/releases/${DISTVERSION}/source
|
||||
|
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
@ -8,6 +8,7 @@
|
||||
|
||||
PORTNAME= thunderbird
|
||||
DISTVERSION= 1.5.0.9
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= mail ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
|
||||
MASTER_SITE_SUBDIR= thunderbird/releases/${DISTVERSION}/source
|
||||
|
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
@ -8,6 +8,7 @@
|
||||
|
||||
PORTNAME= thunderbird
|
||||
DISTVERSION= 1.5.0.9
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= mail ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
|
||||
MASTER_SITE_SUBDIR= thunderbird/releases/${DISTVERSION}/source
|
||||
|
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= flock
|
||||
PORTVERSION= 3.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ftp://ftp.physics.purdue.edu/pub/pundits/ \
|
||||
http://archive.progeny.com/pundits/
|
||||
|
18
sysutils/flock/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
18
sysutils/flock/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
@ -4,9 +4,11 @@
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports-stable/www/firefox/Makefile,v 1.21 2006/10/25 01:20:12 ahze Exp $
|
||||
#
|
||||
|
||||
PORTNAME= firefox
|
||||
DISTVERSION= 2.0.0.1
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= www ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
|
||||
|
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
@ -4,9 +4,11 @@
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports-stable/www/firefox/Makefile,v 1.21 2006/10/25 01:20:12 ahze Exp $
|
||||
#
|
||||
|
||||
PORTNAME= firefox
|
||||
DISTVERSION= 2.0.0.1
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= www ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
|
||||
|
18
www/firefox/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
18
www/firefox/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
@ -4,10 +4,11 @@
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports-stable/www/firefox15/Makefile,v 1.21 2006/10/24 17:48:39 ahze Exp $
|
||||
#
|
||||
|
||||
PORTNAME= firefox
|
||||
DISTVERSION= 1.5.0.9
|
||||
PORTEPOCH= 2
|
||||
PORTEPOCH= 3
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}/source
|
||||
|
18
www/firefox15/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
18
www/firefox15/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
@ -4,9 +4,11 @@
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports-stable/www/firefox/Makefile,v 1.21 2006/10/25 01:20:12 ahze Exp $
|
||||
#
|
||||
|
||||
PORTNAME= firefox
|
||||
DISTVERSION= 2.0.0.1
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= www ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
|
||||
|
18
www/firefox36/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
18
www/firefox36/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
@ -4,10 +4,11 @@
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/www/nvu/Makefile,v 1.5 2006/07/18 15:07:36 ahze Exp $
|
||||
#
|
||||
|
||||
PORTNAME= nvu
|
||||
DISTVERSION= 1.0
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://cvs.nvu.com/download/
|
||||
DISTNAME= ${PORTNAME}-${DISTVERSION}-sources
|
||||
|
18
www/kompozer/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
18
www/kompozer/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
@ -4,10 +4,11 @@
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports-stable/www/mozilla/Makefile,v 1.15 2006/10/18 17:29:07 ahze Exp $
|
||||
#
|
||||
|
||||
PORTNAME= mozilla
|
||||
PORTVERSION= 1.7.13
|
||||
PORTREVISION?= 1
|
||||
PORTREVISION?= 2
|
||||
PORTEPOCH= 2
|
||||
CATEGORIES?= www
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
|
||||
|
18
www/mozilla/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
18
www/mozilla/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
@ -4,10 +4,11 @@
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/www/nvu/Makefile,v 1.5 2006/07/18 15:07:36 ahze Exp $
|
||||
#
|
||||
|
||||
PORTNAME= nvu
|
||||
DISTVERSION= 1.0
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://cvs.nvu.com/download/
|
||||
DISTNAME= ${PORTNAME}-${DISTVERSION}-sources
|
||||
|
18
www/nvu/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
18
www/nvu/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
@ -8,6 +8,7 @@
|
||||
|
||||
PORTNAME= seamonkey
|
||||
DISTVERSION= 1.0.7
|
||||
PORTREVISION= 1
|
||||
CATEGORIES?= www ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
|
||||
MASTER_SITE_SUBDIR= seamonkey/releases/${DISTVERSION}
|
||||
|
18
www/seamonkey/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
18
www/seamonkey/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
@ -8,6 +8,7 @@
|
||||
|
||||
PORTNAME= seamonkey
|
||||
DISTVERSION= 1.0.7
|
||||
PORTREVISION= 1
|
||||
CATEGORIES?= www ipv6
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
|
||||
MASTER_SITE_SUBDIR= seamonkey/releases/${DISTVERSION}
|
||||
|
18
www/seamonkey2/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
18
www/seamonkey2/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
@ -4,10 +4,11 @@
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/www/xulrunner/Makefile,v 1.13 2006/10/12 12:22:03 ahze Exp $
|
||||
#
|
||||
|
||||
PORTNAME= xulrunner
|
||||
PORTVERSION= 1.8.0.4
|
||||
PORTREVISION?= 5
|
||||
PORTREVISION?= 6
|
||||
CATEGORIES?= www devel
|
||||
MASTER_SITES= ${MASTER_SITE_MOZILLA}
|
||||
MASTER_SITE_SUBDIR= xulrunner/releases/${PORTVERSION}/source/
|
||||
|
18
www/xulrunner/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
18
www/xulrunner/files/patch-widget_src_gtk2_nsDragService.cpp
Normal file
@ -0,0 +1,18 @@
|
||||
--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
|
||||
+++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
|
||||
@@ -799,7 +799,6 @@
|
||||
void
|
||||
nsDragService::GetTargetDragData(GdkAtom aFlavor)
|
||||
{
|
||||
- gtk_grab_add(mHiddenWidget);
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
|
||||
mTargetWidget, mTargetDragContext));
|
||||
@@ -817,7 +816,6 @@
|
||||
gtk_main_iteration();
|
||||
}
|
||||
PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
|
||||
- gtk_grab_remove(mHiddenWidget);
|
||||
}
|
||||
|
||||
void
|
Loading…
Reference in New Issue
Block a user