- Update to 0.9.10 and drop FreeBSD 4.x support

- Install js_server
This commit is contained in:
Jean-Yves Lefort 2006-04-07 20:28:45 +00:00
parent 6b11bbcf2f
commit fa9a9cd603
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=159079
10 changed files with 15 additions and 173 deletions

View File

@ -7,8 +7,7 @@
PORTNAME?= FlightGear
PORTVERSION?= ${FGVERSION}
PORTREVISION= 1
PORTREVISION?= 1
PORTREVISION?= 0
CATEGORIES= games
MASTER_SITES+= ftp://ftp.flightgear.org/pub/fgfs/Source/:fg \
ftp://ftp.de.flightgear.org/pub/fgfs/Source/:fg
@ -25,11 +24,10 @@ RUN_DEPENDS= ${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${X11BASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear \
${X11BASE}/share/FlightGear/version:${PORTSDIR}/games/fgfs-base
FGVERSION= 0.9.9
FGVERSION= 0.9.10
USE_X_PREFIX= yes
USE_GL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@ -41,11 +39,18 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
.endif
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
IGNORE= does not build on FreeBSD 4.x
.endif
post-patch:
@${REINPLACE_CMD} -e 's|-D_REENTRANT|${PTHREAD_CFLAGS}|' \
${WRKSRC}/configure
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/utils/js_server/js_server ${PREFIX}/bin
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (FlightGear-0.9.9.tar.gz) = c1bff0cc9eda34f2a31ec9cd4e5216e6
SHA256 (FlightGear-0.9.9.tar.gz) = 46597145e087d116e479bf9048c06a0c84107ebda62420d783104831e4775c6a
SIZE (FlightGear-0.9.9.tar.gz) = 1771791
MD5 (FlightGear-0.9.10.tar.gz) = f4b89c9cafc18d56beab77a04f1ebdce
SHA256 (FlightGear-0.9.10.tar.gz) = 6307ad26e4141d27dcd66962f9c8e117206197a468b4f8bc99a6a31deb2e4992
SIZE (FlightGear-0.9.10.tar.gz) = 2072135

View File

@ -1,81 +0,0 @@
--- src/FDM/JSBSim/FGEngine.cpp.orig Sat May 7 15:55:16 2005
+++ src/FDM/JSBSim/FGEngine.cpp Sat May 7 15:57:56 2005
@@ -52,6 +52,7 @@
# include <fstream>
# endif
#endif
+#include <cstdio>
#include "FGEngine.h"
#include "FGTank.h"
--- src/FDM/JSBSim/FGFCS.cpp.orig Sat May 7 15:55:16 2005
+++ src/FDM/JSBSim/FGFCS.cpp Sat May 7 15:57:43 2005
@@ -36,6 +36,7 @@
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
INCLUDES
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%*/
+#include <cstdio>
#include "FGFCS.h"
#include "FGFDMExec.h"
--- src/FDM/JSBSim/FGNozzle.cpp.orig Sat May 7 15:55:16 2005
+++ src/FDM/JSBSim/FGNozzle.cpp Sat May 7 15:57:32 2005
@@ -36,6 +36,7 @@
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%*/
#include <sstream>
+#include <cstdio>
#include "FGNozzle.h"
#include "FGAtmosphere.h"
--- src/FDM/JSBSim/FGPropeller.cpp.orig Sat May 7 15:55:16 2005
+++ src/FDM/JSBSim/FGPropeller.cpp Sat May 7 15:57:23 2005
@@ -36,6 +36,7 @@
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%*/
#include <sstream>
+#include <cstdio>
#include "FGPropeller.h"
#include "FGPropagate.h"
--- src/FDM/JSBSim/FGState.cpp.orig Sat May 7 15:55:16 2005
+++ src/FDM/JSBSim/FGState.cpp Sat May 7 15:57:13 2005
@@ -51,6 +51,8 @@
//#define snprintf _snprintf
#endif
+#include <cstdio>
+
#include "FGState.h"
namespace JSBSim {
--- src/FDM/JSBSim/FGThruster.cpp.orig Sat May 7 15:55:16 2005
+++ src/FDM/JSBSim/FGThruster.cpp Sat May 7 15:56:47 2005
@@ -36,6 +36,7 @@
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%*/
#include <sstream>
+#include <cstdio>
#include "FGThruster.h"
--- src/FDM/JSBSim/FGTrim.cpp.orig Sat May 7 15:55:16 2005
+++ src/FDM/JSBSim/FGTrim.cpp Sat May 7 15:56:25 2005
@@ -45,6 +45,7 @@
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%*/
#include <stdlib.h>
+#include <cstdio>
#include "FGFDMExec.h"
#include "FGAtmosphere.h"
--- src/FDM/JSBSim/FGTurbine.cpp.orig Sat May 7 15:55:16 2005
+++ src/FDM/JSBSim/FGTurbine.cpp Sat May 7 15:56:36 2005
@@ -41,6 +41,7 @@
#include <vector>
#include <sstream>
+#include <cstdio>
#include "FGTurbine.h"

View File

@ -1,10 +0,0 @@
--- src/Airports/simple.hxx.orig Sun Nov 20 18:54:27 2005
+++ src/Airports/simple.hxx Sun Nov 20 18:54:43 2005
@@ -36,6 +36,7 @@
#ifdef HAVE_CONFIG_H
# include <config.h>
#endif
+#include <time.h>
#include <simgear/math/point3d.hxx>
#include <simgear/route/waypoint.hxx>
#include <simgear/compiler.h>

View File

@ -1,20 +0,0 @@
--- src/Main/bootstrap.cxx.orig Thu Sep 15 20:48:39 2005
+++ src/Main/bootstrap.cxx Thu Sep 15 20:51:05 2005
@@ -28,6 +28,8 @@
#if defined(__linux__) && defined(__i386__)
# include <fpu_control.h>
# include <signal.h>
+#elif defined(__FreeBSD__)
+# include <signal.h>
#endif
#include <stdlib.h>
@@ -144,6 +146,8 @@
// Enable floating-point exceptions for Linux/x86
#if defined(__linux__) && defined(__i386__)
initFPE();
+#elif defined(__FreeBSD__)
+ signal(SIGFPE, SIG_IGN);
#endif
#if defined(sgi)

View File

@ -1,10 +0,0 @@
--- src/Main/metar_main.cxx.orig Sun Nov 20 19:38:38 2005
+++ src/Main/metar_main.cxx Sun Nov 20 19:39:05 2005
@@ -20,6 +20,7 @@
//
// $Id: metar_main.cxx,v 1.10 2005/10/25 16:28:46 ehofman Exp $
+#include <time.h>
#include <iomanip>
#include <sstream>
#include <string.h>

View File

@ -1,11 +0,0 @@
--- src/Main/renderer.cxx.orig Sun Nov 20 19:23:36 2005
+++ src/Main/renderer.cxx Sun Nov 20 19:28:43 2005
@@ -122,7 +122,7 @@
FGRenderer::FGRenderer()
{
#ifdef FG_JPEG_SERVER
- jpgRenderFrame = FGRenderer::update;
+ jpgRenderFrame = &FGRenderer::update;
#endif
}

View File

@ -1,15 +0,0 @@
--- src/Network/ATC-Inputs.cxx.orig Sun Nov 20 19:02:57 2005
+++ src/Network/ATC-Inputs.cxx Sun Nov 20 19:05:33 2005
@@ -32,7 +32,11 @@
# include <sys/stat.h>
# include <fcntl.h>
# include <unistd.h>
-# include <istream>
+# ifdef SG_HAVE_STD_INCLUDES
+# include <istream>
+# else
+# include <istream.h>
+# endif
#endif
#include <errno.h>

View File

@ -1,18 +0,0 @@
--- src/Network/ATC-Outputs.cxx.orig Sun Nov 20 19:14:22 2005
+++ src/Network/ATC-Outputs.cxx Sun Nov 20 19:14:47 2005
@@ -32,7 +32,6 @@
# include <sys/stat.h>
# include <fcntl.h>
# include <unistd.h>
-# include <ostream>
#endif
#include <errno.h>
@@ -47,6 +46,7 @@
#include "ATC-Outputs.hxx"
+SG_USING_STD(ostream);
SG_USING_STD(string);

View File

@ -1,8 +1,10 @@
bin/al-info
bin/est-epsilon
bin/fgfs
bin/fgjs
bin/gl-info
bin/js_demo
bin/js_server
bin/metar
bin/terrasync
bin/yasim