net/pygopherd: modernize port

- Add LICENSE and LICENSE_FILE
- Remove unnecessary PYDISTUTILS_PKGVERSION
- Add NO_ARCH
- Regenerate patches with make makepatch
- Record TIMESTAMP in distinfo
- Fix pkg-plist
- Take maintainership
- Bump PORTREVISION

PR:		213539
Submitted by:	Neel Chauhan <neel@neelc.org>
Approved by:	koobs (mentor)
This commit is contained in:
Carlos J. Puga Medina 2016-10-28 00:03:30 +00:00
parent 5e705ff0d1
commit fa187b926d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=424797
7 changed files with 28 additions and 19 deletions

View File

@ -3,20 +3,24 @@
PORTNAME= pygopherd
PORTVERSION= 2.0.16
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= net python
MASTER_SITES= http://gopher.quux.org:70/devel/gopher/Downloads/pygopherd/ \
http://gopher.quux.org:70/devel/gopher/Downloads/pygopherd/old/
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
MAINTAINER= neel@neelc.org
COMMENT= Multiprotocol Information Server
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= python
USE_PYTHON= distutils
PYDISTUTILS_PKGVERSION= 2.0.15
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_ARCH= yes
post-patch:
.for f in setup.py bin/pygopherd conf/pygopherd.conf doc/pygopherd.8
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/${f}

View File

@ -1,2 +1,3 @@
TIMESTAMP = 1476825666
SHA256 (pygopherd_2.0.16.tar.gz) = d96ba235a4207aee94b1436ac084448d69ec7042e477a0649da8148bb044c729
SIZE (pygopherd_2.0.16.tar.gz) = 255475

View File

@ -1,6 +1,6 @@
--- bin/pygopherd.orig Sun Sep 8 02:58:15 2002
+++ bin/pygopherd Fri Aug 9 01:59:33 2002
@@ -24,7 +24,7 @@
--- bin/pygopherd.orig 2005-09-22 13:00:21 UTC
+++ bin/pygopherd
@@ -23,7 +23,7 @@
from pygopherd import *
import sys

View File

@ -1,6 +1,6 @@
--- conf/pygopherd.conf.orig Sun Sep 8 03:00:01 2002
+++ conf/pygopherd.conf Sun Sep 8 03:00:34 2002
@@ -119,7 +119,7 @@
--- conf/pygopherd.conf.orig 2006-09-11 14:10:13 UTC
+++ conf/pygopherd.conf
@@ -125,7 +125,7 @@ root = /var/gopher
# specify multiple files here -- just separate them with a colon.
# ALL of them that are found will be read.

View File

@ -1,6 +1,6 @@
--- doc/pygopherd.8.orig Sun Jan 18 02:26:38 2004
+++ doc/pygopherd.8 Sun Jan 18 02:29:01 2004
@@ -180,7 +180,7 @@
--- doc/pygopherd.8.orig 2005-09-22 13:00:21 UTC
+++ doc/pygopherd.8
@@ -180,7 +180,7 @@ distribution includes two files of inter
\fIconf/pygopherd.conf\fR and
\fIconf/mime.types\fR. Debian users will find
the configuration file pre-installed in
@ -9,7 +9,7 @@
\fImime.types\fR file provided by the system
already.
.PP
@@ -196,7 +196,7 @@
@@ -196,7 +196,7 @@ remaining ones should be fine for a basi
.PP
Invoke \fBPyGopherd\fR with \fBpygopherd
path/to/configfile\fR (or
@ -18,7 +18,7 @@
Place some files in the location specified by the
\fIroot\fR directive in the config file and
you're ready to run!
@@ -221,7 +221,7 @@
@@ -221,7 +221,7 @@ If you are not tracking Debian unstable,
package from the \fBPyGopherd\fR website and then run
\fBdpkg -i\fR to install the downloaded
package. Then, skip to the configuration section below.
@ -27,7 +27,7 @@
to start the program.
.SS "OTHER SYSTEM-WIDE INSTALLATION"
.PP
@@ -242,7 +242,7 @@
@@ -242,7 +242,7 @@ Some systems will use \fBpython\fR or
\fBpython2.2\fR.
.PP
Next, proceed to configuration. Make sure that the
@ -36,7 +36,7 @@
names valid users (\fIsetuid\fR and
\fIsetgid\fR options) and a valid document
root (\fIroot\fR option).
@@ -287,7 +287,7 @@
@@ -287,7 +287,7 @@ installation step necessary.
.SH "CONFIGURATION"
.PP
\fBPyGopherd\fR is regulated by a configuratoin file normally

View File

@ -1,6 +1,6 @@
--- setup.py.orig Sat Aug 23 16:31:00 2003
+++ setup.py Fri Dec 5 21:24:43 2003
@@ -33,7 +33,7 @@
--- setup.py.orig 2005-09-22 13:00:21 UTC
+++ setup.py
@@ -33,7 +33,7 @@ setup(name = "pygopherd",
url = pygopherd.version.homepage,
packages = ['pygopherd', 'pygopherd.handlers', 'pygopherd.protocols'],
scripts = ['bin/pygopherd'],

View File

@ -130,4 +130,8 @@ etc/pygopherd/mime.types
%%PYTHON_SITELIBDIR%%/pygopherd/zipfile.py
%%PYTHON_SITELIBDIR%%/pygopherd/zipfile.pyc
%%PYTHON_SITELIBDIR%%/pygopherd/zipfile.pyo
%%PYTHON_SITELIBDIR%%/pygopherd-2.0.15-py%%PYTHON_VER%%.egg-info/PKG-INFO
%%PYTHON_SITELIBDIR%%/pygopherd-2.0.15-py%%PYTHON_VER%%.egg-info/SOURCES.txt
%%PYTHON_SITELIBDIR%%/pygopherd-2.0.15-py%%PYTHON_VER%%.egg-info/dependency_links.txt
%%PYTHON_SITELIBDIR%%/pygopherd-2.0.15-py%%PYTHON_VER%%.egg-info/top_level.txt
man/man8/pygopherd.8.gz