New port pysol-sound-server. Despite its name, it's a rather generic

Python extension module that plays WAVs together with MP3 or MOD
background music.

PR:		16608
Submitted by:	Maxim Sobolev <sobomax@altavista.net>
This commit is contained in:
Thomas Gellekum 2000-03-07 11:39:46 +00:00
parent 66b16a684a
commit fa12a82534
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=26611
7 changed files with 46 additions and 0 deletions

View File

@ -56,6 +56,7 @@
SUBDIR += nspmod
SUBDIR += play
SUBDIR += playmidi
SUBDIR += pysol-sound-server
SUBDIR += radio
SUBDIR += raproxy
SUBDIR += replay

View File

@ -0,0 +1,22 @@
# New ports collection makefile for: pysol-sound-server
# Version required: 2.10
# Date created: 7 January 2000
# Whom: Maxim Sobolev
#
# $FreeBSD$
#
DISTNAME= pysol-sound-server-2.10
CATEGORIES= audio games
MASTER_SITES= http://wildsau.idv.uni-linz.ac.at/mfx/download/pysol/pysol-sound-server/
MAINTAINER= sobomax@altavista.net
LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl \
smpeg-0.3.0:${PORTSDIR}/graphics/smpeg
WRKSRC= ${WRKDIR}/${DISTNAME}/src
GNU_CONFIGURE= yes
CONFIGURE_ENV= X11BASE="${X11BASE}"
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (pysol-sound-server-2.10.tar.gz) = 65d3ec95166707fe9e97d863e038b245

View File

@ -0,0 +1,13 @@
--- configure.orig Tue Feb 1 01:08:47 2000
+++ configure Tue Feb 1 01:13:24 2000
@@ -5,8 +5,8 @@
SDL_CFLAGS=`$SDL_CONFIG --cflags`
SDL_LIBS=`$SDL_CONFIG --libs`
-SMPEG_CFLAGS=""
-SMPEG_LIBS="-lsmpeg"
+SMPEG_CFLAGS="-I""$X11BASE""/include"
+SMPEG_LIBS="-L""$X11BASE""/lib -lsmpeg"
sed -e "s|@SDL_VERSION@|$SDL_VERSION|g" -e "s|@SDL_CFLAGS@|$SDL_CFLAGS|g" -e "s|@SDL_LIBS@|$SDL_LIBS|g" -e "s|@SMPEG_CFLAGS@|$SMPEG_CFLAGS|g" -e "s|@SMPEG_LIBS@|$SMPEG_LIBS|g" < Setup.pre.in > Setup.in

View File

@ -0,0 +1 @@
Python extension module to play sounds and background music

View File

@ -0,0 +1,7 @@
A Python extension module that plays WAV samples together with MP3
or MOD background music.
- Maxim Sobolev
sobomax@altavista.net
WWW: http://pysol.tsx.org/

View File

@ -0,0 +1 @@
lib/python1.5/site-packages/pysolsoundservermodule.so