Import pipsecd, a tool for making IPsec tunnels.
PR: 13178 Submitted by: Patrick Bihan-Faou <patrick@mindstep.com>
This commit is contained in:
parent
790af7141e
commit
fa0c40ffbb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=20754
38
net/pipsecd/Makefile
Normal file
38
net/pipsecd/Makefile
Normal file
@ -0,0 +1,38 @@
|
||||
# New ports collection makefile for: pipsecd
|
||||
# Version required: 19990519
|
||||
# Date created: 16 Aug 1999
|
||||
# Whom: Patrick Bihan-Faou <patrick@mindstep.com>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= tunip
|
||||
PKGNAME= pipsecd-19990519
|
||||
CATEGORIES= net security
|
||||
MASTER_SITES= http://www.enst.fr/~beyssac/
|
||||
|
||||
MAINTAINER= patrick@mindstep.com
|
||||
|
||||
BUILD_DEPENDS= ${PREFIX}/lib/libcrypto.a:${PORTSDIR}/security/openssl:install
|
||||
|
||||
ALL_TARGET= pipsecd
|
||||
|
||||
WRKSRC= ${WRKDIR}/pipsec-19990519
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/pipsecd ${PREFIX}/sbin
|
||||
${MKDIR} ${PREFIX}/etc/ipsec
|
||||
${INSTALL_DATA} ${WRKSRC}/pipsecd.conf.sample ${PREFIX}/etc/ipsec
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/pipsecd
|
||||
${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/pipsecd
|
||||
${INSTALL_MAN} ${WRKSRC}/COPYRIGHT ${PREFIX}/share/doc/pipsecd
|
||||
${INSTALL_MAN} ${WRKSRC}/README.port ${PREFIX}/share/doc/pipsecd
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
strip ${PREFIX}/sbin/pipsecd
|
||||
|
||||
.include <bsd.port.post.mk>
|
1
net/pipsecd/distinfo
Normal file
1
net/pipsecd/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (tunip.tar.gz) = 7dff992e614bd61a007e362d47c9a66a
|
26
net/pipsecd/files/patch-aa
Normal file
26
net/pipsecd/files/patch-aa
Normal file
@ -0,0 +1,26 @@
|
||||
--- Makefile.orig Mon Aug 16 11:51:13 1999
|
||||
+++ Makefile Mon Aug 16 12:28:08 1999
|
||||
@@ -6,17 +6,20 @@
|
||||
CLEANFILES= *.core *.o pipsecd
|
||||
|
||||
# Where your OpenSSL includes are located
|
||||
-INCDIR=/usr/local/ssl/include
|
||||
+INCDIR=-I$(PREFIX)/include -I$(PREFIX)/include/openssl
|
||||
|
||||
# Where your libcrypto is located
|
||||
-LIBDIR=/usr/local/ssl/lib
|
||||
+LIBDIR=-L$(PREFIX)/lib
|
||||
+
|
||||
+# Misc Defines
|
||||
+DEFINES=-DFILE_PREFIX=\"$(PREFIX)\"
|
||||
|
||||
# Optional (to use FreeBSD's libmd)
|
||||
#OPTLIB= -lmd
|
||||
#OPTDEF= -DUSE_SYSTEM_HASH
|
||||
|
||||
pipsecd: tunip.c defs.h
|
||||
- gcc -Wall -I$(INCDIR) -g -o $(OPTDEF) pipsecd tunip.c -L$(LIBDIR) $(OPTLIB) -lcrypto
|
||||
+ gcc -Wall $(INCDIR) -g -o $(OPTDEF) pipsecd tunip.c $(LIBDIR) $(OPTLIB) -lcrypto $(DEFINES)
|
||||
|
||||
install: pipsecd
|
||||
install pipsecd /usr/local/sbin/
|
13
net/pipsecd/files/patch-ab
Normal file
13
net/pipsecd/files/patch-ab
Normal file
@ -0,0 +1,13 @@
|
||||
--- tunip.c.orig Mon Aug 16 11:54:50 1999
|
||||
+++ tunip.c Mon Aug 16 12:27:07 1999
|
||||
@@ -57,8 +57,8 @@
|
||||
|
||||
#include "defs.h"
|
||||
|
||||
-#define _PATH_CONF "/etc/ipsec/pipsecd.conf"
|
||||
-#define _PATH_STARTUP "/etc/ipsec/startup"
|
||||
+#define _PATH_CONF FILE_PREFIX "/etc/ipsec/pipsecd.conf"
|
||||
+#define _PATH_STARTUP FILE_PREFIX "/etc/ipsec/startup"
|
||||
#define _PATH_DEV_RANDOM "/dev/random"
|
||||
|
||||
#define MAX_HEADER 64
|
22
net/pipsecd/files/patch-ac
Normal file
22
net/pipsecd/files/patch-ac
Normal file
@ -0,0 +1,22 @@
|
||||
--- README.port.orig Mon Aug 16 12:58:09 1999
|
||||
+++ README.port Mon Aug 16 13:03:28 1999
|
||||
@@ -0,0 +1,19 @@
|
||||
+This is the ported version of the pipsecd program
|
||||
+from Pierre Beyssac at the ENST.
|
||||
+
|
||||
+The main difference with the original code are:
|
||||
+- it compiles with OpenSSL-0.94
|
||||
+- config files are in /usr/local/etc/ipsec
|
||||
+
|
||||
+
|
||||
+Apart from that it works exactly as the original work from
|
||||
+Pierre Beyssac.
|
||||
+
|
||||
+You can obtain the source distribution of pipsecd at:
|
||||
+http://www.enst.fr/~beyssac/tunip.tar.gz
|
||||
+
|
||||
+Enjoy!
|
||||
+
|
||||
+Patrick Bihan-Faou - MindStep Corporation
|
||||
+patrick@mindstep.com - http://www.mindstep.com/
|
||||
+
|
1
net/pipsecd/pkg-comment
Normal file
1
net/pipsecd/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Simple IPSEC tunnel tool from Pierre Beyssac
|
7
net/pipsecd/pkg-descr
Normal file
7
net/pipsecd/pkg-descr
Normal file
@ -0,0 +1,7 @@
|
||||
This simple program lets you build a IPSec tunnel using
|
||||
the tun device.
|
||||
|
||||
You need to have the openSSL library for it.
|
||||
|
||||
- Patrick Bihan-Faou
|
||||
patrick@mindstep.com
|
19
net/pipsecd/pkg-message
Normal file
19
net/pipsecd/pkg-message
Normal file
@ -0,0 +1,19 @@
|
||||
This is the ported version of the pipsecd program
|
||||
from Pierre Beyssac at the ENST.
|
||||
|
||||
The main difference with the original code are:
|
||||
- it compiles with OpenSSL-0.94
|
||||
- config files are in /usr/local/etc/ipsec
|
||||
|
||||
|
||||
Apart from that it works exactly as the original work from
|
||||
Pierre Beyssac.
|
||||
|
||||
You can obtain the source distribution of pipsecd at:
|
||||
http://www.enst.fr/~beyssac/tunip.tar.gz
|
||||
|
||||
Enjoy!
|
||||
|
||||
Patrick Bihan-Faou - MindStep Corporation
|
||||
patrick@mindstep.com - http://www.mindstep.com/
|
||||
|
7
net/pipsecd/pkg-plist
Normal file
7
net/pipsecd/pkg-plist
Normal file
@ -0,0 +1,7 @@
|
||||
sbin/pipsecd
|
||||
etc/ipsec/pipsecd.conf.sample
|
||||
share/doc/pipsecd/README
|
||||
share/doc/pipsecd/COPYRIGHT
|
||||
share/doc/pipsecd/README.port
|
||||
@dirrm share/doc/pipsecd
|
||||
@dirrm etc/ipsec
|
Loading…
Reference in New Issue
Block a user