Update to 2.4.0

This commit is contained in:
Baptiste Daroussin 2020-08-31 09:48:17 +00:00
parent 2f8c40f4d8
commit f9f01f3211
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=547161
6 changed files with 15 additions and 81 deletions

View File

@ -2,27 +2,30 @@
# $FreeBSD$
PORTNAME= hypermail
PORTVERSION= 2.3.0
PORTREVISION= 2
PORTVERSION= 2.4.0
DISTVERSIONPREFIX= v
CATEGORIES= www mail
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Program to generate a cross-referenced HTML mail archive
LICENSE= GPLv2
LIB_DEPENDS+= libgdbm.so:databases/gdbm \
libpcre.so:devel/pcre
LIB_DEPENDS+= libpcre.so:devel/pcre \
libtrio.so:devel/trio
USES= desthack
USES= localbase iconv desthack
USE_GITHUB= yes
GH_ACCOUNT= hypermail-project
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-htmldir=${STAGEDIR}${PREFIX}/share/doc/hypermail \
--with-gdbm=${LOCALBASE}
--without-gdbm \
--with-external-pcre=${LOCALBASE}/bin/pcre-config \
--enable-system-libtrio
CFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ARGS= INSTALL_PROG=${INSTALL}
OPTIONS_DEFINE= DOCS

View File

@ -1,2 +1,3 @@
SHA256 (hypermail-2.3.0.tar.gz) = 619938b0cf54eae786f36ef237f106ef7bff7a5c69904ca32afd8d47bf1605d1
SIZE (hypermail-2.3.0.tar.gz) = 1280010
TIMESTAMP = 1598864487
SHA256 (hypermail-project-hypermail-v2.4.0_GH0.tar.gz) = e1d8b51d2c6129a2fbabd156d441f1133cca38cf50c7b26d4a760710df17e7d8
SIZE (hypermail-project-hypermail-v2.4.0_GH0.tar.gz) = 2964813

View File

@ -1,20 +0,0 @@
--- docs/Makefile.in.orig Thu Apr 10 15:31:21 2003
+++ docs/Makefile.in Thu Jan 8 00:25:29 2004
@@ -41,7 +41,9 @@
$(INSTALL_PROG) -c -m 0644 hmrc.4 $(mandir)/man4
install.html:
+.if !defined(NOPORTDOCS)
@(if [ ! -d $(htmldir) ]; then mkdir -p $(htmldir); fi)
+ @(if [ ! -d $(imagedir) ]; then mkdir -p $(imagedir); fi)
$(INSTALL_PROG) -c -m 0644 hr.yellow.png $(htmldir)
$(INSTALL_PROG) -c -m 0644 hypermail.png $(htmldir)
$(INSTALL_PROG) -c -m 0644 stars.png $(htmldir)
@@ -50,6 +52,7 @@
$(INSTALL_PROG) -c -m 0644 hypermail-faq.html $(htmldir)
$(INSTALL_PROG) -c -m 0644 customizing.html $(htmldir)
$(INSTALL_PROG) -c -m 0644 hmrc.html $(htmldir)
+.endif
clean:
clobber:

View File

@ -1,12 +0,0 @@
--- src/pcre/pcreposix.c.orig 2003-07-03 20:04:06.000000000 +0200
+++ src/pcre/pcreposix.c 2012-02-14 12:49:55.077985140 +0100
@@ -217,7 +217,8 @@
if (preg->re_pcre == NULL) return pcre_posix_error_code(errorptr);
-preg->re_nsub = pcre_info(preg->re_pcre, NULL, NULL);
+pcre_fullinfo((const pcre *)preg->re_pcre, NULL,
+ PCRE_INFO_CAPTURECOUNT, &(preg->re_nsub));
return 0;
}

View File

@ -1,27 +0,0 @@
--- src/pcre/pcretest.c.orig 2012-02-14 12:36:59.560983755 +0100
+++ src/pcre/pcretest.c 2012-02-14 12:45:15.056415687 +0100
@@ -748,24 +748,6 @@
new_info(re, NULL, PCRE_INFO_NAMECOUNT, &namecount);
new_info(re, NULL, PCRE_INFO_NAMETABLE, (void *)&nametable);
- old_count = pcre_info(re, &old_options, &old_first_char);
- if (count < 0) fprintf(outfile,
- "Error %d from pcre_info()\n", count);
- else
- {
- if (old_count != count) fprintf(outfile,
- "Count disagreement: pcre_fullinfo=%d pcre_info=%d\n", count,
- old_count);
-
- if (old_first_char != first_char) fprintf(outfile,
- "First char disagreement: pcre_fullinfo=%d pcre_info=%d\n",
- first_char, old_first_char);
-
- if (old_options != (int)get_options) fprintf(outfile,
- "Options disagreement: pcre_fullinfo=%ld pcre_info=%d\n",
- get_options, old_options);
- }
-
if (size != gotten_store) fprintf(outfile,
"Size disagreement: pcre_fullinfo=%d call to malloc for %d\n",
size, gotten_store);

View File

@ -1,11 +0,0 @@
--- src/proto.h.orig 2014-09-19 05:03:40.694275686 +0200
+++ src/proto.h 2014-09-19 05:03:48.494270677 +0200
@@ -104,7 +104,7 @@
char *PushString(struct Push *, const char *);
char *PushNString(struct Push *, const char *, int);
-char *strcasestr (const char *, const char *);
+// char *strcasestr (const char *, const char *);
char *strsav(const char *);
char *strreplace(char *, char *);
void strcpymax(char *, const char *, int);