Anyterm provides a terminal emulator on a Web page using Javascript and a

server daemon. The daemon typically runs behind an HTTP proxy; it forks a shell
and communicates with the script using XMLHTTP on port 80 or securely using
SSL. This provides you with shell access to your machine from almost any Web
browser, even when firewalls are in the way.

WWW: http://anyterm.org/

PR:		ports/140740
Submitted by:	Douglas Thrift
This commit is contained in:
Martin Wilke 2009-11-21 10:18:54 +00:00
parent edf39c3d39
commit f9c065abb9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=244585
9 changed files with 1358 additions and 0 deletions

View File

@ -12,6 +12,7 @@
SUBDIR += amphetadesk
SUBDIR += analog
SUBDIR += anyremote2html
SUBDIR += anyterm
SUBDIR += aolserver
SUBDIR += aolserver-xotcl
SUBDIR += apache-contrib

41
www/anyterm/Makefile Normal file
View File

@ -0,0 +1,41 @@
# New ports collection makefile for: anyterm
# Date created: 19 November 2009
# Whom: Douglas Thrift
#
# $FreeBSD$
#
PORTNAME= anyterm
PORTVERSION= 1.1.29
CATEGORIES= www
MASTER_SITES= http://anyterm.org/download/ \
http://apt.douglasthrift.net/files/${PORTNAME}/ \
http://code.douglasthrift.net/files/${PORTNAME}/
EXTRACT_SUFX= .tbz2
MAINTAINER= douglas@douglasthrift.net
COMMENT= A terminal emulator on a Web page
BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost-libs
MAN1= anytermd.1
USE_RC_SUBR= anytermd
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
ALL_TARGET= default_target
PLIST_FILES= sbin/anytermd
post-patch:
@${REINPLACE_CMD} -e 's|/private/etc/apache2|${FILESDIR}|' \
${WRKSRC}/scripts/mimetype.sh
@${REINPLACE_CMD} -e 's|^CPP_FLAGS=|&-I${LOCALBASE}/include |' \
-e 's|^LINK_FLAGS=|&-L${LOCALBASE}/lib |' ${WRKSRC}/common.mk
@${REINPLACE_CMD} -e 's|^COMPILE_FLAGS=|&-I${LOCALBASE}/include |' \
${WRKSRC}/libpbe/common.mk
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/anytermd ${PREFIX}/sbin/anytermd
@${INSTALL_MAN} ${WRKSRC}/anytermd.1 ${MANPREFIX}/man/man1/anytermd.1
.include <bsd.port.mk>

3
www/anyterm/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (anyterm-1.1.29.tbz2) = 84fe7f3b4f516815901d1f545e79f13d
SHA256 (anyterm-1.1.29.tbz2) = 6e7710cf2240cb4eced295bdf17de4b6ce223c7fe4d1668260a6d60a8aec9846
SIZE (anyterm-1.1.29.tbz2) = 178424

View File

@ -0,0 +1,38 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: anytermd
# REQUIRE: NETWORKING DAEMON LOGIN cleanvar devfs
# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf to enable anytermd:
#
# anytermd_enable (bool): Set to "NO" by default.
# Set it to "YES" to enable anytermd.
#
# anytermd_flags (str): Set to "-c /usr/bin/login -u nobody --local-only"
# by default. See anytermd(1) for flags.
#
# anytermd_name (str): Set to "anyterm" by default.
#
. %%RC_SUBR%%
name=anytermd
rcvar=`set_rcvar`
load_rc_config $name
# Set defaults
: ${anytermd_enable:="NO"}
: ${anytermd_flags:="-c /usr/bin/login -u nobody --local-only"}
: ${anytermd_name:="anyterm"}
pidfile=/var/run/$anytermd_name.pid
command=%%PREFIX%%/sbin/$name
command_args="$anytermd_flags --name $anytermd_name"
run_rc_command "$1"

1236
www/anyterm/files/mime.types Normal file

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,11 @@
--- common.mk.orig 2009-11-20 00:32:31.545770710 -0800
+++ common.mk 2009-11-20 00:32:51.669545361 -0800
@@ -51,7 +51,7 @@
LINK_FLAGS=${GCC_FLAGS} ${DEBUG_FLAGS} \
-lutil
-ifeq (${UNAME_S},OpenBSD)
+ifeq (${UNAME_S},FreeBSD)
LINK_FLAGS+=-liconv
endif

View File

@ -0,0 +1,11 @@
--- libpbe/src/format.cc.orig 2009-11-20 00:12:52.878597868 -0800
+++ libpbe/src/format.cc 2009-11-20 00:13:07.402710981 -0800
@@ -21,7 +21,7 @@
#include <string>
#include <cstdarg>
#include <cstdio>
-#include <malloc.h>
+#include <stdlib.h>
namespace pbe {

View File

@ -0,0 +1,10 @@
--- src/SubProcess.cc.orig 2008-10-26 06:17:37.000000000 -0700
+++ src/SubProcess.cc 2009-11-19 23:58:03.399815119 -0800
@@ -22,6 +22,7 @@
#if defined(__FreeBSD__)
#include <libutil.h>
#include <sys/ioctl.h>
+#include <termios.h>
#elif defined(__OpenBSD__)
#include <termios.h>
#include <util.h>

7
www/anyterm/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
Anyterm provides a terminal emulator on a Web page using Javascript and a
server daemon. The daemon typically runs behind an HTTP proxy; it forks a shell
and communicates with the script using XMLHTTP on port 80 or securely using
SSL. This provides you with shell access to your machine from almost any Web
browser, even when firewalls are in the way.
WWW: http://anyterm.org/